summaryrefslogtreecommitdiff
path: root/dev-ros/mavros
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/mavros
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/mavros')
-rw-r--r--dev-ros/mavros/Manifest4
-rw-r--r--dev-ros/mavros/mavros-0.19.0-r1.ebuild38
-rw-r--r--dev-ros/mavros/mavros-9999.ebuild38
-rw-r--r--dev-ros/mavros/metadata.xml11
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-ros/mavros/Manifest b/dev-ros/mavros/Manifest
new file mode 100644
index 000000000000..7ac88b09c118
--- /dev/null
+++ b/dev-ros/mavros/Manifest
@@ -0,0 +1,4 @@
+DIST mavros-0.19.0.tar.gz 219739 BLAKE2B 4e9a47fa4cdbf11b530bdc39a8048b1834689039af3005d30ffcc2b626651612db12ecc1929ecaf994c5a887224bcf2b0469d1e15ed5b353be4132fb0f523a96 SHA512 87b1b77505d3606196d609a016bcb89b3831e982f8352a13f69f5c2580f46ac603edb2d3c2ce4df5cdd1424172145b88d2b35d149c2be507eb0f23039e7e45a7
+EBUILD mavros-0.19.0-r1.ebuild 1056 BLAKE2B d2d3734548f83d2bc2c73b566ca75890a294019be39c36259688bda16ccee5fca7490dc89bf74966b78e2b35ccd7f416f9d405d6ba81018962670f20bd83e0f3 SHA512 0cf2c358d76fa7d95590b88292286829b9290bbc7961cc68eb7dd2bbf11e0d33aff8266b4d69215d0c13eeb6470111da1d7e3d42d34d8f7a9178bef3d0ec5da0
+EBUILD mavros-9999.ebuild 1056 BLAKE2B d2d3734548f83d2bc2c73b566ca75890a294019be39c36259688bda16ccee5fca7490dc89bf74966b78e2b35ccd7f416f9d405d6ba81018962670f20bd83e0f3 SHA512 0cf2c358d76fa7d95590b88292286829b9290bbc7961cc68eb7dd2bbf11e0d33aff8266b4d69215d0c13eeb6470111da1d7e3d42d34d8f7a9178bef3d0ec5da0
+MISC metadata.xml 328 BLAKE2B d7ed4dde907bc9dd5533e4a54e90939df954d6af2c0fac66156b21309508546a4eccf8ebaef5d70e42a30ec99091f6cadd52b90199e65e05bcf8fe92069d2ab7 SHA512 a4d2ca220b3dea64853e31e188202fdde1e3533d50659e8c5b8593a1067bf88dcd7f6881e8691f91c99d8502e8739ffa13c5bcead139763109ff304736328b2e
diff --git a/dev-ros/mavros/mavros-0.19.0-r1.ebuild b/dev-ros/mavros/mavros-0.19.0-r1.ebuild
new file mode 100644
index 000000000000..ca3cb535a01a
--- /dev/null
+++ b/dev-ros/mavros/mavros-0.19.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/mavlink/mavros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="MAVLink extendable communication node for ROS"
+LICENSE="GPL-3 LGPL-3 BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_updater
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/angles
+ dev-ros/libmavconn
+ dev-ros/rosconsole_bridge
+ dev-libs/boost:=
+ dev-ros/eigen_conversions
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/mavros_msgs-${PV}[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/mavlink-gbp-release-2016.11.11
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/mavros/mavros-9999.ebuild b/dev-ros/mavros/mavros-9999.ebuild
new file mode 100644
index 000000000000..ca3cb535a01a
--- /dev/null
+++ b/dev-ros/mavros/mavros-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/mavlink/mavros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="MAVLink extendable communication node for ROS"
+LICENSE="GPL-3 LGPL-3 BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_updater
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/angles
+ dev-ros/libmavconn
+ dev-ros/rosconsole_bridge
+ dev-libs/boost:=
+ dev-ros/eigen_conversions
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/mavros_msgs-${PV}[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/mavlink-gbp-release-2016.11.11
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/mavros/metadata.xml b/dev-ros/mavros/metadata.xml
new file mode 100644
index 000000000000..769989122d7c
--- /dev/null
+++ b/dev-ros/mavros/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mavlink/mavros</remote-id>
+ </upstream>
+</pkgmetadata>