summaryrefslogtreecommitdiff
path: root/dev-ros/map_msgs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/map_msgs
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/map_msgs')
-rw-r--r--dev-ros/map_msgs/Manifest5
-rw-r--r--dev-ros/map_msgs/map_msgs-1.13.0.ebuild20
-rw-r--r--dev-ros/map_msgs/map_msgs-9999.ebuild20
-rw-r--r--dev-ros/map_msgs/metadata.xml11
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-ros/map_msgs/Manifest b/dev-ros/map_msgs/Manifest
new file mode 100644
index 000000000000..8a089cb5830f
--- /dev/null
+++ b/dev-ros/map_msgs/Manifest
@@ -0,0 +1,5 @@
+DIST navigation_msgs-1.13.0.tar.gz 2251 SHA256 09bba8fb7a60135183830dec4381cd3187244794aab9759ac50bbc6007e04a61 SHA512 e7b4a83bbbd5384f72d1a9d7e3544cde718728ba2a2562b3c0da5b5fd7db146faf8c717d4af2509eaf1ff545ac85da121f7e37cb7b6b53c8a5b8d683c6b4e66c WHIRLPOOL 43284659576fd06fd15db50ad38ab98160e60d594ba9306cba209b9a789c6895a5e00744126a683ffdeedfd177891b0e38a01b69cf72f4445f80ff6126497cc3
+EBUILD map_msgs-1.13.0.ebuild 522 SHA256 5d55a471faae598d0e824117bd9b46f02f455a2fe2b806571e4bab5b615ded60 SHA512 5ddc4916b82ca66fde51b1042f7f0a09c773c85b21d8a19c1b274e3b28603dd54108b6b4f00a9ef729e96edc7c5fdb0fc18347b3ed96c2325abb5dd0f0368934 WHIRLPOOL 96c62c51b1d79fa1ccef652cedb646e67125e90e92bcc6e3e0d90e7c93f05f41a2ee68ed653842f9f7ed544c2ede09441bbb233ed6b498fa71b03839d005e41e
+EBUILD map_msgs-9999.ebuild 522 SHA256 5d55a471faae598d0e824117bd9b46f02f455a2fe2b806571e4bab5b615ded60 SHA512 5ddc4916b82ca66fde51b1042f7f0a09c773c85b21d8a19c1b274e3b28603dd54108b6b4f00a9ef729e96edc7c5fdb0fc18347b3ed96c2325abb5dd0f0368934 WHIRLPOOL 96c62c51b1d79fa1ccef652cedb646e67125e90e92bcc6e3e0d90e7c93f05f41a2ee68ed653842f9f7ed544c2ede09441bbb233ed6b498fa71b03839d005e41e
+MISC ChangeLog 1438 SHA256 803d2957a029d26032d0f0d3ad3f1f28c5c56e7d996657b767d40861def5861f SHA512 6f5c7eab163095c597c3a16b8d97e28a731af500c08b3382108358bc27cc5c164cfb76cca38254150960422cc2a626275a4edd8c76da331331e03aa88a7116e2 WHIRLPOOL e3daf44962968ab58e6873ee1f7c9e14d104a52fcd09b87834766c07c13368b010e4726f2c78858a25b12b15c7913daf94191ffce6f548814f46b11766ffa2b5
+MISC metadata.xml 342 SHA256 111c4ade02c5bb338ca23d3caa6395f7b199d0de2199aacb90a53d6d850d9712 SHA512 6b28c6c3ff5f68ebfe8ba768c80ebc61c054453fde126fc64aa406e69fdf2f3174031930b8830144ba25401354df016f8179ab3d16c50d339b486a13421dd684 WHIRLPOOL f1d52bb2165e0aacf327a845ba8f406cabfa9af97862ecbc7607bd54ab43c07b00a808a0c6fb5f6e7c2da65af43ed6c2cfa11c1f85592613740e0ca6df1c8e49
diff --git a/dev-ros/map_msgs/map_msgs-1.13.0.ebuild b/dev-ros/map_msgs/map_msgs-1.13.0.ebuild
new file mode 100644
index 000000000000..55baaa5fe494
--- /dev/null
+++ b/dev-ros/map_msgs/map_msgs-1.13.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation_msgs"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/sensor_msgs dev-ros/nav_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages commonly used in mapping packages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/map_msgs/map_msgs-9999.ebuild b/dev-ros/map_msgs/map_msgs-9999.ebuild
new file mode 100644
index 000000000000..55baaa5fe494
--- /dev/null
+++ b/dev-ros/map_msgs/map_msgs-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation_msgs"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/sensor_msgs dev-ros/nav_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages commonly used in mapping packages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/map_msgs/metadata.xml b/dev-ros/map_msgs/metadata.xml
new file mode 100644
index 000000000000..8279667632da
--- /dev/null
+++ b/dev-ros/map_msgs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-planning/navigation_msgs</remote-id>
+ </upstream>
+</pkgmetadata>