summaryrefslogtreecommitdiff
path: root/dev-ros/interval_intersection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/interval_intersection
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/interval_intersection')
-rw-r--r--dev-ros/interval_intersection/Manifest5
-rw-r--r--dev-ros/interval_intersection/files/gcc6.patch31
-rw-r--r--dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild30
-rw-r--r--dev-ros/interval_intersection/interval_intersection-9999.ebuild29
-rw-r--r--dev-ros/interval_intersection/metadata.xml11
5 files changed, 106 insertions, 0 deletions
diff --git a/dev-ros/interval_intersection/Manifest b/dev-ros/interval_intersection/Manifest
new file mode 100644
index 000000000000..12e87b86a649
--- /dev/null
+++ b/dev-ros/interval_intersection/Manifest
@@ -0,0 +1,5 @@
+AUX gcc6.patch 1465 BLAKE2B e66648e673f2e80f2033171615a829772ad33c3d382da15ae73195510c1e5f4e5cc11793c87d5619443189d582401d32eaa4e96419b2d678d73b10ff4dffae81 SHA512 b2f5d80bce8c15b9636a57c56a83dc1b7f57463fe398b67436584e9790e6548b600c92b2921c624c3eafb590565db7eb17518b748dfd8d2bb440501e9e2c885d
+DIST calibration-0.10.14.tar.gz 112475 BLAKE2B a43bf316b3eea30f5f3e273e0dd2754fe819a1aa246237cb1ecc4bc49463abbd3eb71f77579fc0655c483ad9ac259bb027ac014fc5ec368a73bada61dedf6712 SHA512 5ef17cd21e04c134717859ecb12c4e7fc0086b044cf7d35d40bd43439a0f24e8ad41fe7b5fa37dcc8ec5e4abb2be8f64d86510706a3d97510cf1b92c2196ad40
+EBUILD interval_intersection-0.10.14.ebuild 799 BLAKE2B f47aa7e6158befa4e67c3e3e0852f83b1115ba4f9c6ff93f5fde97c2375cc941f40b1f6d6420fb33c999f2ad2979ad03c6d686e3c3167b8598b5becc5607eb92 SHA512 bc7c81d318fc6d7d0c4534721837f8909472c3c0f959c777b612da39af43791688ee3987e69bacb2cef7e8b2484f270e01f21be92baaf23070196aa39892dc0d
+EBUILD interval_intersection-9999.ebuild 762 BLAKE2B 29ee105746802b9b5297a62eec1d51edcd04bf99d459febd1848a81ee83b92bded8e56ca93335f6bc6f83381c40cf55f6750e8022358f36f1e6026a52b7c26fe SHA512 7d677353eeb5f99337aad8f0d8606ffe557d52b08874707bdeb8084fe8ae13fbe3844a21edd06bd39c339ac8ab7354de0b7397cfe07c0d4f1c3924a3941922cb
+MISC metadata.xml 340 BLAKE2B 52b47839e0051b2f1813313ae3989819be9668c093763a9c9518302d5b5832142fd02e6c7427493411d2b3ad3143d41180aa1c0f890362b43258109fc5b858b3 SHA512 de7b08cf3292d6c46f7a6e954ece0a32c8e2f4d67bc5212ce755662b8abf50425d54c00e0601ba943a4a9835f32c3df63ef87d5655788510ed86f05dd485a963
diff --git a/dev-ros/interval_intersection/files/gcc6.patch b/dev-ros/interval_intersection/files/gcc6.patch
new file mode 100644
index 000000000000..632383629f66
--- /dev/null
+++ b/dev-ros/interval_intersection/files/gcc6.patch
@@ -0,0 +1,31 @@
+commit c23ddb86367fc43c2d15e08a452ad2dc1a62041b
+Author: Hodorgasm <nsane457@gmail.com>
+Date: Mon Sep 19 19:11:57 2016 -0400
+
+ Fix "stdlib.h: No such file or directory" errors in GCC-6
+
+ Including '-isystem /usr/include' breaks building with GCC-6.
+ See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129
+
+diff --git a/interval_intersection/CMakeLists.txt b/interval_intersection/CMakeLists.txt
+index 9bfd103..73bc0ac 100644
+--- a/interval_intersection/CMakeLists.txt
++++ b/interval_intersection/CMakeLists.txt
+@@ -4,7 +4,7 @@ project(interval_intersection)
+ find_package(Boost REQUIRED thread)
+ find_package(catkin REQUIRED actionlib actionlib_msgs calibration_msgs geometry_msgs rosconsole roscpp roscpp_serialization rostime std_msgs)
+
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS})
++include_directories(${catkin_INCLUDE_DIRS})
+ include_directories(include)
+
+ # generate the messages
+@@ -35,7 +35,7 @@ add_executable(interval_intersection_node src/interval_intersection_node.cpp)
+ target_link_libraries(interval_intersection_node ${PROJECT_NAME})
+ add_dependencies(interval_intersection_node calibration_msgs_gencpp)
+
+-include_directories(SYSTEM ${BOOST_INCLUDE_DIRS})
++include_directories(${BOOST_INCLUDE_DIRS})
+ add_executable(interval_intersection_action src/interval_intersection_action.cpp)
+ target_link_libraries(interval_intersection_action ${Boost_LIBRARIES}
+ ${catkin_LIBRARIES}
diff --git a/dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild b/dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild
new file mode 100644
index 000000000000..e814990288f3
--- /dev/null
+++ b/dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for calculating the intersection of interval messages coming in on several topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/actionlib
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/roscpp_serialization
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/gcc6.patch" )
diff --git a/dev-ros/interval_intersection/interval_intersection-9999.ebuild b/dev-ros/interval_intersection/interval_intersection-9999.ebuild
new file mode 100644
index 000000000000..bf87d040c0f6
--- /dev/null
+++ b/dev-ros/interval_intersection/interval_intersection-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for calculating the intersection of interval messages coming in on several topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/actionlib
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/roscpp_serialization
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
diff --git a/dev-ros/interval_intersection/metadata.xml b/dev-ros/interval_intersection/metadata.xml
new file mode 100644
index 000000000000..660014a7883d
--- /dev/null
+++ b/dev-ros/interval_intersection/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-perception/calibration</remote-id>
+ </upstream>
+</pkgmetadata>