summaryrefslogtreecommitdiff
path: root/dev-ros/hardware_interface/hardware_interface-0.19.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ros/hardware_interface/hardware_interface-0.19.3.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ros/hardware_interface/hardware_interface-0.19.3.ebuild')
-rw-r--r--dev-ros/hardware_interface/hardware_interface-0.19.3.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-ros/hardware_interface/hardware_interface-0.19.3.ebuild b/dev-ros/hardware_interface/hardware_interface-0.19.3.ebuild
new file mode 100644
index 000000000000..534f5a3f8d25
--- /dev/null
+++ b/dev-ros/hardware_interface/hardware_interface-0.19.3.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-controls/ros_control"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Hardware Interface base class"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/roscpp"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-ros/rostest )"