summaryrefslogtreecommitdiff
path: root/dev-ros/gennodejs/gennodejs-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/gennodejs/gennodejs-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/gennodejs/gennodejs-9999.ebuild')
-rw-r--r--dev-ros/gennodejs/gennodejs-9999.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ros/gennodejs/gennodejs-9999.ebuild b/dev-ros/gennodejs/gennodejs-9999.ebuild
new file mode 100644
index 000000000000..025485282d83
--- /dev/null
+++ b/dev-ros/gennodejs/gennodejs-9999.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/RethinkRobotics-opensource/gennodejs"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="Javascript ROS message and service generators"
+HOMEPAGE="http://wiki.ros.org/gennodejs"
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"