summaryrefslogtreecommitdiff
path: root/dev-ros/genlisp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/genlisp
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/genlisp')
-rw-r--r--dev-ros/genlisp/Manifest5
-rw-r--r--dev-ros/genlisp/genlisp-0.4.16.ebuild18
-rw-r--r--dev-ros/genlisp/genlisp-9999.ebuild18
-rw-r--r--dev-ros/genlisp/metadata.xml11
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-ros/genlisp/Manifest b/dev-ros/genlisp/Manifest
new file mode 100644
index 000000000000..968c57df92be
--- /dev/null
+++ b/dev-ros/genlisp/Manifest
@@ -0,0 +1,5 @@
+DIST genlisp-0.4.16.tar.gz 10059 SHA256 31d3b86a0e3c0517b743a5c74dc3fe4a533ea22fdd1481b7432aa5f7b7800a0d SHA512 1cf180a337716f704d0e152a77049349aee9935273592b83aca64f3a9f926ed8775669114744ebf265dd09e70cf24af24e5c3e12a7bb3e7ecd90dc86f3cca3a6 WHIRLPOOL 0088ba1efd7b921662adf7b82994acf5cbd9a9f87202d200a5a6f3f620697da6b35985575533f1c7dec88a2c007bec8d4d358760bb57ecb9e2aae72ddbbe59d5
+EBUILD genlisp-0.4.16.ebuild 419 SHA256 4bac4c5b2050913384af7452afd505c51823dfe34688d4dad7af656e13ea3852 SHA512 6977ef6e12c2999617888846bd772162303bc60f83aaf64fee399e4aba05e0bb6679c06ae88ab564470ff0b77f9f6a5faea5f852f89b17e54e17263241c8f57a WHIRLPOOL 27b920844796494f2b922a5fc91963a7a5018e355c9abe68c90573e1b2f63f1cd2de5be382f29963e915af4de4dba6d35ab23b64fa26259c9f12b94d6a0b69e0
+EBUILD genlisp-9999.ebuild 419 SHA256 4bac4c5b2050913384af7452afd505c51823dfe34688d4dad7af656e13ea3852 SHA512 6977ef6e12c2999617888846bd772162303bc60f83aaf64fee399e4aba05e0bb6679c06ae88ab564470ff0b77f9f6a5faea5f852f89b17e54e17263241c8f57a WHIRLPOOL 27b920844796494f2b922a5fc91963a7a5018e355c9abe68c90573e1b2f63f1cd2de5be382f29963e915af4de4dba6d35ab23b64fa26259c9f12b94d6a0b69e0
+MISC ChangeLog 1826 SHA256 e7a3187ca1a7cb5392e60eeb425d0ca12a33b10ec2c8b71c3d6933386e21b061 SHA512 559bf2aa1face9221d7227fcfa5300a14ddc37b22c862ea2160b1185aa3fcf6c76344d4395c689d7fc62731b62626b4f079995c41a934f2f3f4e9a3865e5c0e5 WHIRLPOOL 29b4cb833100b1b54b2646e3fe852ea55254fe49463389ed1d00fd1213cb41165d27a9d42c52baab3dc40982c45954dda9f52be069c790f3e257ed0eeef4e94c
+MISC metadata.xml 325 SHA256 5f165f6db278cc2e992478766e65293dc29b2b5100f1329a63d3ce710a853650 SHA512 f1bda8492546d5a2cecaed684a06df6d41b1b1883cf1dba70dd51f88993a5466924394468d750fc5778bd1530b660e12c0d1e186f30530e5919c9a46a9382159 WHIRLPOOL 59a5bcad0f23aeac15dd48f82dc065bd1997f5e55073071e4ff5dbf4ea36f4d9a28ed5f822cfed230e181491cb036b7e0e42cf04739726c17825619d5d0ee6b1
diff --git a/dev-ros/genlisp/genlisp-0.4.16.ebuild b/dev-ros/genlisp/genlisp-0.4.16.ebuild
new file mode 100644
index 000000000000..74d8c84a356c
--- /dev/null
+++ b/dev-ros/genlisp/genlisp-0.4.16.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/genlisp"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="Common-Lisp ROS message and service generators"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/genlisp/genlisp-9999.ebuild b/dev-ros/genlisp/genlisp-9999.ebuild
new file mode 100644
index 000000000000..74d8c84a356c
--- /dev/null
+++ b/dev-ros/genlisp/genlisp-9999.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/genlisp"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="Common-Lisp ROS message and service generators"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/genlisp/metadata.xml b/dev-ros/genlisp/metadata.xml
new file mode 100644
index 000000000000..3fcc5a81490f
--- /dev/null
+++ b/dev-ros/genlisp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/genlisp</remote-id>
+ </upstream>
+</pkgmetadata>