summaryrefslogtreecommitdiff
path: root/dev-ros/gazebo_ros
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-ros/gazebo_ros
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-ros/gazebo_ros')
-rw-r--r--dev-ros/gazebo_ros/Manifest2
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-2.9.2.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/gazebo_ros/Manifest b/dev-ros/gazebo_ros/Manifest
index 2f3830cf9d48..63f15dcb1635 100644
--- a/dev-ros/gazebo_ros/Manifest
+++ b/dev-ros/gazebo_ros/Manifest
@@ -1,4 +1,6 @@
DIST gazebo_ros_pkgs-2.9.1.tar.gz 1861740 BLAKE2B 56569e73184c767abeea0ac6add8aa19bb70e66f3a41fe9fc5278e540759de945467372c7a0130acdb665924ab803defa22e148a36a624d08c39835dc110e208 SHA512 47510f97060d5434619948899b416a8136545b79cd112051543212abe8ce34a30c1f868c633a3f3288fd6c0ea775162daf2eea15ca539a352c9bdb55ee336b20
+DIST gazebo_ros_pkgs-2.9.2.tar.gz 1864333 BLAKE2B d8a777594624fe6ae38f1ae27ea49f9629a59f507ec5e8512f50dbf8ae551e6b171dd47eff308ab1badc4e07de7183fe512ff8179637169896f6cb1dbf3d50ba SHA512 38ca70b44a229d8ca87bf9cb2ed3e0eaf7855f5711a81891986a985b7ff4218cdd6c914c1d25352da47a3fb52a3df5638af36990264e5241d17bb43ae0fa6f0b
EBUILD gazebo_ros-2.9.1.ebuild 1085 BLAKE2B df33199d29c4f98b0bdcac64b8758ef8a70871560999833501f27802faa715e603a981c69c1366c34e3f8816ac4596a6b72c0f169c842fd7cd7887863d4e5333 SHA512 f1de76be96789c41356aaaea2d9d08885d2dc8bd001bf0f0dbffa9ab6243a7bec352609acafeb79e9c28536bf3d6adb9c1958c37e3eaf05713d3912c89d04b81
+EBUILD gazebo_ros-2.9.2.ebuild 1085 BLAKE2B 074927d8b4486a87f6151df4c71a744c763856d767a067d6cf55c2488d3ba75f543e0b8cf18a5dbb5b3bd74d212ca75a966ad2bcdc64533ced5240f38caa3e33 SHA512 8d81d71fcd443998d10f5a2d5f9ba5fe15c75a871e0fac8de2e1d1f06fed3432f4ca1523911de275b6f1d6e1c7cb9f5f0a8bb24540004d38341d96d10dad1df8
EBUILD gazebo_ros-9999.ebuild 1085 BLAKE2B df33199d29c4f98b0bdcac64b8758ef8a70871560999833501f27802faa715e603a981c69c1366c34e3f8816ac4596a6b72c0f169c842fd7cd7887863d4e5333 SHA512 f1de76be96789c41356aaaea2d9d08885d2dc8bd001bf0f0dbffa9ab6243a7bec352609acafeb79e9c28536bf3d6adb9c1958c37e3eaf05713d3912c89d04b81
MISC metadata.xml 344 BLAKE2B 673236d235252b8d24e90577c187252fe83ac05f87c29b123c3e064be9649efca3e8e23f0f60e2fd7a1d1b4f1c8c59dd6ae18bed904057f68c8a99c8c2e49fda SHA512 9b7223f95a007995d9a626aa653d2f0f8dc84364c325109fbd9b2f84f0359db12f2d2e3d16391f33364627082f52f8bac6b81c1992d64630bd70e476ce2c5d4d
diff --git a/dev-ros/gazebo_ros/gazebo_ros-2.9.2.ebuild b/dev-ros/gazebo_ros/gazebo_ros-2.9.2.ebuild
new file mode 100644
index 000000000000..f617eb50bd9b
--- /dev/null
+++ b/dev-ros/gazebo_ros/gazebo_ros-2.9.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS plugins that offer messages and services for interfacing with gazebo"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/gazebo_dev
+ dev-libs/tinyxml
+ sci-electronics/gazebo:=
+ dev-libs/protobuf:=
+ dev-ros/gazebo_plugins[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/dynamic_reconfigure
+ dev-libs/libxml2
+ dev-libs/boost:=[threads]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"