summaryrefslogtreecommitdiff
path: root/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/gazebo_ros/gazebo_ros-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/gazebo_ros/gazebo_ros-9999.ebuild')
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-9999.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild b/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild
index ca217b085352..40f612568195 100644
--- a/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild
+++ b/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild
@@ -1,16 +1,15 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
KEYWORDS="~amd64"
-PYTHON_COMPAT=( python2_7 )
CATKIN_HAS_MESSAGES=yes
ROS_SUBDIR=${PN}
inherit ros-catkin
-DESCRIPTION="ROS plugins that offer message and service publishers for interfacing with gazebo"
+DESCRIPTION="ROS plugins that offer messages and services for interfacing with gazebo"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
@@ -20,17 +19,20 @@ RDEPEND="
dev-libs/tinyxml
sci-electronics/gazebo:=
dev-libs/protobuf:=
- dev-ros/gazebo_plugins[${PYTHON_USEDEP}]
- dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/gazebo_plugins[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
dev-ros/roscpp
- dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/tf[${PYTHON_SINGLE_USEDEP}]
dev-ros/dynamic_reconfigure
dev-libs/libxml2
dev-libs/boost:=[threads]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/std_msgs
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
-DEPEND="${RDEPEND}"