summaryrefslogtreecommitdiff
path: root/dev-ros/diagnostic_updater/diagnostic_updater-1.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/diagnostic_updater/diagnostic_updater-1.9.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/diagnostic_updater/diagnostic_updater-1.9.0.ebuild')
-rw-r--r--dev-ros/diagnostic_updater/diagnostic_updater-1.9.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_updater/diagnostic_updater-1.9.0.ebuild b/dev-ros/diagnostic_updater/diagnostic_updater-1.9.0.ebuild
new file mode 100644
index 000000000000..f4bd878c1610
--- /dev/null
+++ b/dev-ros/diagnostic_updater/diagnostic_updater-1.9.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for updating diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-ros/rostest[${PYTHON_USEDEP}] )"