summaryrefslogtreecommitdiff
path: root/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild')
-rw-r--r--dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
new file mode 100644
index 000000000000..2e621e904b7b
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/depthimage_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a depth image to a laser scan for use with navigation and localization"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ media-libs/opencv:=
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/isnan.patch" "${FILESDIR}/pluginlib.patch" )