summaryrefslogtreecommitdiff
path: root/dev-ros/console_bridge_vendor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-ros/console_bridge_vendor
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-ros/console_bridge_vendor')
-rw-r--r--dev-ros/console_bridge_vendor/Manifest4
-rw-r--r--dev-ros/console_bridge_vendor/console_bridge_vendor-1.2.0.ebuild37
-rw-r--r--dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild37
-rw-r--r--dev-ros/console_bridge_vendor/metadata.xml11
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-ros/console_bridge_vendor/Manifest b/dev-ros/console_bridge_vendor/Manifest
new file mode 100644
index 000000000000..6822f30b7065
--- /dev/null
+++ b/dev-ros/console_bridge_vendor/Manifest
@@ -0,0 +1,4 @@
+DIST console_bridge_vendor-1.2.0.tar.gz 5640 BLAKE2B d0a2b18c8d4b9259e6c8ba2953a7650e9aaef348345c5651b5a769ec9c2d4346e404688d7e6c60c3c45186d0afa0e3d3a6d9e49baef2ef1da4e0679aa7d5ba06 SHA512 2b5c8ab47554d724665184ae4dfea32a6291d9d2578a489eb81e695cc513c723e934c1dca0e66eaf83b81d656fbc67a4c7e3b4d15eae5d8770ad6ebc700b6d6b
+EBUILD console_bridge_vendor-1.2.0.ebuild 788 BLAKE2B 6013837d97ed10221e6334427df52649d7059c307734beb33908faabe1a60d5670a2c8d6ab0fee665da16805feb5d3acf81b12c9211f76c53587fcd476b6229e SHA512 0e9b0d8620cc81a127af63b4a6536c60b52d6c1cfa3a44148430dabe25cfe4b621ace5360cd18a875dcf087eac51c8020d0d6edd09c389ae89567cde341c9517
+EBUILD console_bridge_vendor-9999.ebuild 788 BLAKE2B 6013837d97ed10221e6334427df52649d7059c307734beb33908faabe1a60d5670a2c8d6ab0fee665da16805feb5d3acf81b12c9211f76c53587fcd476b6229e SHA512 0e9b0d8620cc81a127af63b4a6536c60b52d6c1cfa3a44148430dabe25cfe4b621ace5360cd18a875dcf087eac51c8020d0d6edd09c389ae89567cde341c9517
+MISC metadata.xml 340 BLAKE2B 870056bcba705aba636b787bab5b7418c318794f542a5e9ee3f165dc569e6e69b0e41ea54899150184f4ec5810398f3d2ae9fe33ffac64ddacfcba9b3c9e583f SHA512 7e652e5616c60cf5b77bd6f7a4b120ce26c35885426c87f9d22cc2963c9975f9423f1e2e88c795c55457d386b608ce783cb606a5b02dad1fd92a467373c34169
diff --git a/dev-ros/console_bridge_vendor/console_bridge_vendor-1.2.0.ebuild b/dev-ros/console_bridge_vendor/console_bridge_vendor-1.2.0.ebuild
new file mode 100644
index 000000000000..9d08355634bd
--- /dev/null
+++ b/dev-ros/console_bridge_vendor/console_bridge_vendor-1.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-any-r1
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ros2/console_bridge_vendor"
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/ros2/console_bridge_vendor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Wrapper around console_bridge"
+HOMEPAGE="https://github.com/ros2/console_bridge_vendor"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+ >=dev-libs/console_bridge-0.4.1
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
diff --git a/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild b/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
new file mode 100644
index 000000000000..9d08355634bd
--- /dev/null
+++ b/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-any-r1
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ros2/console_bridge_vendor"
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/ros2/console_bridge_vendor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Wrapper around console_bridge"
+HOMEPAGE="https://github.com/ros2/console_bridge_vendor"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+ >=dev-libs/console_bridge-0.4.1
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
diff --git a/dev-ros/console_bridge_vendor/metadata.xml b/dev-ros/console_bridge_vendor/metadata.xml
new file mode 100644
index 000000000000..aaf4c6a26a54
--- /dev/null
+++ b/dev-ros/console_bridge_vendor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros2/console_bridge_vendor</remote-id>
+ </upstream>
+</pkgmetadata>