summaryrefslogtreecommitdiff
path: root/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild')
-rw-r--r--dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild22
1 files changed, 17 insertions, 5 deletions
diff --git a/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild b/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
index 9d08355634bd..41ddf98ec4ba 100644
--- a/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
+++ b/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit cmake-utils python-any-r1
+inherit cmake python-any-r1
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
@@ -25,13 +25,25 @@ if [ "${PV#9999}" != "${PV}" ] ; then
else
KEYWORDS="~amd64"
fi
-IUSE=""
+IUSE="test"
DEPEND="
- >=dev-libs/console_bridge-0.4.1
+ >=dev-libs/console_bridge-1.0.1
"
RDEPEND="${DEPEND}"
BDEPEND="
$(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
+ test? ( dev-ros/ament_lint_auto )
${PYTHON_DEPS}
"
+
+python_check_deps() {
+ has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}