summaryrefslogtreecommitdiff
path: root/dev-ros/bondcpp/bondcpp-1.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
commita5332b59346f7cbf0fdbd148b54aa8a84aaf8190 (patch)
treee6d8d3589fcd01fbc3f1286185639163daa81424 /dev-ros/bondcpp/bondcpp-1.8.1.ebuild
parentfceeaf01a28ee71065cf3798b70b77d3bc4ef199 (diff)
gentoo resync : 10.11.2017
Diffstat (limited to 'dev-ros/bondcpp/bondcpp-1.8.1.ebuild')
-rw-r--r--dev-ros/bondcpp/bondcpp-1.8.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/bondcpp/bondcpp-1.8.1.ebuild b/dev-ros/bondcpp/bondcpp-1.8.1.ebuild
new file mode 100644
index 000000000000..123e756ecdab
--- /dev/null
+++ b/dev-ros/bondcpp/bondcpp-1.8.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ implementation of bond, a mechanism for checking when another process has terminated"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bond
+ dev-ros/cmake_modules
+ dev-ros/roscpp
+ dev-ros/smclib
+ dev-libs/boost:=
+ sys-apps/util-linux
+"
+DEPEND="${RDEPEND}"