summaryrefslogtreecommitdiff
path: root/dev-ros/base_local_planner/base_local_planner-1.16.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-ros/base_local_planner/base_local_planner-1.16.1.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-ros/base_local_planner/base_local_planner-1.16.1.ebuild')
-rw-r--r--dev-ros/base_local_planner/base_local_planner-1.16.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/base_local_planner/base_local_planner-1.16.1.ebuild b/dev-ros/base_local_planner/base_local_planner-1.16.1.ebuild
new file mode 100644
index 000000000000..459e749a5fbb
--- /dev/null
+++ b/dev-ros/base_local_planner/base_local_planner-1.16.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Trajectory Rollout and Dynamic Window approaches to local robot navigation on a plane"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/angles
+ >=dev-ros/costmap_2d-1.16
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-cpp/eigen:3
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ >=dev-ros/nav_core-1.16
+ dev-ros/pluginlib
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2_ros
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/voxel_grid
+ dev-libs/boost:=[threads]
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-cpp/gtest dev-ros/rosunit[${PYTHON_USEDEP}] )
+"