summaryrefslogtreecommitdiff
path: root/dev-qt/qtxml/qtxml-5.9.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-14 01:05:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-14 01:05:40 +0100
commit76cba73c47c8694e74377004634daca18f2d9c08 (patch)
tree468603ebdc189bcfae77696162761b3be936baea /dev-qt/qtxml/qtxml-5.9.5.ebuild
parent6957f5c65b02bba533954eabc0b62f5de36be206 (diff)
gentoo resync : 14.04.2018
Diffstat (limited to 'dev-qt/qtxml/qtxml-5.9.5.ebuild')
-rw-r--r--dev-qt/qtxml/qtxml-5.9.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-qt/qtxml/qtxml-5.9.5.ebuild b/dev-qt/qtxml/qtxml-5.9.5.ebuild
new file mode 100644
index 000000000000..b8568f5ed9a2
--- /dev/null
+++ b/dev-qt/qtxml/qtxml-5.9.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Implementation of SAX and DOM for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+"
+DEPEND="${RDEPEND}
+ test? ( ~dev-qt/qtnetwork-${PV} )
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/xml
+)
+
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :xml
+)