summaryrefslogtreecommitdiff
path: root/dev-qt/qtx11extras/qtx11extras-5.15.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
commitf616ce4660c92a3fcb4f05663c2ab47c9defa0c3 (patch)
tree66ba5228853030737ae2dd9c9894b96266213246 /dev-qt/qtx11extras/qtx11extras-5.15.7.ebuild
parent1bfb8c3d7e00e7ff828008510f5a7568c81d8889 (diff)
gentoo auto-resync : 30:11:2022 - 01:22:10
Diffstat (limited to 'dev-qt/qtx11extras/qtx11extras-5.15.7.ebuild')
-rw-r--r--dev-qt/qtx11extras/qtx11extras-5.15.7.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-qt/qtx11extras/qtx11extras-5.15.7.ebuild b/dev-qt/qtx11extras/qtx11extras-5.15.7.ebuild
new file mode 100644
index 000000000000..e1496666496e
--- /dev/null
+++ b/dev-qt/qtx11extras/qtx11extras-5.15.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt5-build
+
+DESCRIPTION="Linux/X11-specific support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*[X]
+"
+DEPEND="${RDEPEND}
+ test? ( =dev-qt/qtwidgets-${QT5_PV}* )
+"