summaryrefslogtreecommitdiff
path: root/dev-qt/qtx11extras/qtx11extras-5.12.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /dev-qt/qtx11extras/qtx11extras-5.12.1.ebuild
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'dev-qt/qtx11extras/qtx11extras-5.12.1.ebuild')
-rw-r--r--dev-qt/qtx11extras/qtx11extras-5.12.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-qt/qtx11extras/qtx11extras-5.12.1.ebuild b/dev-qt/qtx11extras/qtx11extras-5.12.1.ebuild
new file mode 100644
index 000000000000..6245a6cc5506
--- /dev/null
+++ b/dev-qt/qtx11extras/qtx11extras-5.12.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Linux/X11-specific support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}[xcb]
+"
+DEPEND="${RDEPEND}
+ test? ( ~dev-qt/qtwidgets-${PV} )
+"