summaryrefslogtreecommitdiff
path: root/dev-qt/qtwebchannel/qtwebchannel-6.7.0_rc.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-12 18:46:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-12 18:46:38 +0000
commitd71aca7673826d5f5fa93b43c7c8af3c1e023dc6 (patch)
tree82fd4c1459b4cdcb08680126fe8ea984e5534645 /dev-qt/qtwebchannel/qtwebchannel-6.7.0_rc.ebuild
parent0c97119fc8982c1a6f367de25542834e4dd6cda4 (diff)
gentoo auto-resync : 12:03:2024 - 18:46:38
Diffstat (limited to 'dev-qt/qtwebchannel/qtwebchannel-6.7.0_rc.ebuild')
-rw-r--r--dev-qt/qtwebchannel/qtwebchannel-6.7.0_rc.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-qt/qtwebchannel/qtwebchannel-6.7.0_rc.ebuild b/dev-qt/qtwebchannel/qtwebchannel-6.7.0_rc.ebuild
new file mode 100644
index 000000000000..196c658b4733
--- /dev/null
+++ b/dev-qt/qtwebchannel/qtwebchannel-6.7.0_rc.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Qt WebChannel"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm64 ~loong"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[concurrent]
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ has_version ">=dev-qt/qtdeclarative-${PV}:6" && #913692
+ local mycmakeargs=( $(cmake_use_find_package qml Qt6Qml) )
+
+ qt6-build_src_configure
+}