summaryrefslogtreecommitdiff
path: root/dev-qt/qtwayland/qtwayland-6.5.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-06 16:26:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-06 16:26:18 +0100
commit3221bf225fb68a31e281fcdbfde4cea0d576d946 (patch)
tree63e4f978840b705bebc18062b4d599ae75fd32e1 /dev-qt/qtwayland/qtwayland-6.5.9999.ebuild
parent64b277f858d171900cba8a53e675ef8c3ff893fc (diff)
gentoo auto-resync : 06:09:2023 - 16:26:18
Diffstat (limited to 'dev-qt/qtwayland/qtwayland-6.5.9999.ebuild')
-rw-r--r--dev-qt/qtwayland/qtwayland-6.5.9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-qt/qtwayland/qtwayland-6.5.9999.ebuild b/dev-qt/qtwayland/qtwayland-6.5.9999.ebuild
index 7319f5b43fd6..517bfcaf25e0 100644
--- a/dev-qt/qtwayland/qtwayland-6.5.9999.ebuild
+++ b/dev-qt/qtwayland/qtwayland-6.5.9999.ebuild
@@ -11,14 +11,16 @@ if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64"
fi
-IUSE="qml vulkan"
+IUSE="compositor qml vulkan"
RDEPEND="
dev-libs/wayland
~dev-qt/qtbase-${PV}:6[gui,opengl,vulkan=]
media-libs/libglvnd
x11-libs/libxkbcommon
- qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+ compositor? (
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+ )
"
DEPEND="
${RDEPEND}
@@ -38,6 +40,7 @@ CMAKE_SKIP_TESTS=(
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package qml Qt6Quick)
+ $(qt_feature compositor wayland_server)
)
qt6-build_src_configure