summaryrefslogtreecommitdiff
path: root/dev-qt/qtspeech/qtspeech-6.5.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-20 01:53:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-20 01:53:29 +0000
commit54d0ccbac3b6fbd01dcd252ea006d4e9e62f8e6e (patch)
treefc8f42b6568c9de11a72455118288dee202ce586 /dev-qt/qtspeech/qtspeech-6.5.3.ebuild
parent3f0a9aff8dc766c410952343d02561aab3eda2b9 (diff)
gentoo auto-resync : 20:12:2023 - 01:53:29
Diffstat (limited to 'dev-qt/qtspeech/qtspeech-6.5.3.ebuild')
-rw-r--r--dev-qt/qtspeech/qtspeech-6.5.3.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-qt/qtspeech/qtspeech-6.5.3.ebuild b/dev-qt/qtspeech/qtspeech-6.5.3.ebuild
deleted file mode 100644
index 78bb4e99d6eb..000000000000
--- a/dev-qt/qtspeech/qtspeech-6.5.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Text-to-speech library for the Qt6 framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64"
-fi
-
-IUSE="flite +speechd"
-# can build with neither, but then it is just mock tts and may be confusing
-REQUIRED_USE="|| ( flite speechd )"
-
-# TODO: tests are known failing with clang and needs looking into, albeit
-# it is still usable at runtime save for applications segfaulting on exit
-# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
-# of this). Restricting because also seen this result in hanging. Note that
-# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
-# status on new major versions.
-RESTRICT="test"
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6
- ~dev-qt/qtdeclarative-${PV}:6
- flite? (
- app-accessibility/flite
- ~dev-qt/qtmultimedia-${PV}:6
- )
- speechd? ( app-accessibility/speech-dispatcher )
-"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- $(qt_feature flite)
- $(qt_feature speechd)
-
- # flite_alsa was likely to work around old issues in flite, it does
- # nothing but add -lasound (no code change, and is unneeded)
- -DQT_FEATURE_flite_alsa=OFF
- )
-
- qt6-build_src_configure
-}