summaryrefslogtreecommitdiff
path: root/dev-qt/qtspeech/qtspeech-5.15.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-08 18:03:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-08 18:03:40 +0100
commit418459f7de9eb29d6db8b61681f39c467d9600e1 (patch)
tree87b23e3d06e1b08b13c64e16503aa7ea88b38a8a /dev-qt/qtspeech/qtspeech-5.15.11.ebuild
parent522fa4e6f267ba688a264ceec8d6c79663b61219 (diff)
gentoo auto-resync : 08:10:2023 - 18:03:40
Diffstat (limited to 'dev-qt/qtspeech/qtspeech-5.15.11.ebuild')
-rw-r--r--dev-qt/qtspeech/qtspeech-5.15.11.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-qt/qtspeech/qtspeech-5.15.11.ebuild b/dev-qt/qtspeech/qtspeech-5.15.11.ebuild
new file mode 100644
index 000000000000..19d976af0d2c
--- /dev/null
+++ b/dev-qt/qtspeech/qtspeech-5.15.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+inherit qt5-build
+
+DESCRIPTION="Text-to-speech library for the Qt5 framework"
+
+IUSE="alsa flite"
+
+RDEPEND="
+ >=app-accessibility/speech-dispatcher-0.8.7
+ =dev-qt/qtcore-${QT5_PV}*
+ flite? (
+ >=app-accessibility/flite-2[alsa?]
+ =dev-qt/qtmultimedia-${QT5_PV}*[alsa?]
+ alsa? ( media-libs/alsa-lib )
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ qt_use_disable_config flite flite \
+ src/plugins/tts/tts.pro
+
+ qt_use_disable_config alsa flite_alsa \
+ src/plugins/tts/flite/flite.pro
+
+ qt5-build_src_prepare
+}