summaryrefslogtreecommitdiff
path: root/dev-qt/qtspeech/qtspeech-5.11.0_rc2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-19 13:06:44 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-19 13:06:44 +0100
commit97967bbbae8f43c98315b079178f1717f130e302 (patch)
tree27523f8cbd75ed85f33294862514b786a30dd6e5 /dev-qt/qtspeech/qtspeech-5.11.0_rc2.ebuild
parent30c53e395853f5bfe805a1e429fcf26666eed8f8 (diff)
gentoo resync : 19.05.2018
Diffstat (limited to 'dev-qt/qtspeech/qtspeech-5.11.0_rc2.ebuild')
-rw-r--r--dev-qt/qtspeech/qtspeech-5.11.0_rc2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-qt/qtspeech/qtspeech-5.11.0_rc2.ebuild b/dev-qt/qtspeech/qtspeech-5.11.0_rc2.ebuild
new file mode 100644
index 000000000000..24627d2b8665
--- /dev/null
+++ b/dev-qt/qtspeech/qtspeech-5.11.0_rc2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Text-to-speech library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# TODO: flite plugin - needs 2.0.0 (not yet in tree)
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/speech-dispatcher-0.8.7
+ ~dev-qt/qtcore-${PV}
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-5.9.4-nogui.patch" )