summaryrefslogtreecommitdiff
path: root/dev-qt/qtscxml/qtscxml-6.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-10 18:09:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-10 18:09:58 +0100
commitfc6ff4de73d70ead4ce3a005b4f5328f2b23129b (patch)
tree053abc181331b12ef77ce22da8a81bc298e50602 /dev-qt/qtscxml/qtscxml-6.6.0.ebuild
parent35d60f48c1e8e3d48626e53a1933c55805177d20 (diff)
gentoo auto-resync : 10:10:2023 - 18:09:58
Diffstat (limited to 'dev-qt/qtscxml/qtscxml-6.6.0.ebuild')
-rw-r--r--dev-qt/qtscxml/qtscxml-6.6.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/qtscxml-6.6.0.ebuild b/dev-qt/qtscxml/qtscxml-6.6.0.ebuild
new file mode 100644
index 000000000000..3baf824212bc
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-6.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # may fail with pid-sandbox, or at least musl/hardened+gcc (exact
+ # conditions unknown but passes without pid, considering this flaky)
+ tst_qstatemachine
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ )
+
+ qt6-build_src_configure
+}