summaryrefslogtreecommitdiff
path: root/dev-qt/qtpaths/qtpaths-5.15.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-13 23:44:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-13 23:44:17 +0100
commitfdca6388cf31827202fae75cae067c695bd09339 (patch)
tree5021150295c139ea6a808950a9e1928b8ef593b8 /dev-qt/qtpaths/qtpaths-5.15.9.ebuild
parentb43fb9ec552fc1a84599161478d77c6716dd9e0a (diff)
gentoo auto-resync : 13:04:2023 - 23:44:17
Diffstat (limited to 'dev-qt/qtpaths/qtpaths-5.15.9.ebuild')
-rw-r--r--dev-qt/qtpaths/qtpaths-5.15.9.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-qt/qtpaths/qtpaths-5.15.9.ebuild b/dev-qt/qtpaths/qtpaths-5.15.9.ebuild
new file mode 100644
index 000000000000..4f1248d19ada
--- /dev/null
+++ b/dev-qt/qtpaths/qtpaths-5.15.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Command line client to QStandardPaths"
+
+IUSE=""
+
+DEPEND="=dev-qt/qtcore-${QT5_PV}*"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/qtpaths
+)
+
+src_install() {
+ qt5-build_src_install
+ qt5_symlink_binary_to_path qtpaths 5
+}