summaryrefslogtreecommitdiff
path: root/dev-qt/qtopengl/qtopengl-5.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-qt/qtopengl/qtopengl-5.7.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-qt/qtopengl/qtopengl-5.7.1.ebuild')
-rw-r--r--dev-qt/qtopengl/qtopengl-5.7.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-qt/qtopengl/qtopengl-5.7.1.ebuild b/dev-qt/qtopengl/qtopengl-5.7.1.ebuild
new file mode 100644
index 000000000000..f1c9248875d2
--- /dev/null
+++ b/dev-qt/qtopengl/qtopengl-5.7.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qtbase"
+VIRTUALX_REQUIRED="test"
+inherit qt5-build
+
+DESCRIPTION="OpenGL support library for the Qt5 framework (deprecated)"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 x86"
+fi
+
+IUSE="gles2"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}[gles2=]
+ ~dev-qt/qtwidgets-${PV}[gles2=]
+ virtual/opengl
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/opengl
+)
+
+src_configure() {
+ local myconf=(
+ -opengl $(usex gles2 es2 desktop)
+ )
+ qt5-build_src_configure
+}