summaryrefslogtreecommitdiff
path: root/dev-qt/qtmultimedia/qtmultimedia-4.8.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-qt/qtmultimedia/qtmultimedia-4.8.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-qt/qtmultimedia/qtmultimedia-4.8.7.ebuild')
-rw-r--r--dev-qt/qtmultimedia/qtmultimedia-4.8.7.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-qt/qtmultimedia/qtmultimedia-4.8.7.ebuild b/dev-qt/qtmultimedia/qtmultimedia-4.8.7.ebuild
new file mode 100644
index 000000000000..eb03bb3922ac
--- /dev/null
+++ b/dev-qt/qtmultimedia/qtmultimedia-4.8.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit qt4-build-multilib
+
+DESCRIPTION="The Multimedia module for the Qt toolkit"
+
+if [[ ${QT4_BUILD_TYPE} == release ]]; then
+ KEYWORDS="amd64 arm ~arm64 ~ia64 ppc ppc64 x86"
+fi
+
+IUSE="alsa"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
+ ~dev-qt/qtgui-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
+ alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.8.0-alsa.patch"
+ "${FILESDIR}/${PN}-4.8.6-Relax-ALSA-version-checks-for-1.1.x.patch" # bug 572426
+)
+
+QT4_TARGET_DIRECTORIES="src/multimedia"
+
+QCONFIG_ADD="multimedia"
+QCONFIG_DEFINE="QT_MULTIMEDIA"
+
+multilib_src_configure() {
+ local myconf=(
+ -multimedia -audio-backend
+ $(qt_use alsa)
+ -no-accessibility -no-qt3support -no-xmlpatterns -no-phonon -no-phonon-backend
+ -no-svg -no-webkit -no-script -no-scripttools -no-declarative
+ -system-zlib -no-gif -no-libtiff -no-libpng -no-libmng -no-libjpeg -no-openssl
+ -no-cups -no-dbus -no-gtkstyle -no-nas-sound -no-opengl
+ -no-sm -no-xshape -no-xvideo -no-xsync -no-xinerama -no-xcursor -no-xfixes
+ -no-xrandr -no-xrender -no-mitshm -no-fontconfig -no-freetype -no-xinput -no-xkb
+ )
+ qt4_multilib_src_configure
+}