summaryrefslogtreecommitdiff
path: root/dev-qt/qtlocation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-qt/qtlocation
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest2
-rw-r--r--dev-qt/qtlocation/qtlocation-5.12.2.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index 53719a4e02f3..6e08518941f6 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,5 +1,7 @@
DIST qtlocation-everywhere-src-5.11.3.tar.xz 5589440 BLAKE2B 544d90151fcbaf8a75d374e4acec9bbd78b63c2dee0258f1e08e18ffb94a86c91f63dd8c9215af96e3648d50a40fe6b66c105abec0ab6dd4473903a06f2d0253 SHA512 880cd6983bc0b4c5ac5a1edb2b3ffbe89f133bd819e4bea4fb8e91ba8d847ab80572743e3994145ee6697cb2fc24c393ac3c4ead847a022d848799eaa4982716
DIST qtlocation-everywhere-src-5.12.1.tar.xz 5902336 BLAKE2B f22d925abfca45ef8d08636d131970dfdfa6974dcbed60ac43212784816836e5dd60a74ad429fe10f593b96a9b4c052b28890d3bf91ceac90d576ab3a6334618 SHA512 08dceeef8681b1266763197d8d4cab1d2ae8e8d0b62ae50ab44c64698588652d6ecf976b8f0095fa33b3a93b66b43fd4acbde4ebc47af8bdd79ce708c4237ed2
+DIST qtlocation-everywhere-src-5.12.2.tar.xz 5907108 BLAKE2B 3016921c6817414950ac3901252606cac844a385a604c46ee383817ef36d95c20641020dbc0c85d9dc2f647c18666aed3b51b5d55d003fe043377268734ab0c8 SHA512 1809c81cf6a916a8312ea449c178ec91f939d1bfc3bb21f3a1bd977a2be37fade1cf35bbe9253a8e6b8f4354cbdefcb67c071ff620254d5e95b9e35f7830eb79
EBUILD qtlocation-5.11.3-r1.ebuild 924 BLAKE2B 0608a37072401e2d5b4872976abc693f040c81cf8baa71dc1e7be5d3b229b44a4c794f36731a7885c297d4531f35aa057889da32f02f1c7575df1a315b5b32e1 SHA512 85a0f48a04d7dea9d07715599d21d7b1c2a334d2b338082296787f15fdc9b8654a11992ee1ee612e1d5cce2befe3dd267efd2efc28d69ba339eb4b6296a4774f
EBUILD qtlocation-5.12.1.ebuild 950 BLAKE2B d1961722a0b57b61414a79128fbc99262a1ed92b6276a5d36d6db150534db096c4fd8e90c640c2e70c8326453a695577ddbb46b75ee0fd7a80afe1593b2c78d2 SHA512 d709f39bc1d986f1349edd34cb97a6a96ffde97f2c47abfc48f89adb85318e4db082538dcc91f3c23d90b2b586faed19cd3caf19b3ed08e9bd2c431581223b53
+EBUILD qtlocation-5.12.2.ebuild 950 BLAKE2B d1961722a0b57b61414a79128fbc99262a1ed92b6276a5d36d6db150534db096c4fd8e90c640c2e70c8326453a695577ddbb46b75ee0fd7a80afe1593b2c78d2 SHA512 d709f39bc1d986f1349edd34cb97a6a96ffde97f2c47abfc48f89adb85318e4db082538dcc91f3c23d90b2b586faed19cd3caf19b3ed08e9bd2c431581223b53
MISC metadata.xml 481 BLAKE2B 210b94f2e7cdb09b2e07ec4a931ea47d5aed734be52e9dcb132ae174fc0707ebd82feff52e44490c7133274c4dd31b0898f9fa54ce700b635b6a45c2cbf2b5c6 SHA512 bc22732d392630b21ba3895b22a3b1835fe639f930bad0ebab511757df89ebbb30530f0c482ff0a7eb24c7ba844f0b2448040dc5252ac98b0ac01423f236829f
diff --git a/dev-qt/qtlocation/qtlocation-5.12.2.ebuild b/dev-qt/qtlocation/qtlocation-5.12.2.ebuild
new file mode 100644
index 000000000000..25dc50ab1019
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.12.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtpositioning-${PV}[qml]
+ ~dev-qt/qtsql-${PV}
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtconcurrent-${PV}
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}" || die
+ qt5_qmake "${QT_BUILD_DIR}"
+ qt5-build_src_configure
+}