summaryrefslogtreecommitdiff
path: root/dev-qt/qtlocation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
commitf616ce4660c92a3fcb4f05663c2ab47c9defa0c3 (patch)
tree66ba5228853030737ae2dd9c9894b96266213246 /dev-qt/qtlocation
parent1bfb8c3d7e00e7ff828008510f5a7568c81d8889 (diff)
gentoo auto-resync : 30:11:2022 - 01:22:10
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest3
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.7.ebuild49
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index 1fa6f773b1ba..b82ca6f27664 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,4 +1,7 @@
DIST qtlocation-5.15.5-gentoo-kde-1.tar.xz 3952 BLAKE2B ddab14fa3b17d080ea47a6bc10c3ca8fe180ff4954f22833967d1938f06c657c86c2e186e5c6bb50e3fd65c6c0c0b5cc94527bd687b714a315f23dcb7762c606 SHA512 f20b5aea6d68ab6860d69369d58b777ff56de3e2d93e3cbdadd21e6e0fb3511829d5c28b918c19e10290c1e5add0d087f98b2b005ac2f9a5381b9d59fd626a59
+DIST qtlocation-5.15.7-gentoo-kde-1.tar.xz 3948 BLAKE2B fcbac7c87e8c5f470f523c153b6caec2de66ccb7be6f8b0bdbf042d957a88626b4a46848eb6c6442b8199851b908f91241db72f7762816519ef27327f232927d SHA512 396c31cbf3f80c268ebcbf26de8cbfa2d51a355ef4d7824545f7d2fe98ccb5203b61cca9650cfae2793250006b2a5fa514b9bc19fff5650b86ac38a8ba9b9948
DIST qtlocation-everywhere-opensource-src-5.15.5.tar.xz 6559912 BLAKE2B 4f546293b2cfddf5512f3648aef9c527762d6c6ddbaca6583cf0287178524bae9f84e4b94950ce1139042efa995a4f31ef20f26b8d5479048df2ba75cac35d23 SHA512 5090f68926a7bc2f25ea5ae259cb87653b83fcf337c3255a7a2700724f6ac83ec2e1d9b6f38f185ab7dab84e5e042b72c58f4e4cacada6fb7d729378b93d9b3e
+DIST qtlocation-everywhere-opensource-src-5.15.7.tar.xz 6559220 BLAKE2B 635be1ec133a6dd7dbf071922090b6acfe4c02503275ac2539cd4e099dc518ac43654be54e5fa17d292fcdb9edf88a11a1eeec7e37faa752deb6671bef86abba SHA512 fc4579b14f7f4836ef550d80b867c2655f52da34b0637dce4d83b10f2f7a836530a8f2a6b0f1a41c38e5e391c5d8e2431818e9813fd9d597f67704fcfbfb2f7e
EBUILD qtlocation-5.15.5.ebuild 1158 BLAKE2B 2027660f38c9a0b1be35cdd27b685c9910530807e0cbc842c4c1366927933d3d482aeefd2c0b2f14c992ed03e10df35cad1af907f87f59bcf790461b4208a413 SHA512 09afb642c3a9a367aa9e1511b91a3fdf428511fd77e493947fb9a7ce8110038758a524d3a5ec8468f2f85bc39a3ff1c6193a2cafacee68f59998da35de114928
+EBUILD qtlocation-5.15.7.ebuild 1151 BLAKE2B 78e3ac4dafa6a06ed00af30ce7f1591f628ced0325f9bf1ed3b99c00c154800a60716da5a306128f700d2b64603128fdeb862c540e4f28dd7549cdc2490765ee SHA512 fcc45b2d39b31ca1b47a74b8936c7f553d48e2dbd0678b5b0bfd217731a18571d18d1d27c80429adac83a8c001a79f14d377e1a70185cce042b55470d76bc313
MISC metadata.xml 482 BLAKE2B 651a49dc4a07f5e5a9c21990868e666d98acdea7d7b0b2c0e4c98eafc3da72c803d380e4abda30f33250f7bbd7654df713833ccdddcb975cbad6f92e488f643b SHA512 192c670abd7da29645513bf1d9297d942efdc49f5cf170861e7689fda47f51daa47f10c7c81c3b045366e0259179c6839ff7747197c9d792e8d0fd1a5818973e
diff --git a/dev-qt/qtlocation/qtlocation-5.15.7.ebuild b/dev-qt/qtlocation/qtlocation-5.15.7.ebuild
new file mode 100644
index 000000000000..ebcbd1ab6c03
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.15.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+IUSE=""
+
+RDEPEND="
+ dev-libs/icu:=
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtpositioning-${QT5_PV}*[qml]
+ =dev-qt/qtsql-${QT5_PV}*
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ =dev-qt/qtconcurrent-${QT5_PV}*
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/imports/locationlabs
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}"/src/location || die
+ qt5_qmake "${QT5_BUILD_DIR}"
+ cp "${S}"/src/location/qtlocation-config.pri "${QT5_BUILD_DIR}"/src/location || die
+ qt5-build_src_configure
+}