summaryrefslogtreecommitdiff
path: root/dev-qt/qtlocation/qtlocation-6.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-19 12:05:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-19 12:05:02 +0100
commitb6cfc0c19effe2d9f7b8ab303cd00636f16da253 (patch)
treea0158050dac0a7ebfb9df4f667ec6ad2dd185538 /dev-qt/qtlocation/qtlocation-6.6.2.ebuild
parent2d01b3d133c0fbf17de8d7b47905585af88bd6e4 (diff)
gentoo auto-resync : 19:04:2024 - 12:05:02
Diffstat (limited to 'dev-qt/qtlocation/qtlocation-6.6.2.ebuild')
-rw-r--r--dev-qt/qtlocation/qtlocation-6.6.2.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-qt/qtlocation/qtlocation-6.6.2.ebuild b/dev-qt/qtlocation/qtlocation-6.6.2.ebuild
deleted file mode 100644
index 321eff47e2b6..000000000000
--- a/dev-qt/qtlocation/qtlocation-6.6.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Location (places, maps, navigation) library for the Qt6 framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64"
-fi
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6[network]
- ~dev-qt/qtdeclarative-${PV}:6
- ~dev-qt/qtpositioning-${PV}:6[qml]
-"
-DEPEND="${RDEPEND}"
-
-CMAKE_SKIP_TESTS=(
- # ignores QML_IMPORT_PATH (unlike other tests) and looks in
- # the missing builddir/qml, skip rather than work around
- tst_declarative_ui
-)
-
-src_install() {
- qt6-build_src_install
-
- if use test; then
- local delete=( # sigh
- "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*TestGeoServicePlugin*.cmake
- "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*UnsupportedPlacesGeoServicePlugin*.cmake
- "${D}${QT6_LIBDIR}"/cmake/Qt6Qml/QmlPlugins/*declarative_location_test*.cmake
- "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_geocodingplugin.so
- "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_placesplugin_unsupported.so
- "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_qmltestplugin.so
- "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_routingplugin.so
- "${D}${QT6_QMLDIR}"/QtLocation/Test
- )
- # using -f given not tracking which tests may be skipped or not
- rm -rf -- "${delete[@]}" || die
- fi
-}