summaryrefslogtreecommitdiff
path: root/dev-qt/qthelp/qthelp-5.11.0_rc2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-19 13:06:44 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-19 13:06:44 +0100
commit97967bbbae8f43c98315b079178f1717f130e302 (patch)
tree27523f8cbd75ed85f33294862514b786a30dd6e5 /dev-qt/qthelp/qthelp-5.11.0_rc2.ebuild
parent30c53e395853f5bfe805a1e429fcf26666eed8f8 (diff)
gentoo resync : 19.05.2018
Diffstat (limited to 'dev-qt/qthelp/qthelp-5.11.0_rc2.ebuild')
-rw-r--r--dev-qt/qthelp/qthelp-5.11.0_rc2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-qt/qthelp/qthelp-5.11.0_rc2.ebuild b/dev-qt/qthelp/qthelp-5.11.0_rc2.ebuild
new file mode 100644
index 000000000000..1e0ee9ab67fe
--- /dev/null
+++ b/dev-qt/qthelp/qthelp-5.11.0_rc2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Qt5 module for integrating online documentation into applications"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtsql-${PV}[sqlite]
+ ~dev-qt/qtwidgets-${PV}
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/assistant/help
+ src/assistant/qcollectiongenerator
+ src/assistant/qhelpconverter
+ src/assistant/qhelpgenerator
+)