summaryrefslogtreecommitdiff
path: root/dev-qt/qtdeclarative/qtdeclarative-6.6.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-19 12:05:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-19 12:05:02 +0100
commitb6cfc0c19effe2d9f7b8ab303cd00636f16da253 (patch)
treea0158050dac0a7ebfb9df4f667ec6ad2dd185538 /dev-qt/qtdeclarative/qtdeclarative-6.6.2-r1.ebuild
parent2d01b3d133c0fbf17de8d7b47905585af88bd6e4 (diff)
gentoo auto-resync : 19:04:2024 - 12:05:02
Diffstat (limited to 'dev-qt/qtdeclarative/qtdeclarative-6.6.2-r1.ebuild')
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-6.6.2-r1.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-qt/qtdeclarative/qtdeclarative-6.6.2-r1.ebuild b/dev-qt/qtdeclarative/qtdeclarative-6.6.2-r1.ebuild
deleted file mode 100644
index f9ae12f80864..000000000000
--- a/dev-qt/qtdeclarative/qtdeclarative-6.6.2-r1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Qt Declarative (Quick 2)"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 ~arm arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
-fi
-
-IUSE="accessibility opengl +sql vulkan +widgets"
-
-# behaves very badly when qtdeclarative is not already installed, also
-# other more minor issues (installs junk, sandbox/offscreen issues)
-RESTRICT="test"
-
-RDEPEND="~dev-qt/qtbase-${PV}:6[accessibility=,gui,network,opengl=,sql?,vulkan=,widgets=]"
-DEPEND="
- ${RDEPEND}
- vulkan? ( dev-util/vulkan-headers )
-"
-BDEPEND="~dev-qt/qtshadertools-${PV}:6"
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package sql Qt6Sql)
- )
-
- qt6-build_src_configure
-}