summaryrefslogtreecommitdiff
path: root/dev-qt/qtconcurrent/qtconcurrent-5.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-qt/qtconcurrent/qtconcurrent-5.7.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-qt/qtconcurrent/qtconcurrent-5.7.1.ebuild')
-rw-r--r--dev-qt/qtconcurrent/qtconcurrent-5.7.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-qt/qtconcurrent/qtconcurrent-5.7.1.ebuild b/dev-qt/qtconcurrent/qtconcurrent-5.7.1.ebuild
new file mode 100644
index 000000000000..bcecd17cde13
--- /dev/null
+++ b/dev-qt/qtconcurrent/qtconcurrent-5.7.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Multi-threading concurrence support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/concurrent
+)