summaryrefslogtreecommitdiff
path: root/dev-qt/qtconcurrent/qtconcurrent-5.15.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-qt/qtconcurrent/qtconcurrent-5.15.4.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-qt/qtconcurrent/qtconcurrent-5.15.4.ebuild')
-rw-r--r--dev-qt/qtconcurrent/qtconcurrent-5.15.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-qt/qtconcurrent/qtconcurrent-5.15.4.ebuild b/dev-qt/qtconcurrent/qtconcurrent-5.15.4.ebuild
new file mode 100644
index 000000000000..8307e75b3263
--- /dev/null
+++ b/dev-qt/qtconcurrent/qtconcurrent-5.15.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_KDEPATCHSET_REV=1
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Multi-threading concurrence support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~sparc x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*:5=
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/concurrent
+)