summaryrefslogtreecommitdiff
path: root/dev-qt/qt3support/qt3support-4.8.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-qt/qt3support/qt3support-4.8.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-qt/qt3support/qt3support-4.8.7.ebuild')
-rw-r--r--dev-qt/qt3support/qt3support-4.8.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-qt/qt3support/qt3support-4.8.7.ebuild b/dev-qt/qt3support/qt3support-4.8.7.ebuild
new file mode 100644
index 000000000000..6dc258487e99
--- /dev/null
+++ b/dev-qt/qt3support/qt3support-4.8.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit qt4-build-multilib
+
+DESCRIPTION="The Qt3Support module for the Qt toolkit"
+
+if [[ ${QT4_BUILD_TYPE} == release ]]; then
+ KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+fi
+
+IUSE="+accessibility"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}[aqua=,debug=,qt3support,${MULTILIB_USEDEP}]
+ ~dev-qt/qtgui-${PV}[accessibility=,aqua=,debug=,qt3support,${MULTILIB_USEDEP}]
+ ~dev-qt/qtsql-${PV}[aqua=,debug=,qt3support,${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+ src/qt3support
+ src/tools/uic3
+ tools/porting"
+
+multilib_src_configure() {
+ local myconf=(
+ -qt3support
+ $(qt_use accessibility)
+ )
+ qt4_multilib_src_configure
+}