summaryrefslogtreecommitdiff
path: root/dev-qt/qt-docs/qt-docs-5.9.6_p201806072055.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-qt/qt-docs/qt-docs-5.9.6_p201806072055.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-qt/qt-docs/qt-docs-5.9.6_p201806072055.ebuild')
-rw-r--r--dev-qt/qt-docs/qt-docs-5.9.6_p201806072055.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-qt/qt-docs/qt-docs-5.9.6_p201806072055.ebuild b/dev-qt/qt-docs/qt-docs-5.9.6_p201806072055.ebuild
deleted file mode 100644
index b2808a6778ef..000000000000
--- a/dev-qt/qt-docs/qt-docs-5.9.6_p201806072055.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit versionator
-
-DESCRIPTION="Qt5 documentation, for use with Qt Creator and other tools"
-HOMEPAGE="https://doc.qt.io/"
-
-PV_FULL=${PV/_p/-0-}
-PV_NODOTS=$(get_version_component_range 1)$(get_version_component_range 2)$(get_version_component_range 3)
-BASE_URI="https://download.qt.io/online/qtsdkrepository/linux_x64/desktop/qt5_${PV_NODOTS}_src_doc_examples/qt.${PV_NODOTS}.doc"
-SRC_URI="${BASE_URI}/${PV_FULL}qt-everywhere-documentation.7z
- charts? ( ${BASE_URI}.qtcharts/${PV_FULL}qtcharts-documentation.7z )
- datavis? ( ${BASE_URI}.qtdatavis3d/${PV_FULL}qtdatavisualization-documentation.7z )
- networkauth? ( ${BASE_URI}.qtnetworkauth/${PV_FULL}qtnetworkauth-documentation.7z )
- script? ( ${BASE_URI}.qtscript/${PV_FULL}qtscript-documentation.7z
- ${BASE_URI}.qtscript/${PV_FULL}qtscripttools-documentation.7z )
- speech? ( ${BASE_URI}.qtspeech/${PV_FULL}qtspeech-documentation.7z )
- virtualkeyboard? ( ${BASE_URI}.qtvirtualkeyboard/${PV_FULL}qtvirtualkeyboard-documentation.7z )
- webengine? ( ${BASE_URI}.qtwebengine/${PV_FULL}qtwebengine-documentation.7z )
-"
-
-LICENSE="FDL-1.3"
-SLOT="5"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-
-IUSE="3d bluetooth charts datavis declarative graphicaleffects +html location
- multimedia networkauth +qch script sensors speech virtualkeyboard webengine"
-REQUIRED_USE="|| ( html qch )"
-
-DEPEND="app-arch/p7zip"
-
-S=${WORKDIR}/Docs/Qt-${PV%_p*}
-
-src_prepare() {
- default
-
- # bug 597026
- rm -r global || die
-
- # bug 602750
- rm Makefile || die
-
- use 3d || rm -r qt3d* || die
- use bluetooth || rm -r qtbluetooth* || die
- use declarative || rm -r qtqml* qtquick* || die
- use graphicaleffects || rm -r qtgraphicaleffects* || die
- use location || rm -r qtlocation* || die
- use multimedia || rm -r qtmultimedia* || die
- use sensors || rm -r qtsensors* || die
-}
-
-src_install() {
- # must be the same as QT_INSTALL_DOCS
- local dest=/usr/share/doc/qt-${PV%_p*}
- insinto "${dest}"
- use html && doins -r */
- use qch && doins *.qch
- docompress -x "${dest}"
-}