summaryrefslogtreecommitdiff
path: root/dev-qt/assistant
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
commitdb70871b2044b9bfde346d6f4027dafb0a013c4c (patch)
tree34548aee54e5458d3754bd8c8f987acdb5ee444c /dev-qt/assistant
parent1c382dc5dbc52576ac2300fee0498af8af44e7b4 (diff)
gentoo auto-resync : 15:06:2023 - 13:38:09
Diffstat (limited to 'dev-qt/assistant')
-rw-r--r--dev-qt/assistant/Manifest3
-rw-r--r--dev-qt/assistant/assistant-5.15.10.ebuild60
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-qt/assistant/Manifest b/dev-qt/assistant/Manifest
index 80c12f0cdb0b..01c9dbc5d25c 100644
--- a/dev-qt/assistant/Manifest
+++ b/dev-qt/assistant/Manifest
@@ -1,4 +1,7 @@
+DIST qttools-5.15.10-gentoo-kde-1.tar.xz 3188 BLAKE2B bc9b411398dc225f16a654d025ef69318988c80554c732ab0fdf19cedd8429775c6569f99f656fa27494c407eb319e7a4eb42fc201ef0f543380dcbdb2898559 SHA512 b95278acb13db8c2c05f2d1fcf1d07f3939135c6684ee078db1fa9fb88dfe435c5095faf567fb510be018ed6aa04c0c780359116f38ada41bf56151f4dc8fa97
DIST qttools-5.15.9-gentoo-kde-1.tar.xz 1024 BLAKE2B cc4cf05962b9d29aeb34f18df530073f051945b8922dea8a5e43d8337bf442d7e7e148aaa68912a9df481fed0617e3568cd80a2e07359afc1b5228d08ca0d6cb SHA512 9781fbc9f10e389d0094a756ac63679bd4fd24e6809e486669a0236c2f8e0fe1285985a936867f47d309162b57c886d48fb5075445e1a51de20a2916b09a8a89
+DIST qttools-everywhere-opensource-src-5.15.10.tar.xz 8899372 BLAKE2B c49cfc36640f68743f7c21f06ac87221b3e8b92a2fa096c54cf539bc4eb80a99decfb6f0fde53b1c5334612bf5d8641465f350143470429c505b6dc7f597bcf0 SHA512 08d5182309c0f19f14af4e509871bca13b89cdd762bd4b7f98b15120b2e74308e478f826b4236f01abc299520da32b716df9e7bfaa84935fbdc0a74422ade5f1
DIST qttools-everywhere-opensource-src-5.15.9.tar.xz 8898188 BLAKE2B 9ba8c3cab5669d2bfba782efdcd31d8a853ab7b42b653d4cfe9d30d16bedf6ed7cd34f4bbce8a52c40b555693db4e763cb454fadb8fc1630ca0d2ac969f4edca SHA512 ddd2a47fe51e9a6e650123eda097ea037971f01f9210cea9c1d13c7a8e581e436a41c954f83def0a8ee35c30f388627809e3eb4bbf27b5e3ece6a55f7d777067
+EBUILD assistant-5.15.10.ebuild 1308 BLAKE2B be0c02b5f2049c90f86f483b7c02e2c72921845fda5404645affe6929375abd43480b141f5c5756cf3d7ba551a7eca8f5b25b55f5117d02ef2c9bcc04414d327 SHA512 8eb82d0e9659f4e5c98a78f1776ec993d074496e61f99e39ee3291d8fa7d1d73d71f91287ff6a302b331511ba9552845c0ad610ebfddd1ae0aeebdc0b2f53e34
EBUILD assistant-5.15.9.ebuild 1304 BLAKE2B a8346fafdd8d94ad7da1f46ef1ba63bdff287c9a50b3fce4cb1eeeecb810b7e1117323bb503c83f54e7237f1d920d9d43f9e5ec4cde95e9403be0e1e3da69080 SHA512 b11a0b125b33f8760db75d31f65a46d7928502eda6bee6cd9a4b6518386fa753612a0a673d685a30ff87d1c8fc0b6ff37b99c33f47de48a7afdebfecdea5c5f3
MISC metadata.xml 482 BLAKE2B 651a49dc4a07f5e5a9c21990868e666d98acdea7d7b0b2c0e4c98eafc3da72c803d380e4abda30f33250f7bbd7654df713833ccdddcb975cbad6f92e488f643b SHA512 192c670abd7da29645513bf1d9297d942efdc49f5cf170861e7689fda47f51daa47f10c7c81c3b045366e0259179c6839ff7747197c9d792e8d0fd1a5818973e
diff --git a/dev-qt/assistant/assistant-5.15.10.ebuild b/dev-qt/assistant/assistant-5.15.10.ebuild
new file mode 100644
index 000000000000..12f38d51e08a
--- /dev/null
+++ b/dev-qt/assistant/assistant-5.15.10.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+fi
+
+QT5_MODULE="qttools"
+inherit desktop qt5-build xdg-utils
+
+DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"
+
+IUSE=""
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*[png]
+ =dev-qt/qthelp-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtprintsupport-${QT5_PV}*
+ =dev-qt/qtsql-${QT5_PV}*[sqlite]
+ =dev-qt/qtwidgets-${QT5_PV}*
+"
+RDEPEND="${DEPEND}
+ !dev-qt/${PN}:5
+ !<dev-qt/qtchooser-66-r2
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/assistant/assistant
+)
+
+src_prepare() {
+ sed -e "s/qtHaveModule(webkitwidgets)/false/g" \
+ -i src/assistant/assistant/assistant.pro || die
+
+ qt5-build_src_prepare
+}
+
+src_install() {
+ qt5-build_src_install
+ qt5_symlink_binary_to_path assistant
+
+ doicon -s 32 src/assistant/assistant/images/assistant.png
+ newicon -s 128 src/assistant/assistant/images/assistant-128.png assistant.png
+ make_desktop_entry "${QT5_BINDIR}"/assistant 'Qt 5 Assistant' assistant 'Qt;Development;Documentation'
+}
+
+pkg_postinst() {
+ qt5-build_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ qt5-build_pkg_postrm
+ xdg_icon_cache_update
+}