summaryrefslogtreecommitdiff
path: root/dev-qt/assistant
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /dev-qt/assistant
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'dev-qt/assistant')
-rw-r--r--dev-qt/assistant/Manifest2
-rw-r--r--dev-qt/assistant/assistant-5.12.1.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-qt/assistant/Manifest b/dev-qt/assistant/Manifest
index fbc6b28a026f..8f9f0d256731 100644
--- a/dev-qt/assistant/Manifest
+++ b/dev-qt/assistant/Manifest
@@ -1,3 +1,5 @@
DIST qttools-everywhere-src-5.11.3.tar.xz 9705920 BLAKE2B 1c44d914463cd2bb2e61652debbd4661822442e0fc02569d98c17e3898d6acdd7546fb978af4a3dfe4fd00d66cbd4424b794ee7e7a26460465503b03b5f9957a SHA512 f9604ef4c33892a429c4f7252892271888b64e087ce8e943308680628b8c3a033aa2ea6659e6210ac90e3404120f458c77f650f20fed13f4723ed3c03a598eaf
+DIST qttools-everywhere-src-5.12.1.tar.xz 9818060 BLAKE2B 1a1cf98d19e41b5fa2ec765ce9b931e9d678dc6e504f65f5b2b96ba5420d36c3955098abc4b66a886f37243e13fa388ff4e2761fc39295d864818cca50cb0380 SHA512 e3ae1974f0b20bad1b86d038c3585753183b8c24c133393e3ecf65a0487402ad8dcf8147bf263e9a4c2d3abef1b706981943fcf5268726e424f1b61f69ce4f2e
EBUILD assistant-5.11.3.ebuild 1199 BLAKE2B d0d2c32af3904215f9c1bb9cc1b3fd916e6fa55a1707a0d6959816faafaced118ac30b946df5fe8250ce19058a9b66ba0ecdd37adb3a5d11640ad9be397bc187 SHA512 f675d5c910754521aafcca73d44645f4e45948a8f9ce13689d7fa558c270383b493b2d42ba8fad4d78bb65e3dbf6e8115980a3d677c641671959e25832303f06
+EBUILD assistant-5.12.1.ebuild 1202 BLAKE2B 5940a629c8f8c565859f45f889d2dc25098f7b28f3a5ebfe671245ce81b845b0a5b9c26d2ba7aa0af19fca3c105ab29f94ebfc282c1ab66332abc0de5506a330 SHA512 7ae10138415d4adb0cb8feb0ad62fc7edddca260151a86a0101189b38608a3fc2390b8e9b78016de3759846c523b885943ce8c438725b3e29224e957697f3483
MISC metadata.xml 481 BLAKE2B 210b94f2e7cdb09b2e07ec4a931ea47d5aed734be52e9dcb132ae174fc0707ebd82feff52e44490c7133274c4dd31b0898f9fa54ce700b635b6a45c2cbf2b5c6 SHA512 bc22732d392630b21ba3895b22a3b1835fe639f930bad0ebab511757df89ebbb30530f0c482ff0a7eb24c7ba844f0b2448040dc5252ac98b0ac01423f236829f
diff --git a/dev-qt/assistant/assistant-5.12.1.ebuild b/dev-qt/assistant/assistant-5.12.1.ebuild
new file mode 100644
index 000000000000..6d109d6a499a
--- /dev/null
+++ b/dev-qt/assistant/assistant-5.12.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qttools"
+inherit desktop gnome2-utils qt5-build
+
+DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~sparc ~x86"
+fi
+
+IUSE="webkit"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qthelp-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtprintsupport-${PV}
+ ~dev-qt/qtsql-${PV}[sqlite]
+ ~dev-qt/qtwidgets-${PV}
+ webkit? ( >=dev-qt/qtwebkit-5.9.1:5 )
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/assistant/assistant
+)
+
+src_prepare() {
+ qt_use_disable_mod webkit webkitwidgets \
+ src/assistant/assistant/assistant.pro
+
+ qt5-build_src_prepare
+}
+
+src_install() {
+ qt5-build_src_install
+
+ doicon -s 32 src/assistant/assistant/images/assistant.png
+ newicon -s 128 src/assistant/assistant/images/assistant-128.png assistant.png
+ make_desktop_entry "${QT5_BINDIR}"/assistant 'Qt 5 Assistant' assistant 'Qt;Development;Documentation'
+}
+
+pkg_postinst() {
+ qt5-build_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ qt5-build_pkg_postrm
+ gnome2_icon_cache_update
+}