summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-21 19:57:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-21 19:57:51 +0000
commitfe3d938433735c9b681b7e72296a5ae70fd2a7e9 (patch)
tree7ec2937cecc4be47ff9ab102db046946216609ea /dev-python
parentd8e7aaf1b90b28ec354e7854abea07d53644e754 (diff)
gentoo auto-resync : 21:12:2023 - 19:57:50
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin268674 -> 268673 bytes
-rw-r--r--dev-python/httpx-socks/Manifest2
-rw-r--r--dev-python/httpx-socks/httpx-socks-0.8.0-r1.ebuild (renamed from dev-python/httpx-socks/httpx-socks-0.8.0.ebuild)9
-rw-r--r--dev-python/pytest-httpx/Manifest2
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.28.0.ebuild32
-rw-r--r--dev-python/tekore/Manifest4
-rw-r--r--dev-python/tekore/tekore-5.2.0.ebuild55
-rw-r--r--dev-python/tekore/tekore-5.2.1-r1.ebuild (renamed from dev-python/tekore/tekore-5.2.1.ebuild)9
-rw-r--r--dev-python/translate-toolkit/Manifest2
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.12.1.ebuild118
10 files changed, 171 insertions, 62 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 609fd3bed4c7..43885f143626 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/httpx-socks/Manifest b/dev-python/httpx-socks/Manifest
index e0eab60700ac..e5a701ec53b2 100644
--- a/dev-python/httpx-socks/Manifest
+++ b/dev-python/httpx-socks/Manifest
@@ -1,3 +1,3 @@
DIST httpx-socks-0.8.0.gh.tar.gz 15285 BLAKE2B 1da3bffff2be273e62452d96c8e07f38cf3c488bb89704ab377565feecafc1f96e9b96b615dfca4c3721c295414005014f868982a440ed47f3454814545aa6c7 SHA512 f58555670bc689002633daf3cf373641cbab6417636d16e878d5f9fc796b8bf7111d7c6985909590ccaeedb95793f589676e7f36c217330cbf46b4778319a4b7
-EBUILD httpx-socks-0.8.0.ebuild 1190 BLAKE2B 641d6969da16f5eb0c0ad015398dde5d63c4c1b6735d9b8cf796e2a151e2390ea1168e69af11649c5adc28b32596653f7ba3eb3c3ecf080ef21a2c06d2c7f70a SHA512 8fedc343986ca5ac744fb79a233ef6dee6e1f51a74a1b7adaf798313349b5ff9b89c879ff51c2e34e29c8b9083abf084dbfd45cb3fec822579c1857ad2c35f87
+EBUILD httpx-socks-0.8.0-r1.ebuild 1215 BLAKE2B 161026c144fd49e0b9fe516f3d2dd5177f6f196db3621b4192092f804094045a6c085afe7811b4f25355bfa55c707120f809146afad992d1c1fe529bd83aa253 SHA512 a40399ced8524a28c337af5d1035c256acbd4535988cabb2b69cbc2da10200f23f2d16f36c314f408320aa503df2b1694d6112b2fb2562b0533ec7589cee64cb
MISC metadata.xml 400 BLAKE2B b244ebd9f79b1c3313797b0384339d17df61913473cd26ab01c8490fe02cbe735609dbd2b2d76e7b1b7f716bbb3038590517481a05c1b7886ad49905f171f5e3 SHA512 3cb1600426cdc5b9ec3bd5d18b547dedb961bbc341891293f828e70d5156d845c8676ba25244804d32c702fab40134c39237e5ce4fc518104a969a8f8ffb282f
diff --git a/dev-python/httpx-socks/httpx-socks-0.8.0.ebuild b/dev-python/httpx-socks/httpx-socks-0.8.0-r1.ebuild
index ce8d7e95504e..5e5bae2f9631 100644
--- a/dev-python/httpx-socks/httpx-socks-0.8.0.ebuild
+++ b/dev-python/httpx-socks/httpx-socks-0.8.0-r1.ebuild
@@ -24,9 +24,7 @@ SLOT="0"
KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
- <dev-python/httpx-0.26.0[${PYTHON_USEDEP}]
>=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
- <dev-python/httpcore-2[${PYTHON_USEDEP}]
>=dev-python/httpcore-0.17.3[${PYTHON_USEDEP}]
>=dev-python/python-socks-2.0.0[${PYTHON_USEDEP}]
"
@@ -42,3 +40,10 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin dependencies
+ sed -i -e 's:,<[0-9.]*::' setup.py || die
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index ebae9feeedfb..76aef8ab19da 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,3 +1,5 @@
DIST pytest_httpx-0.27.0.tar.gz 33905 BLAKE2B 352812df060f878044a628dee62ab36f15d17080afc0367b6331c2e5e13600eefff7a3668f4a9364d437394ad8f8354f41619ec4f6b8bc5ac14b1cd652357802 SHA512 e2834313f507d02b9df96a47f8be6f46b451972e88ed9c9bfcb8bdb92545cc44064b11a1160a5d9d900381181918611d5d5a9efaf60f4e491f33182e9bd884dd
+DIST pytest_httpx-0.28.0.tar.gz 34065 BLAKE2B 13b52ba38a6e98f0d9aa10109b2d476feedfef516492b4cbe3f2cc91d1b1809934409e0e696021e1b2d5e3668cf3493834f44cb11940bac73f64949a73401308 SHA512 5dae77c04e1d801ba63a487d91e2d80a94e0626673749453ce0d273bbe876967d73789dc7811f1e96ad7366de2a00a5cee1a512398693b41e7cbc2424cb0c44f
EBUILD pytest-httpx-0.27.0.ebuild 643 BLAKE2B c94e43f74f465175b5f7781f8c826b284126479c92b25c5fdf0d51f6ecfd9cda204871cb3ee2f2dd644653ae209b1586385072a27c3802602a6f2acf4a3d8af6 SHA512 34bdd52f3ecc4d2097f33cf2b6ee1ee0cbb97fad86ad23d8e0d83ee206bad6f0735d826725bc38e9363fb057dafe32482312b82966f012fa1edc34dfc730d139
+EBUILD pytest-httpx-0.28.0.ebuild 646 BLAKE2B dd9744d51dd316fe19913f72d334857044fd09801db909bb92ff47241751c5729ccbae6a41722b66b0174266968f37bc36ee2cde5462d8fd2d7841c34c971466 SHA512 62f55a3c336e1ca1005353ae62aa5f939562ba0cc5b7fd256b0833484b146be9a3ebe449b4f21cae41ac631453579b4a8044f9e6a424236c9039a3d357c813c1
MISC metadata.xml 468 BLAKE2B e0f824f05936a831a958b027366ba18cad85307ac6c81b74b299f58270bcff53e06f32b2471d6433bd7014ffde83ddb24f787c07632453d14f4ee6e4679ffd10 SHA512 16bf024801db3c0d7b789cd1f16520a1ff2520e8b3e2abbeeff5b1192c19b8ac64f55fa678c922f8a817debcfe05242ce11e0164a00422445d7301858718b359
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.28.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.28.0.ebuild
new file mode 100644
index 000000000000..0319210f3619
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.28.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.26*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index 80d34c9126ea..c3732fb2fd75 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1,5 +1,3 @@
-DIST tekore-5.2.0.gh.tar.gz 262281 BLAKE2B 84f759ed5856f9fdab2f4ef115cad11e021ac0c0c4006e7d07c23a413778d1c45e68d0b4bdb8234688c99f026daf519047e4ce7760a58c71e75aa30009472117 SHA512 9151d6d83420c8f80b420535b344063814ca2dc0ca5681c196e7c920844ad6b6305562e59a8d4e23c694eab2b47029cc735a4b0a079a98828252a09e75236a73
DIST tekore-5.2.1.gh.tar.gz 262294 BLAKE2B 9572f4e45d4e90421b49697e816e4c83220af55360276f77ad86fd4469afdb214ec5dceab6e65170e9050d0e728f0f4998c99c30e6379c25c405f922b61ad853 SHA512 f91d9b166acf2a9906dff4aec00328221f4d54e6f833b982cc782168552284c29ddd03f8da052ccabd93dc2e7bbe72c95019599d6b57fcccd1561f36d7136e63
-EBUILD tekore-5.2.0.ebuild 1307 BLAKE2B f1f211f0e9abd189666ae74bbd8b917f4242d4b0a760fcb96eb9f2177f69f5672d14b5cf5b463c8c0989f3a806084072910a4cc56076817cbf6397cc47090547 SHA512 f3a9b6c913075912e43ac7c1d79f574ad47240c511fd96adc5c41e7d18efffc81e14abbdbbb7e1b6372ec3d863be48efc3b25b302c883766f44e1a37d6a140aa
-EBUILD tekore-5.2.1.ebuild 1107 BLAKE2B 3607f889e5522f2b66e02229f40454577ecb83e2425c13e12d3c45f185b1fe25d9104c6cdc2b77658bce562c78674cac2dabf77c893ff2c5f13c6f31eca6b649 SHA512 e8661a8bd7e76e452ebd037b96bbe472ae543229a710266dad1f3e3958f196ff755567cbee7be66d05a1a0c6490ad9482dc977addd588a69e4e71e4e2d10756c
+EBUILD tekore-5.2.1-r1.ebuild 1218 BLAKE2B 83a2b2a904b360c7177b4706191a69bf0bfcd81c3b6d6cb012fd630293a2158673122a775f69f44380227b1a3c6e8fc142475dd9a22ba31c0e0af443a2ea84f6 SHA512 421b43dafc59bb8a4d96c1a8d54257e0bb457fa3deeb4ac07f02ce897538a7f73004cb999bc200f2431bf02dc8755639dc8309dee5538300a46ef73cdcce0c59
MISC metadata.xml 513 BLAKE2B c6af854b6f684809ccdf1fbf573013580f9d56ab644913d3a095734867f654ec42b4d694e4197418a20e5fa7291737e14c3189bfad9e5cbe0aa9182db2197af6 SHA512 4d7fa6932a8d832226a080294177e08f7891e39fbd5f379f269268b1c21a8e28129c91f7f2c3b32e56de49c0a2d0a3365a5f57dd7445dd3ce09eae01b21409d9
diff --git a/dev-python/tekore/tekore-5.2.0.ebuild b/dev-python/tekore/tekore-5.2.0.ebuild
deleted file mode 100644
index 98ce61f606a8..000000000000
--- a/dev-python/tekore/tekore-5.2.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Spotify Web API client"
-HOMEPAGE="
- https://tekore.readthedocs.io/
- https://github.com/felix-hilden/tekore/
- https://pypi.org/project/tekore/
-"
-SRC_URI="
- https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-KEYWORDS="~amd64"
-SLOT="0"
-
-RDEPEND="
- <dev-python/httpx-0.26[${PYTHON_USEDEP}]
- >=dev-python/pydantic-1.8[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- >=dev-python/pydantic-2[${PYTHON_USEDEP}]
- >=dev-python/pytest-asyncio-0.17[${PYTHON_USEDEP}]
- dev-python/pytest-httpx[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( readme.rst )
-
-distutils_enable_tests pytest
-# TODO: package sphinx_codeautolink
-# distutils_enable_sphinx docs/src \
-# dev-python/sphinx-rtd-theme \
-# dev-python/sphinx-tabs \
-# dev-python/sphinx-autodoc-typehints
-
-EPYTEST_DESELECT=(
- # Internet
- tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
- # these tests use calls specific to pydantic-2
- # TODO: reselect when we can depend on >=pydantic-2
- tests/model.py::TestModel::test_enum_in_model
- tests/model.py::TestModel::test_unknown_attribute_ignored
-)
diff --git a/dev-python/tekore/tekore-5.2.1.ebuild b/dev-python/tekore/tekore-5.2.1-r1.ebuild
index 19d6051b2c8f..6e7f60d52dae 100644
--- a/dev-python/tekore/tekore-5.2.1.ebuild
+++ b/dev-python/tekore/tekore-5.2.1-r1.ebuild
@@ -24,7 +24,7 @@ KEYWORDS="~amd64 ~arm64"
SLOT="0"
RDEPEND="
- <dev-python/httpx-0.26[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
>=dev-python/pydantic-1.8[${PYTHON_USEDEP}]
"
@@ -49,3 +49,10 @@ EPYTEST_DESELECT=(
# Internet
tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
)
+
+src_prepare() {
+ # unpin dependencies
+ sed -i -e 's:,<[0-9.]*::' pyproject.toml || die
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index 6a1ac9af7ea5..c2943cd38b38 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,3 +1,5 @@
DIST translate-3.11.1.gh.tar.gz 1197476 BLAKE2B 5db1d5ab5dd79b0f85b48ca13e1a281a88d7e9e3a5502f9d5e44c3a82014aa49e28b3e283b2636f3bff79385da7e5db658b160c32275deb823625199a8932b57 SHA512 5b75e28c0baa41dc3a0fabb08e1961530bdffb2ae9d18bf40a682816b222f0bb725dbe67ba3536b9029c8d50c1c6b38eaa9f3e8fcbeb69653ef6565613013371
+DIST translate-3.12.1.gh.tar.gz 1200341 BLAKE2B dd2a5ddcdc2d4f282d70fd2158268c23d55f8714d314071f9863baf6fdc1f8433fb2e0d6d241cac6f1db5c71affffffa9fbd74d96ec0520b088a051d4f73aaee SHA512 d49b57350063582fe49f91c164e0879df1e348137587c153a65372d3db288e23b37a50bd73a870ea4280019612a6be9f95eccb716723e1afc4c0248113eb377e
EBUILD translate-toolkit-3.11.1.ebuild 3132 BLAKE2B 33b6d42c56a25ef734342f14d8afcc64e52aed747562970978ec01e76b0bb71c0717c45033f3b1be171fb4324ceaebe9d64784bf8a5963ed13d1d02b93f461f6 SHA512 1c98620a60720af567a665e92c9b9412b083b699a51c6e3cbe5637fa0ab894bb1c3d03c9cf14b8bcfd0ee927efde41666d7324ebeac9d9a5536e00358fc72fbf
+EBUILD translate-toolkit-3.12.1.ebuild 3135 BLAKE2B a1a9eb35eeb14727e9d4efdfcccf9baf5bd62a7701a26e85905753610b8be20a6f86d45d855ad4464c6352857c70e5b0a9b9f061c123fec64221f88348f01ea5 SHA512 1191f473eace930f5d600e53c822109b526e5adc0af7173cce1ad453f226da86c428c4891155c026bf2e1f69a88ac5c710ffb12a806fd41d29bbf094ed24055a
MISC metadata.xml 756 BLAKE2B 06f64f258d362954f99f7e9eee241eb3dddc6b00b9069df2ad977d28b5cf06f9c8ee2246ee5958600b5ac86297968d7aaced6b6420dca4ed507c441c58c61ca9 SHA512 80374c40513ca450f97e3930929c1450e7438ea15830e60937952a6fccfd999675f2ca2056c5aa4e287ba256c6ec08a09d8f7adb8b2c5af8ca0cd595f34acd85
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.12.1.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.12.1.ebuild
new file mode 100644
index 000000000000..9bf1ba95a909
--- /dev/null
+++ b/dev-python/translate-toolkit/translate-toolkit-3.12.1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_P=translate-${PV}
+DESCRIPTION="Toolkit to convert between many translation formats"
+HOMEPAGE="
+ https://github.com/translate/translate/
+ https://pypi.org/project/translate-toolkit/
+"
+SRC_URI="
+ https://github.com/translate/translate/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+html +ical +ini +subtitles +yaml"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/Levenshtein-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/mistletoe-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
+ ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
+ ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
+ subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+# Technically, the test suite also has undeclared dependency
+# on dev-python/snapshottest but all the tests using it are broken
+# anyway, so we skip them.
+BDEPEND="
+ test? (
+ dev-python/phply[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # unfortunately, this bad quality package doesn't support XDG_DATA_DIRS
+ # correctly, so we need to reassemble all data files in a single directory
+ local -x XDG_DATA_HOME=${T}/share
+ cp -r translate/share "${T}/" || die
+ cp -r "${ESYSROOT}/usr/share"/gaupol "${XDG_DATA_HOME}"/ || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Fails with network-sandbox (and even with it off but w/ softer fail)
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ # all tests based on snapshottest are broken and I'm too tired
+ # to figure this out
+ tests/translate/tools/test_pocount.py::test_{cases,output}
+ tests/translate/tools/test_junitmsgfmt.py::test_output
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged fluent.*
+ tests/translate/storage/test_fluent.py
+ # changes directory and does not change it back, sigh
+ tests/odf_xliff/test_odf_xliff.py
+ )
+
+ if ! use ini; then
+ EPYTEST_IGNORE+=(
+ translate/convert/test_ini2po.py
+ translate/convert/test_po2ini.py
+ )
+ fi
+
+ if ! use subtitles; then
+ EPYTEST_IGNORE+=(
+ translate/storage/test_subtitles.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr
+ doins -r translate/share
+
+ if ! use html; then
+ rm "${ED}"/usr/bin/{html2po,po2html} || die
+ fi
+ if ! use ical; then
+ rm "${ED}"/usr/bin/{ical2po,po2ical} || die
+ fi
+ if ! use ini; then
+ rm "${ED}"/usr/bin/{ini2po,po2ini} || die
+ fi
+ if ! use subtitles; then
+ rm "${ED}"/usr/bin/{sub2po,po2sub} || die
+ fi
+}