summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-18 15:36:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-18 15:36:15 +0100
commita2f7cdda45fadf1f967379421e8d808b1a503cd3 (patch)
treec02c7db0bb9249243aa73a4098a17e13daaaff21 /dev-python
parent66611e742171c343d64095516e19737d4753ba61 (diff)
gentoo auto-resync : 18:08:2023 - 15:36:15
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin267199 -> 267198 bytes
-rw-r--r--dev-python/mkdocs-bootstrap/Manifest2
-rw-r--r--dev-python/mkdocs-bootstrap/mkdocs-bootstrap-1.1.1.ebuild24
-rw-r--r--dev-python/mkdocs-minify-plugin/Manifest2
-rw-r--r--dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.7.1.ebuild48
5 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 18c2b1ea6fba..ddff8b6f2c38 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/mkdocs-bootstrap/Manifest b/dev-python/mkdocs-bootstrap/Manifest
index 92149b159fa3..c6af83d92a20 100644
--- a/dev-python/mkdocs-bootstrap/Manifest
+++ b/dev-python/mkdocs-bootstrap/Manifest
@@ -1,3 +1,5 @@
+DIST mkdocs-bootstrap-1.1.1.gh.tar.gz 233329 BLAKE2B 58292946d0985ae60d8d9784bcdc3e9f71640d23fd81efae06b99ce644aefc63d53d21bb65a0b4c4d6bb0b077cbac82bcd93da3f5d05f244bdcfa54750478fb7 SHA512 9be5c29961c09436332f902fffd49aee38f99fe8b7337e2add7d6190b1ed487b16a0d2dc3ebd486691719bffd1009207885b3880238a64bc6d2baafa43b0fbd9
DIST mkdocs-bootstrap-1.1.tar.gz 233231 BLAKE2B 64470a4e5ca6d44976944c16244daaefa99702fa68d68fb14e31201fcfd5f927dc2b962fd0b1967a6fd7eec8719389a78dd13cbfcdc387fa6de5f21c9c1a4960 SHA512 a494afa614f96771fbc640862b5cb5674d4eb5c978a56e86e2f523137fed315808067f20cfadca463cbeb5384de062c91001b6eaf5f3ebdce329f167b461d2b5
EBUILD mkdocs-bootstrap-1.1-r2.ebuild 499 BLAKE2B e0a8bbc4479f259b9e585bde9d224bf45d6f552f0e0ab6891b8adc0ebee15b16229ae575836207d584b5ee4068b2372afad0091ab7e23de4a131b5f80e560258 SHA512 b92939905799ec964c7d4c09cdb841ad5a5afd70b02e19169ffac58decc6f6ac4e1624e52e505e094fe02de07984eb58ebea06f3e797a52152a1c610ca8d082f
+EBUILD mkdocs-bootstrap-1.1.1.ebuild 620 BLAKE2B 7523691cb3f7d596fca92f40679b0ce5ff7d78d4de160d8dfed2dfeaf0311c055ecce5ca30e36204dcb16a2e5932af5fa5bd6e46930d9ec46e2415c2c31424df SHA512 f5136b91f3a21b764e72e47c2cb452f86c306dd7d473291efaef863e30f4db333bfd39414f3459bf8e3f0d3d31e8668cba72a715a237a65c6eebf15962845013
MISC metadata.xml 449 BLAKE2B 991a60ba78b90e5b405993269c325a7724fe2c8977836ad2fb15e5c4b429236e7e03be4f6f91dc81a954403036e39cb30ea419a1a79589b1b33e63b3220630ea SHA512 ce0378db70f5c4d524ae77bdc4b40c99ede5741c49d59669d63ad026ad85dfc57e11880fd9476021f2d1d080ff8e4540a07bfb2f50fe34afecfaa77bec78a1b7
diff --git a/dev-python/mkdocs-bootstrap/mkdocs-bootstrap-1.1.1.ebuild b/dev-python/mkdocs-bootstrap/mkdocs-bootstrap-1.1.1.ebuild
new file mode 100644
index 000000000000..22107fefe4eb
--- /dev/null
+++ b/dev-python/mkdocs-bootstrap/mkdocs-bootstrap-1.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+DOCS_BUILDER="mkdocs"
+
+inherit distutils-r1 docs
+
+# No tag, use commit instead
+COMMIT="70f2c3395adc3d64d6f9b6ff5bb01a4f0db72ed6"
+
+DESCRIPTION="Bootstrap theme for MkDocs"
+HOMEPAGE="https://www.mkdocs.org https://github.com/mkdocs/mkdocs-bootstrap"
+SRC_URI="https://github.com/mkdocs/${PN}/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/mkdocs"
diff --git a/dev-python/mkdocs-minify-plugin/Manifest b/dev-python/mkdocs-minify-plugin/Manifest
index 886eb4d9e5c0..389a1f70ca18 100644
--- a/dev-python/mkdocs-minify-plugin/Manifest
+++ b/dev-python/mkdocs-minify-plugin/Manifest
@@ -1,5 +1,7 @@
DIST mkdocs-minify-plugin-0.6.4.gh.tar.gz 8792 BLAKE2B 42dae53b6918655f27f26521e84b42a97e75d7b8f1ec526165341810fce9b0c6bf0add9f451d0122b68e2543deed98a2661ccaefb4b51262fee71964ba3c5bf9 SHA512 d5adf7df838f10abad79c5790c3aefec11ac78078cc5f0640213a2e097cb251a16eba39d9aa6f53996a983d08bcd4558718754d3bd11af74cf407faab3f97453
DIST mkdocs-minify-plugin-0.7.0.gh.tar.gz 8856 BLAKE2B c61cd0817f4e224ca22b71c395a4bfd0d144cf73ac39417dd2293176e98f31fd797a43c3c43d38a0232c5e287c9b6a84273171bdbf4d2eda5ce757f5b19188f8 SHA512 d14b2050bc8acca03532c46d44418d37401a6bd8dafe727a8331e46a57173044f8bb7f461c62eaa3bcd6ccd88065d9a999fcdfdce9b04d5cd62dd858c5ab0d2b
+DIST mkdocs-minify-plugin-0.7.1.gh.tar.gz 8935 BLAKE2B d5b29515a40068dd01894f7dffc54ad627fbaa6e3efaea91c19ab4fb3571dcfba00f1ec9f2e23869dc4bd2bf97dec2a872a8e91fd928dc628f6a0fc8fe455539 SHA512 c8d732cf7906c37b754ad7d5c2132a88d1175f5da453aa53ac390ae2c0461e8a8ed6ffb88c64c8bc627be593e5f9e1f9b8d9e44181c29bee60188d4a9a3a254b
EBUILD mkdocs-minify-plugin-0.6.4.ebuild 1033 BLAKE2B bf8df80f7e55b306ab1c6309d42d2dcd70e11b965bf582201ed89a5ac12d998d3ac3c957d6e29abb521416d97548198946762c8b509472810fd9a9d5a855a038 SHA512 261c10a40219bec4037369793e048a98099d727e42a8ffb66986cc08ff8628ea51a865541d7e7783083d7d3dc0740c8120d26d8e635676540a451b14325ac762
EBUILD mkdocs-minify-plugin-0.7.0.ebuild 1186 BLAKE2B 214d857505ba91b477eac8e8dc11e5ab6d951fcf4afcb0df1040156a5b0c08a350cbf347fddbcfe53b72d74acfb6d150db18baa953cc7dd3e27d2cf6b88a50f2 SHA512 740b7fb7d97a8049b5d9a0bd5f9d7bc56feff01eed40a4443aef6f7eee018e06c1247092196fcfb8f3ba004833b26024d982f2eb3f32f367207f15edb43144fe
+EBUILD mkdocs-minify-plugin-0.7.1.ebuild 1186 BLAKE2B 214d857505ba91b477eac8e8dc11e5ab6d951fcf4afcb0df1040156a5b0c08a350cbf347fddbcfe53b72d74acfb6d150db18baa953cc7dd3e27d2cf6b88a50f2 SHA512 740b7fb7d97a8049b5d9a0bd5f9d7bc56feff01eed40a4443aef6f7eee018e06c1247092196fcfb8f3ba004833b26024d982f2eb3f32f367207f15edb43144fe
MISC metadata.xml 437 BLAKE2B 0b089b896a3b9458b03573a6f2870ee98c194a76969cb730508582aaae75cd5ae3fc46739ba12850a2388cf588aa68c6a45e31a59a8f1894e7eb02fe78d74992 SHA512 f238ac7d118776d582d880a4355d0786dc5d9b3f82e9139d5668fa9be009eeb7228a0bc0b2d5254e76b167ec30457241b808917a910b8d2037c781e46a871946
diff --git a/dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.7.1.ebuild b/dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.7.1.ebuild
new file mode 100644
index 000000000000..55254d02d421
--- /dev/null
+++ b/dev-python/mkdocs-minify-plugin/mkdocs-minify-plugin-0.7.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="An MkDocs plugin to minify HTML and/or JS files prior to being written to disk"
+HOMEPAGE="
+ https://github.com/byrnereese/mkdocs-minify-plugin
+ https://pypi.org/project/mkdocs-minify-plugin/
+"
+# pypi sdist lacks tests, as of 0.6.4
+SRC_URI="
+ https://github.com/byrnereese/mkdocs-minify-plugin/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/csscompressor-0.9.5[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.4.1[${PYTHON_USEDEP}]
+ >=app-text/htmlmin-0.1.12[${PYTHON_USEDEP}]
+ >=dev-python/jsmin-3.0.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # this is a fork of htmlmin with the same patches that we have
+ sed -i -e '/htmlmin2/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PATH=${T}:${PATH}
+ cat > "${T}"/mkdocs <<-EOF || die
+ #!/bin/sh
+ exec "${EPYTHON}" -m mkdocs "\${@}"
+ EOF
+ chmod +x "${T}"/mkdocs || die
+ epytest
+}