summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-26 10:34:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-26 10:34:57 +0000
commit6819e3514f137590abb4b6a9a7ec68f82d4e8d4d (patch)
treea180edfec1f5b5e91db0b4cbcffc23d261d40e7d /dev-python
parentc5ca18eee76dfed87e06ea7b99017878b77d4d24 (diff)
gentoo auto-resync : 26:11:2023 - 10:34:57
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin270233 -> 270224 bytes
-rw-r--r--dev-python/django-timezone-field/Manifest2
-rw-r--r--dev-python/django-timezone-field/django-timezone-field-6.1.0.ebuild42
-rw-r--r--dev-python/ytmusicapi/Manifest4
-rw-r--r--dev-python/ytmusicapi/ytmusicapi-1.2.1-r1.ebuild22
-rw-r--r--dev-python/ytmusicapi/ytmusicapi-1.3.0-r1.ebuild22
6 files changed, 44 insertions, 48 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index f0ff6a7a2a5c..4e96e45d7e32 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/django-timezone-field/Manifest b/dev-python/django-timezone-field/Manifest
index b71c98b3a1d7..f719439d2a4c 100644
--- a/dev-python/django-timezone-field/Manifest
+++ b/dev-python/django-timezone-field/Manifest
@@ -1,3 +1,5 @@
DIST django-timezone-field-6.0.1.gh.tar.gz 35800 BLAKE2B f3b46970bbe234f786988d8c71a016c382ea3d82b798eaf78e685f86a80b3ebd3ee495d0f0230afb84f594b443548d9bc1e8891ea37c08be478bab388edfd70b SHA512 e6d1631af6a4d93f2fae236cf12d8fda15dfd6d70ee01c496364c3e5e141fff2bb5982f607adf474617a86b9f0f611306a17d1d892556a087424110ee3de541d
+DIST django-timezone-field-6.1.0.gh.tar.gz 36029 BLAKE2B 5177b440e0537fbde12e0dd4bf92e65c983996f7ef1393212b0f4c24efecfc0d4d24e1bbc8447295b565d8b9921c0c05f6cc4baa11db3ccc9b60c33c48e76fb2 SHA512 b070e55a2a5196de1fcae4bd19979caf9d84c234a4e379d82dab843541cf99a0acced9a6996e35afe6b40d1bf737d522d34b91df10596e7365f85cfbe0597015
EBUILD django-timezone-field-6.0.1.ebuild 898 BLAKE2B 81e7bc3368f2c97ddb35304f60febe35fb48b7d351ecb44176799146ed3128426989bf4e60e1a25538e85a964a01503ddec8fe06f742f482d32c5c801bd8f28c SHA512 8f48e1cfab2eda74988403b09f32eb66f1dccaa0a6a8ccf867353cc1eac331cfe888e508ad6e4f0a244a96b94847c0af229ba65ca9d20ab3006b4b6071e4755f
+EBUILD django-timezone-field-6.1.0.ebuild 898 BLAKE2B 5da8e160226cb702dc7210ed73fd98dd3cd89555e1fbcfead8f5eb24ad4857d4f180db7ae7f440da1733938562094df58ff54681950fb2b5cce455232116f6a9 SHA512 8cefb9f995a825ae827f8ce2129fa62a90c242eac087cb7ac4fe150b347aae72086b7469686b08887e716780de052f90dbb1393b5a67228e9616285981b5fb2d
MISC metadata.xml 417 BLAKE2B 8169aa146e3ea17598ed401420f9504deccb4fdf4faea57678073d7fcbf7cf4062aaf4e00d4c2eb80a29276b298b144d013b8baedc8b5277ff30bc65dff4f8c4 SHA512 09c5d7dcbf44b72631d63dcbc98e4dd203c28f24ffb5d5e833f6c36e641b4360b096ace62e12faff182fc26fd60fd5f4f9eb3ebf3e463fd0d1afc66fe9a70e6f
diff --git a/dev-python/django-timezone-field/django-timezone-field-6.1.0.ebuild b/dev-python/django-timezone-field/django-timezone-field-6.1.0.ebuild
new file mode 100644
index 000000000000..a51019e8569a
--- /dev/null
+++ b/dev-python/django-timezone-field/django-timezone-field-6.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django app providing database and form fields for timezone objects"
+HOMEPAGE="
+ https://github.com/mfogel/django-timezone-field/
+ https://pypi.org/project/django-timezone-field/
+"
+SRC_URI="
+ https://github.com/mfogel/django-timezone-field/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ <dev-python/django-6[${PYTHON_USEDEP}]
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DB_ENGINE=sqlite
+ epytest
+}
diff --git a/dev-python/ytmusicapi/Manifest b/dev-python/ytmusicapi/Manifest
index f4f71ad7c7e8..cfe77420343b 100644
--- a/dev-python/ytmusicapi/Manifest
+++ b/dev-python/ytmusicapi/Manifest
@@ -1,9 +1,5 @@
-DIST ytmusicapi-1.2.1.tar.gz 71105 BLAKE2B 852015adc0b15a34a1a808810c37bb15d6a2ed7bf1fbcd1dfa8dc3559115842a325b9ce45630ed620f15c113d1f75b3811ab4d9b2cb4416ae4b08903ca1c91c7 SHA512 758050e30f6e328aeb0a43b440cd9bab9719730203073def810a33071f7b5c01a34b83ed3615cf4010f54c29b768f166b4a76ab6a49306f8d299f4a933af21aa
-DIST ytmusicapi-1.3.0.tar.gz 71560 BLAKE2B 168f120e9306f52f61fcaf6945be89625f6438e89d3b490d2b3430bc7d5cebd74ef9ce56b379879084794ff37fb845bbd167c73a7f4fa5880b04c147e95d1981 SHA512 d1e29a6d7908ca83263ce16874774c33a611229f0e33965dc6294820a6871d7804a43239ee88ed4b683b3565be728b7ac3a2f83ef0de9310590509514578d155
DIST ytmusicapi-1.3.1.tar.gz 71721 BLAKE2B 573f3987805e2eb8cabdc1b04648de4c95d17ee66690c6f0d4832cb008430ab1eb758e1ba8bf62ab4f6a92351e74efe7c4c99a96c81e815e6a352a44f0e70334 SHA512 f68efbdd1178e7fd1c1f2a77cfcda9bce395aba6f2898fcc0694701be31c6aa7795d196845da5b03cce5222d2592e9bcd4ea2c620dae32a4878b60e9c45f522b
DIST ytmusicapi-1.3.2.tar.gz 71732 BLAKE2B 957c2b88ea2c9e59c81401762e4dfd4a52a2f5d3ba59653d2556c3d29225ab4bd92155070e75812f302430b453a5c32a2f44fb508b24905a8f0d16c6fe51299b SHA512 c9ccf7999d668502549e4b5393682192d1db2851660444b6255d5bfb2c0c994ab4715800b669bf57d60866aef7c5529ece374c1eda8d945c7008477438dd0fdd
-EBUILD ytmusicapi-1.2.1-r1.ebuild 504 BLAKE2B e94d0beaec9ff24ed842ea5d39bac5e426739752d84b2cc77ae3ab7733061f86d7cd225ce1f89f333447e0b2a474813c3d198c69e90bdf4a7e4d506d94fe0cbf SHA512 9150df9687f787c6f5dfbe2c81bacaeb9c1e57d98bef17963462f339b260a59e02c84b83d275341bc24400570ce9fd0ba4bb6a33ad054236f74e8df4bf5b158c
-EBUILD ytmusicapi-1.3.0-r1.ebuild 505 BLAKE2B ed6bbac253081001dd26b715b44facf3f9d1a69721cb51c5b3022c7ec9358d58baf2be1ba624ef61cdea4655ef4c1cef35ccd70f04ecdf018af9656e70d07c53 SHA512 ab9aa232c0ad8000f6564fac3e15a7ccc912d2658b2e18551822c73dee3b7ccbed5a99b3854621780b3c31a9feb5455c1582336374cfaf7050f7d6d4cb5854eb
EBUILD ytmusicapi-1.3.1.ebuild 504 BLAKE2B e94d0beaec9ff24ed842ea5d39bac5e426739752d84b2cc77ae3ab7733061f86d7cd225ce1f89f333447e0b2a474813c3d198c69e90bdf4a7e4d506d94fe0cbf SHA512 9150df9687f787c6f5dfbe2c81bacaeb9c1e57d98bef17963462f339b260a59e02c84b83d275341bc24400570ce9fd0ba4bb6a33ad054236f74e8df4bf5b158c
EBUILD ytmusicapi-1.3.2.ebuild 505 BLAKE2B ed6bbac253081001dd26b715b44facf3f9d1a69721cb51c5b3022c7ec9358d58baf2be1ba624ef61cdea4655ef4c1cef35ccd70f04ecdf018af9656e70d07c53 SHA512 ab9aa232c0ad8000f6564fac3e15a7ccc912d2658b2e18551822c73dee3b7ccbed5a99b3854621780b3c31a9feb5455c1582336374cfaf7050f7d6d4cb5854eb
MISC metadata.xml 589 BLAKE2B bf51d5de92082a99ffb69839a9cadcea1d740f05d83194b951383713bcfbc4c95021ef27382cc6020298c3b8817553549ba150876c1398094dcc9a7de38bc04c SHA512 d34382f0041b2f74892661880ee7a318d7571254b18bf41d1152560e06f8d1b2da7432b4e9eb8a0d8b6cba645da9a3bf9c6a7c33002471a17d8c516c0aee8f70
diff --git a/dev-python/ytmusicapi/ytmusicapi-1.2.1-r1.ebuild b/dev-python/ytmusicapi/ytmusicapi-1.2.1-r1.ebuild
deleted file mode 100644
index 25bb762afaca..000000000000
--- a/dev-python/ytmusicapi/ytmusicapi-1.2.1-r1.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Unofficial API for YouTube Music"
-HOMEPAGE="https://ytmusicapi.readthedocs.io/
- https://github.com/sigma67/ytmusicapi/"
-
-LICENSE="MIT"
-KEYWORDS="amd64 ~x86"
-SLOT="0"
-
-RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx docs/source \
- dev-python/sphinx-rtd-theme
diff --git a/dev-python/ytmusicapi/ytmusicapi-1.3.0-r1.ebuild b/dev-python/ytmusicapi/ytmusicapi-1.3.0-r1.ebuild
deleted file mode 100644
index 75a0cdb04926..000000000000
--- a/dev-python/ytmusicapi/ytmusicapi-1.3.0-r1.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Unofficial API for YouTube Music"
-HOMEPAGE="https://ytmusicapi.readthedocs.io/
- https://github.com/sigma67/ytmusicapi/"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-
-RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx docs/source \
- dev-python/sphinx-rtd-theme