summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-13 00:16:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-13 00:16:09 +0100
commit395f02db08a3f738bacbe8fbaa9fba11084f4e73 (patch)
treeb0ae09385e419830243aa68696919747e97fd1ba /dev-python
parent36c436b12f9ef2523e5fd963381b78d2dc5cc53d (diff)
gentoo auto-resync : 13:10:2023 - 00:16:09
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin267634 -> 267642 bytes
-rw-r--r--dev-python/django-registration/Manifest2
-rw-r--r--dev-python/django-registration/django-registration-3.4.ebuild32
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index b91c2b71c647..a79c597fda32 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/django-registration/Manifest b/dev-python/django-registration/Manifest
index a975d50a3aba..e4720c7986a7 100644
--- a/dev-python/django-registration/Manifest
+++ b/dev-python/django-registration/Manifest
@@ -1,3 +1,5 @@
DIST django-registration-3.3.gh.tar.gz 77483 BLAKE2B 4d65479983a5aa104daffe07ed84218250893ccf6df44e5533473d587a6e76fe71c905124af3909efda515ea84df49f27eafc32f23480ca3e1f6ef55607b3cd7 SHA512 66ef0de4c1adb303717cf87e9d3ce7ab07ca60bab64cbc810f61f31d05a968c0b4fa216b90e7ad575e647c6fdb789ea875c428b0ca8b0104d055ed0882aae144
+DIST django-registration-3.4.gh.tar.gz 81582 BLAKE2B bc3ee4ed806486c8a0422cc4ef62c2628f6b5880e0aa63ffdfd5ba7f90967c96c5cd7555faf58254e0a49bdb025b9bdf8eb212bfce4596db7db4f97e4eb3400d SHA512 b6c87cbaeb9548e2c2d8672078b5967aee1e881c2b880193ba410a8c293c93fd0c8e57abac8deda2cb6f61a11936fd5c72060e4954f1d74de1e3a3646b63885b
EBUILD django-registration-3.3-r1.ebuild 696 BLAKE2B e4fbc1757697f26f0786e1c01f79b1df654f2aa288f37fa5658c7cfd93d986aaac228f162d0a3812182e9f622b2f95f0bc75c57e5c9fd689f49376a2e3121c01 SHA512 182cea2eebde5eb18b8158d562a1bd3e33cab17366f8e12eefb32b7b53034667b9d425eb2fff28edb6baf8f86fdec402565f52b44c3f9d94b95607b74d7835ef
+EBUILD django-registration-3.4.ebuild 753 BLAKE2B 5a35c0cf1b4e1ba21d6fa0d2c1990b4d2b0180f3a338b668893c3071ed6e379e5cabafed45ef936d93a429bb9f8af678ab5a5496686d5a5f8da3580544d694d5 SHA512 346d3b60f67fb016f1befe0f49cab630bf9818cb636ecd2415187ee0d334359698e938964b2a68edfb4bd682bead70657b065bdab8ef1bb1adceac044933083c
MISC metadata.xml 401 BLAKE2B 695741a0b4b269cf5f259a00fbfa4527872aa396495468b9996a78be679238fdf67986185cb00dd616d048a6ce5d4aa9525b99dbe1af4c980d5caa9bc6936368 SHA512 79fe2b9fe95515d02be6b910273228c9b9b63e598ed1868be6e3c7895562db1362b9304bf9858c76fb3e6c7efc8bada88f2a74c756b72a024ff171fd425ca761
diff --git a/dev-python/django-registration/django-registration-3.4.ebuild b/dev-python/django-registration/django-registration-3.4.ebuild
new file mode 100644
index 000000000000..36c13a4671a0
--- /dev/null
+++ b/dev-python/django-registration/django-registration-3.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="user-registration application for Django"
+HOMEPAGE="
+ https://pypi.org/project/django-registration/
+ https://github.com/ubernostrum/django-registration/
+"
+SRC_URI="
+ https://github.com/ubernostrum/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/confusable_homoglyphs[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.settings
+ PYTHONPATH=. "${EPYTHON}" runtests.py || die "Tests failed with ${EPYTHON}"
+}