summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-24 13:37:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-24 13:37:40 +0000
commitba4938837d52c0aff763d8acdc03ce103dd3ff82 (patch)
tree377739d379f8040dc456a89b2347a8f2a83830c8 /dev-python
parent3e3aa158fd100df495010eed7915f012d5c9bcaa (diff)
gentoo auto-resync : 24:12:2023 - 13:37:40
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin269002 -> 268992 bytes
-rw-r--r--dev-python/distro/Manifest2
-rw-r--r--dev-python/distro/distro-1.9.0.ebuild22
-rw-r--r--dev-python/minify-html/Manifest3
-rw-r--r--dev-python/minify-html/minify-html-0.15.0.ebuild40
-rw-r--r--dev-python/pygobject/Manifest2
-rw-r--r--dev-python/pygobject/pygobject-3.44.2.ebuild80
7 files changed, 149 insertions, 0 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 8b9a8f60140a..e0329413f2fd 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/distro/Manifest b/dev-python/distro/Manifest
index d6bd94e065e3..502071d466bd 100644
--- a/dev-python/distro/Manifest
+++ b/dev-python/distro/Manifest
@@ -1,3 +1,5 @@
DIST distro-1.8.0.tar.gz 59428 BLAKE2B d1b47dd801c4414a6bb21c544c62c306a1cf49b43f70974f7a0b4bcba64620047c7d06b6507ba262eba44d2f192f654646bb69241ed5bf6b761dc9d42e049e18 SHA512 027fe8bc50e263dc49451932774f32cea7900820b6e30cc80afcdc84374777ba733137fdd8d27fec76f66ce9c579bc172721e7ae0f43e72dffbc092126b26af2
+DIST distro-1.9.0.tar.gz 60722 BLAKE2B 1713bbc10b74122e47e9d491a7559a871c81941f35fde74714872723d3fa3435fb15bb29197eb6b6f09e5192fb7e3162e63d5b628ab813befeca3872c49dc53d SHA512 dc66cb7e968e7a651c7a84681e2a0539d196073f71cf0ae1e49c5a6cd6deec345523259a8810ffdc7b6e9763a536eb388a2886ba2bbd1cb62165b57fbefb82ae
EBUILD distro-1.8.0.ebuild 605 BLAKE2B ea15eb5a7f2d873fbd69263336e17c80f82ea470416d9719f35ca2f7ea718e3ba75d1fbd1a7e181a9e32d64266cc6925147089a9cc4fc4bbc65de49776f5ccf5 SHA512 b7ccf0b8f4eeee649e53839540adb876112d7350c7c3069eae53701dd634b40c5c6fa0f9b523a3ea4eb3fff75f44a5e61f3da8aacb97cd4fdc409f981f00aa16
+EBUILD distro-1.9.0.ebuild 612 BLAKE2B dc9512c90308f06967c38e3ec344d262dffdfffc3437d9493650bebb75d8ca3611ff5bd870e56ce951c95e59770fc218cb916f192ba2c38bedf75a7441198077 SHA512 18866eb4964b27890fe7dabbdb647f39177ec87b0c025577714f4cd390b01e8d2b4c61042ab9c528c2f3ee61934a2f39dbc2c8087deae58edc6240c19fbfcdfa
MISC metadata.xml 847 BLAKE2B 62f2559f30efb777b18c61efdd9c957ca1855ed90bd35c93d492225369f1b293120a3c765412b00c2efde0d2a96b6e924ffb8f5d5a2a0bf305f142d29f88a6a0 SHA512 af4a1c5373c4d2b324859e736632349214c33a6f256e2e69be4ad6a8bedf3c8adb670c187dbe16fd9a546d347639e61ac117bcf2918438f290dc8c5cdb13f89c
diff --git a/dev-python/distro/distro-1.9.0.ebuild b/dev-python/distro/distro-1.9.0.ebuild
new file mode 100644
index 000000000000..e2d93ec9c34d
--- /dev/null
+++ b/dev-python/distro/distro-1.9.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Reliable machine-readable Linux distribution information for Python"
+HOMEPAGE="
+ https://distro.readthedocs.io/en/latest/
+ https://github.com/python-distro/distro/
+ https://pypi.org/project/distro/
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest
diff --git a/dev-python/minify-html/Manifest b/dev-python/minify-html/Manifest
index 82cbb1492f82..87917d246dd1 100644
--- a/dev-python/minify-html/Manifest
+++ b/dev-python/minify-html/Manifest
@@ -15,6 +15,8 @@ DIST memchr-2.5.0.crate 65812 BLAKE2B 57966413a1f933dcb2d2d4ccb29c247070f65a8329
DIST memoffset-0.6.5.crate 7686 BLAKE2B 9a797388702389076c426052c3d54dc62802d5db8bc5c9c83990429f2ffaec4fab4c7dd3f09cd0704d1ea555e87976563bb43408ba54b5e66ce7e406d4604009 SHA512 11bdd9185b99dfee8e659e051b09ee301c7142a372a8117864745a5085c015436d2efbb1478192886f09cbc562529e209d2e3325d94938a64bc75b1d91d2bf3f
DIST minify-js-0.4.3.crate 18268 BLAKE2B a64c99431850ec60fce05d78d191a4824441586f4a884251e3fb9e5fcc91d497fd40a2ce954e246fb513081736a284a4f28c3e2309516fd230f82c49d72e460e SHA512 e53af3733a2828ca049a51f2088dcf5a3c151210e06f54d1ded9799cb292a142fc87f4f071b870fa8e326dbf58bcf07bc1604ca53296a2192aa4ae3bc16cc1e9
DIST minify_html-0.11.1.tar.gz 136368 BLAKE2B c28f860868f6456dd67bc64960270bf94af58b3cc72c131ba03c3ca999747f0d35a1fcf1db6859bab962f80157decc8a9d7bd693fbb3477f7e59a9d8f0fec36b SHA512 36c494c57eab502b17752359197d9062c4f928031dbd9c642b09fc8d26ff9f93c7031e845d6b3a2a82f4200e95bc7446b239cb9683b104d86062c2d28e41e33a
+DIST minify_html-0.15.0-crates.tar.xz 22011872 BLAKE2B e23d0b978708995f75aa2ca0a4bdf9bcd5a967a310d7a709941ba83a54487018071a9ab4794232f9963807308e3d63afa7e219b112ea73dfe29ff828d66b84b2 SHA512 7f15918faaa634d1ac9ddff071f410594eb4a1a432b74eb999dc037d5734b0c17c9e831440b50797f025a010d51e7b84cd9f2cf6e645b726a796612d6b4ea710
+DIST minify_html-0.15.0.tar.gz 96948 BLAKE2B 24fe7b747d389a2876210b2774cfad8a623a5549c86fdcb9304d6521a7ef1ab85c770fbfe03a5d6812c7a1d282f409e93132db83b64ea16d4b3fe88c762ea71f SHA512 89b4e40a3572958b6d79985537f9fe9aa917ff94afc72b44f74202298128af71fb0618c1ca50af445da678806b44959d390113d404ae8ad0b75660564095159f
DIST minimal-lexical-0.2.1.crate 94841 BLAKE2B e6b8919b80d938d0b98d60d4f5f29ce43d77ebfcf8b18bde08909141915c6ef4f0d07a543538d4f3ba8527a9f55926d4a8e83473248469d087e80b274d701d61 SHA512 385fab51884bdcc7b0f2728a219ab164d0dc8efe42160b918f2c09f79ecf853fb12bda006d11e649f097bae1499dcd41ddf2a8784ee7d178cf2c28059e46078c
DIST nom-7.1.3.crate 117570 BLAKE2B 5643b67990b7305e101b16b8cd27c447e162a7adc6d0dfac00920b0cb50fea98c9d4edca63c34f6845cba05f8d0acb407cf3045cf64a4cb28e53c8b6bc9090cf SHA512 1ffce08dde299bc0e0367ad59c7b6a83e23decfa11115ee076ab91ec53cdd9ef37e4c2103c96eff23a7b6b8b5c3f67c83ce1917928c7d4c6462083bdfa0c9cad
DIST once_cell-1.17.1.crate 32856 BLAKE2B 8bde2aaaf9ef45d1f6b8458686179f1fe9295ee8faea269e9b49779583ce26ab9dafe988c3584e841a9e5d05e28430ca967ef3b25e755f48f0120d9c99cdb7bc SHA512 1302d51801e38bfee23e74c0046f1ecb1d3c27309b5fe11c2b6c99553b357db502ce1718695602f9d8b10429e8ff03f91c016d5d604957083728293824c05904
@@ -48,4 +50,5 @@ DIST windows_x86_64_gnu-0.42.2.crate 699373 BLAKE2B 01c70809d564b16b268656e47295
DIST windows_x86_64_gnullvm-0.42.2.crate 364068 BLAKE2B 64bc53e98eb3fc649c9b43a6e734de4e65088e41edacabd49f7afcc5dc6e1065c563ecfc682747dda05978dea2dba4f45c16fcc18c3b00684c3d93681e5a7deb SHA512 d39a8bc948110fe612d3f8d6628b3f0d56620df11d8a49e0fabb6c90389ad407582b3af10e4eab46c79b3d11d2e10753d73d9e55963fbeac085f41e9749bdba3
DIST windows_x86_64_msvc-0.42.2.crate 666936 BLAKE2B bc3a456e7f8bc272f8978ec69506ec9d89f97b7582ebbe05d8bd57bdf8156ef62d0d2dc6137a97e81d54059d70db97a24af9a038adff357f5dfd28805d6193b5 SHA512 53a35f438903fceb59e36bd2ac331773fb8e6c8c5a6d984e79021761f91b3b4a23efe49d219667a4d0d23dcdbf906da9c24e74fb1cff93395b5c55ff524e3788
EBUILD minify-html-0.11.1.ebuild 1613 BLAKE2B 1c4c8a4819c76feb91b1b1f912d378bf4dd5f61f37c0fa3887ff252479ff29429564a01e402a5be4c21f0db0a1470384794d88a7f813193fa2de8d3d7d530941 SHA512 7ab07c8322fee80d063e68bb8c7de4983a5406a1008506598cfd0d1f756eca556f5ced7dff45d9a17ea618ea41d6f56af5da6a98978bcc189ea5c8399e6e3516
+EBUILD minify-html-0.15.0.ebuild 834 BLAKE2B 401e6632948d9271350e8e38cd90234a236e0572d71b8326e9713247abe2574037b7a58782127df7fa3dde924ddf8ea6504c480259ae0b3d52754c7b0df4e7c0 SHA512 c1c2e0a2b3b7a7b5ce5fdd6e6c9ba537db377bfc0ed1d7987184d5f1811345b78e6868269bbec5f7255e8a8761f3ab6599029acceb22728caab61cf171bf6819
MISC metadata.xml 355 BLAKE2B 3272cd863755bc6cdaa46183ce8151602bf8972f6c6c7e7d1bc5a8299aade51ebb57348fed9d12dd03293b1402309a6b6d2a07b58f1dae61f3c0b11a30c5a455 SHA512 5bdf97a6145ba789fe936430cd19ff09225f3857eee2a5ecc8515638d9d8923d2d3110c894892d5d8f4ce416287784ccc90539def997c4eb5a30c7444994020b
diff --git a/dev-python/minify-html/minify-html-0.15.0.ebuild b/dev-python/minify-html/minify-html-0.15.0.ebuild
new file mode 100644
index 000000000000..be94da626d42
--- /dev/null
+++ b/dev-python/minify-html/minify-html-0.15.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=maturin
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+CRATES="
+"
+
+inherit cargo distutils-r1 pypi
+
+DESCRIPTION="Extremely fast and smart HTML + JS + CSS minifier"
+HOMEPAGE="
+ https://github.com/wilsonzlin/minify-html/
+ https://pypi.org/project/minify-html/
+"
+SRC_URI+="
+ ${CARGO_CRATE_URIS}
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/${P/-/_}-crates.tar.xz
+ "
+fi
+
+LICENSE="MIT"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD ISC MIT MPL-2.0
+ Unicode-DFS-2016
+"
+# ring crate
+LICENSE+=" openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/minify_html/minify_html.*.so"
diff --git a/dev-python/pygobject/Manifest b/dev-python/pygobject/Manifest
index dcd0dfa10fe0..40834a73d48a 100644
--- a/dev-python/pygobject/Manifest
+++ b/dev-python/pygobject/Manifest
@@ -1,6 +1,8 @@
AUX pygobject-3.44.1-py312.patch 1941 BLAKE2B 93af1e4f307e003b7e9cd62b787efa9690724d2cc293ddc571563e7e0324771537d2dd92e6998d30066bb6707b73937cc8cbbca7926666e70f939d0f6cc86435 SHA512 98d470a39d5e3b3f25e41a516d62d364daf2eec92480b31ef80ad79bc3921f53a7fa05bab23be721889ccf8fcd939e5c0bf7d04efd935f7bf9f56bc2e596cc6b
DIST pygobject-3.44.1.tar.xz 559432 BLAKE2B 7edfe91ac1b7301befaf8ef17078b517666467f446bfbe25850336cd365d314153d444d29ecf028ce44a12cef1c94f139d110ac6784c8a2c6077730d4836f6cc SHA512 5f2ff4a068e7e24dcc32f8c43ba58660c85a0fabdd9ff0bac4ddf1ca82bd0fc962ce5cb3ab25b991c212d45e5e89dac67c3259c5423a7d7fd70b2ac1f56e5327
+DIST pygobject-3.44.2.tar.xz 560188 BLAKE2B 6c1cec327aea3ca17a0d60c0b732178c79574073106ad069a76b2bac4aa911d6208b25f23b4508fbaf88b36211cf10bd0d4cfe242c2dae0c5e9363e7d90051e4 SHA512 e0d481285d190f2c9606a61d6104efaffc110aeb57cff6cd08bae72a0528cc970fc1c422fd949c557e3cfc5d6f2e96389824c6fd9888cdfd3ca1ebdc4a05e753
DIST pygobject-3.46.0.tar.xz 561552 BLAKE2B 6b8c9b4bf6df819c09b7bd2ea6dcb0e7c24ed7f171487b774469bd2c4694df9d4473dbde05273afc7a370f2b1f352d60347aa221bdd674a4aa8a54123d5e54cd SHA512 48293c193ba5aece38d99f45d325d0329ac33e88442bf00848fe818a7c838977b8d2cf50a404c30e8852ccc0b4a44dfda07751d51acc21f740aa2ab6aa3ce661
EBUILD pygobject-3.44.1.ebuild 1992 BLAKE2B 0dd334932fbfe25a72f394ff496b6c9bd291f0e3b62520bc5aeeda57324b783116ff7352e495cf37d7fe9d902ad49dc7f0e751aa5923a627fbf0bf4f5aae19c5 SHA512 145a1544194f896ccdd8c26fd5136970b90e660171ade50a1bbd2cbc8e4812bff86677829a6a5f7f6fb7cdc3b9baa4d54786c2bb00a1cc9736cff18a98b44520
+EBUILD pygobject-3.44.2.ebuild 1831 BLAKE2B 3656d95652359ec4e9e3f6cf2026f35bacaeaae44312effe9396e91627e346f23797aff6b2ecd314f045d2b67730237337e96c878b4031175088833c7ee550b4 SHA512 b1c41342c3af19058738161e12ceae32ca840bff558672441f08a7dfd3fa81f65f938c949a4277ace1bb3eadf69f3b9c81badf3551b5d4724cc301bbe0787ca3
EBUILD pygobject-3.46.0.ebuild 1831 BLAKE2B 75e3bb781cd54aa80da3ac7c1f1a79d446a866312cd8627e139ea688e52ac6b622f945250b28e1354395a9ca4686618e9abf97900bc7907b5b4e3fca5178a3f5 SHA512 ba3abcade38c986476879fa023a70e7f48efcd0b7d5b47111186ce71baf5e36b60b3052b041b79b5022dda3bca2bd2008f376ceac0afdcb12a24fd4588300ee4
MISC metadata.xml 1398 BLAKE2B 0f89629267eea1f03252ac53ebf6478977301f5edf58024152b7e25cac1bb238241d419241dac72181bc82d0bda4dc281fe490a72967b730df7087300562127c SHA512 49ec255944b9530fe59ba325925713512ca84d71149b988c034d092d4a433c6f7a23822d685180c343a40055bb5c879980996d34a30cae8fddc617707bc1a417
diff --git a/dev-python/pygobject/pygobject-3.44.2.ebuild b/dev-python/pygobject/pygobject-3.44.2.ebuild
new file mode 100644
index 000000000000..7d183875bdca
--- /dev/null
+++ b/dev-python/pygobject/pygobject-3.44.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit gnome.org meson virtualx xdg distutils-r1
+
+DESCRIPTION="Python bindings for GObject Introspection"
+HOMEPAGE="
+ https://pygobject.readthedocs.io/
+ https://gitlab.gnome.org/GNOME/pygobject/
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="+cairo examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.56:2
+ >=dev-libs/gobject-introspection-1.56:=
+ dev-libs/libffi:=
+ cairo? (
+ >=dev-python/pycairo-1.16.0[${PYTHON_USEDEP}]
+ x11-libs/cairo[glib]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ >=app-accessibility/at-spi2-core-2.46.0[introspection]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf:2[introspection,jpeg]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+python_configure() {
+ local emesonargs=(
+ $(meson_feature cairo pycairo)
+ $(meson_use test tests)
+ -Dpython="${EPYTHON}"
+ )
+ meson_src_configure
+}
+
+python_compile() {
+ meson_src_compile
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local -x GIO_USE_VFS="local" # prevents odd issues with deleting ${T}/.gvfs
+ local -x GIO_USE_VOLUME_MONITOR="unix" # prevent udisks-related failures in chroots, bug #449484
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x XDG_CACHE_HOME="${T}/${EPYTHON}"
+ meson_src_test --timeout-multiplier 3 || die "test failed for ${EPYTHON}"
+}
+
+python_install() {
+ meson_src_install
+ python_optimize
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}