summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-03 15:11:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-03 15:11:57 +0000
commita4d4c6a7cf31d8d3248101dbfd654cdc416902ac (patch)
tree44b6ebe3c3a8ed12fa6e017aa2ad3479ae5fec31 /dev-python
parent06c8293a57349047e228438cc7936e7481ab9159 (diff)
gentoo auto-resync : 03:11:2022 - 15:11:57
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin261791 -> 261959 bytes
-rw-r--r--dev-python/docstring-to-markdown/Manifest3
-rw-r--r--dev-python/docstring-to-markdown/docstring-to-markdown-0.10.ebuild26
-rw-r--r--dev-python/docstring-to-markdown/metadata.xml12
-rw-r--r--dev-python/python-lsp-server/Manifest3
-rw-r--r--dev-python/python-lsp-server/files/python-lsp-server-1.6.0-unpin-all-the-deps.patch51
-rw-r--r--dev-python/python-lsp-server/python-lsp-server-1.6.0.ebuild87
7 files changed, 182 insertions, 0 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 18708c246aa5..5086bb8d7a28 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/docstring-to-markdown/Manifest b/dev-python/docstring-to-markdown/Manifest
new file mode 100644
index 000000000000..7ef5ce5b54e5
--- /dev/null
+++ b/dev-python/docstring-to-markdown/Manifest
@@ -0,0 +1,3 @@
+DIST docstring-to-markdown-0.10.gh.tar.gz 24732 BLAKE2B 8e45db90642a1426da138807d4f8b8147fbf125160463a094f5adfc8e0d76f75b39493560df7cadf39e9b63c1e01763867fff38aac6454d4d7bc7ebea8d873f8 SHA512 cb716fbaa8311bd563f9275eb64bb67d2870803a6c6c6ffce7b15b672260b46359008dc9ff80a99fee3033f3105fdfd77d7a248e7d8a22df695af820eba8e319
+EBUILD docstring-to-markdown-0.10.ebuild 685 BLAKE2B a5ece42e3e075918a6e18e94c25a62023f941d02f54a2a544271990949bab9c41102b40c435874dde1ade948dbf4048af0e6cf7f0bb6b74932b0fd33b254178b SHA512 de61a923d80c07426b5ecbf407a7555bdeeaf7544d6129ac2eab12f921d5ac440969825615b94f4f5833507b25f23be3dd10c962f83b17825d9116f46dd0585a
+MISC metadata.xml 349 BLAKE2B 661c6f1bfbf032dad675ea05faa3d58ec81fac8240c0cfb4bdb8e75b81e12cc1663670fab45201e8e18fde374b59bc60f365558ecb6e4fdb9714f779ea680cac SHA512 fba9f2c707c73fe768f3a50e3b9ed99883359b8ce3122a5b57eb8ba3286d93eaab1b19905188cd8e65440cf9ae40cbcf8b7b5593068773c07c0ea1ea3c7aab53
diff --git a/dev-python/docstring-to-markdown/docstring-to-markdown-0.10.ebuild b/dev-python/docstring-to-markdown/docstring-to-markdown-0.10.ebuild
new file mode 100644
index 000000000000..ada1bafbe9c4
--- /dev/null
+++ b/dev-python/docstring-to-markdown/docstring-to-markdown-0.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="On the fly conversion of Python docstrings to markdown"
+HOMEPAGE="https://github.com/python-lsp/docstring-to-markdown"
+SRC_URI="https://github.com/python-lsp/docstring-to-markdown/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not depend on pytest-cov/pytest-flake8
+ sed -e '/--cov/d' -e '/--flake8/d' -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/docstring-to-markdown/metadata.xml b/dev-python/docstring-to-markdown/metadata.xml
new file mode 100644
index 000000000000..aa180c5e3fc7
--- /dev/null
+++ b/dev-python/docstring-to-markdown/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">docstring-to-markdown</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-lsp-server/Manifest b/dev-python/python-lsp-server/Manifest
index 0a23936e3add..0e3dbb9fb60f 100644
--- a/dev-python/python-lsp-server/Manifest
+++ b/dev-python/python-lsp-server/Manifest
@@ -1,9 +1,12 @@
AUX python-lsp-server-1.4.1-allow-mccabe-0.7.patch 625 BLAKE2B 60880a45b859273e9ac3078210b4a1deffd2d6b88ef0fc7a4bbfb6beefe50291c777e6c1681ebb333b1b302ce3df38e8d21aef844b49d7dc0e3cf0d5bdc76229 SHA512 100728b441d48301d8516ba5ce5396a70c9f30f8c02b8b2eebdd3f9248e534c96c1845f8e327c2f31529756bcb9a411a56c845ff8a802f6cc4ad694b71c48b76
AUX python-lsp-server-1.5.0-allow-mccabe-0.7.patch 707 BLAKE2B ffec2cfbce2741e8760cec724ad36e5d686a7e031032ce5a8d2662ba839b2437b5e14fe2c7f8395eca751085b54a5b9c417a149566033a74bcf2ab12081dfed4 SHA512 2bb3eba93e4f9d24ae1fdac46d4e8aeeb06be6130c139d5291455f0b30c3d71c8c74eb7618ef410530b3e9c58e91c7a88956b898be714fc5b55db98e7ac80f82
AUX python-lsp-server-1.5.0-unpin-all-the-deps.patch 1213 BLAKE2B b4630dc59f3740f77230556d1dfe45e897afb065bd30d7cc15ebb97ec10a1f8d433ab9e772fcb019c8e10e634854b2b42294e243884dd91c4afadb89d744fab2 SHA512 161c861c26e65f5c2ca7735f7286752ba550e8c8e166fc7f2d0b7ae8d76048ad19e92cc1432f19a4a2c8aa0bc85ff5cd3a9bb3a7ed9c0a786c7c79767a58f330
+AUX python-lsp-server-1.6.0-unpin-all-the-deps.patch 1461 BLAKE2B f4a2bda2717370e18c5cc909486d852c985168fcfca042c8f12bff96701a5a7c2e0cc9fce1429870ceed9e2b385e795b5a5b18c919defc07e42933496b19b863 SHA512 8ba0da9a25bde3c1788e9729b1c98fde9f134ec78c3ee9185e61333cfbf90a50ee9f0cbd9fa569bbaae7289cfa75260b848ececc83f6e7d26891f457808ffb73
DIST python-lsp-server-1.4.1.tar.gz 76416 BLAKE2B 65638b876182c478434c563371b802367fb8439820ccf57e4404dc1507f3cd514ae5d738d418386607db606025fe5126a533c656ec3fede53fdcfd364a4292cf SHA512 4c9171adc88d219c80055ebbc76566583925129969467c156277b52de9b5981b74b11b9961247045ea98cd9e51e146b2d606c8351a7be5db76f6f4e0e4d7195c
DIST python-lsp-server-1.5.0.tar.gz 82371 BLAKE2B 3ff388a95f7ae9f4a8e1b41244da1d05e9310e1edcbc7cbd2b17bd4fa0cbe696f31885b2093afb12e879c875b2bfa721cf4e5e9876002f145cf1633238f6238a SHA512 4e3463dc737b4f5f2af0faa8ab2eb10bea8208d4633c22acde9c8ffa2a888b2350e5994dca2a66031e301224a2646660f627d7fc238cbf5103e82a0453a9a809
+DIST python-lsp-server-1.6.0.tar.gz 85242 BLAKE2B 52fcca5a93035a6ec8179908b2139e9392220cad082afb4c31b18284cdd53050c68fca4bcc9d852fa9acb49200487431fec37dc840e61ab9320fd6c3a86189ee SHA512 e4ab52f334fb1eece3458258ed39bf66eeb6056ed7e243be9c69ce2bac92792786df2fbc1d316133ac5523b44a57e7d89d4d6f18120c748e78ef20570a325c9b
EBUILD python-lsp-server-1.4.1-r1.ebuild 3086 BLAKE2B 7b2f1851b082ae6ac5ec8353a1e8d155060197602c4ddb68a1d7487590313dd08ebdbde64d78ea0cada6fd309945824621d45206047fa8e16c290fd90c23c973 SHA512 17b3cf9fa4de342e3455d65f76aae4c1c0c1bcad73fd142974249aa09b08edaa32200650ac89761c42be7ce4722534b47c4913b7727c93443ab584775a64f467
EBUILD python-lsp-server-1.5.0-r1.ebuild 3094 BLAKE2B 894dc5c522e2f54de16a984424dbdab8cd27ba652a5638057c96a269cd73c13afda493beab06bfbd6ecd9716c01a00d81114b00c423227d061f06e3afc178aef SHA512 123c56730b3b9f771966fae2de4ec1115e29fd44b965bddbf169addce637526803a470fc0a475add11f2547e14be9b5eb32acd97e48cf3ef7851204419e990e2
EBUILD python-lsp-server-1.5.0.ebuild 3296 BLAKE2B 59248c3e0a31a00bf18405278ed3ecce81df6135b5e53df76e69f96c51630841955132cd4d857fbf07fa944726c3162a68ac4e9472da6fd0899b2fe5f140009a SHA512 3402de9df0437626ecbab351a383853a72f49ae192e13a477ff7f43593668eb9711115c04f53a2eaced1b24d901f1aa5552b98743c864def7c8d5bd875eb0abe
+EBUILD python-lsp-server-1.6.0.ebuild 2978 BLAKE2B 471f3478ea119f68f09910ed57c7750477b5c56f518118d682f40d408c301156305cf7472e8c44fafb988bd3ab987f92489a27595dd37f226e0ef0261047b76e SHA512 25f9b7bea8adeb37bfee35c493185f94279bd4dafd345685d151557ed6c180cb351e6e5920562f23d3b6646357e80e07a7cbb14b3f316f0d1d16e910f90336fa
MISC metadata.xml 542 BLAKE2B ca71a08385d37c7f5cc562986630ae482970842054ffa944151d2e4a5d8449329b71c16c61e2a81f3d3d93f02a61ce637fe0bd0961ba3f86b7182b9728b62d5c SHA512 2d5103643838ba8aec53e7d3e924517cc3d735c724b6dfea249bcce3716aebb9f54e3264cb2cccc15dfe7d0ad4b7d052388122144fe6248d4faeef3482d197e7
diff --git a/dev-python/python-lsp-server/files/python-lsp-server-1.6.0-unpin-all-the-deps.patch b/dev-python/python-lsp-server/files/python-lsp-server-1.6.0-unpin-all-the-deps.patch
new file mode 100644
index 000000000000..28bc0f84c6a8
--- /dev/null
+++ b/dev-python/python-lsp-server/files/python-lsp-server-1.6.0-unpin-all-the-deps.patch
@@ -0,0 +1,51 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index 8cce90e..18cf2db 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -13,7 +13,7 @@ readme = "README.md"
+ license = {text = "MIT"}
+ requires-python = ">=3.7"
+ dependencies = [
+- "jedi>=0.17.2,<0.19.0",
++ "jedi>=0.17.2",
+ "python-lsp-jsonrpc>=1.0.0",
+ "pluggy>=1.0.0",
+ "docstring-to-markdown",
+@@ -27,26 +27,26 @@ Homepage = "https://github.com/python-lsp/python-lsp-server"
+
+ [project.optional-dependencies]
+ all = [
+- "autopep8>=1.6.0,<1.7.0",
+- "flake8>=5.0.0,<5.1.0",
+- "mccabe>=0.7.0,<0.8.0",
+- "pycodestyle>=2.9.0,<2.10.0",
++ "autopep8>=1.6.0",
++ "flake8>=5.0.0",
++ "mccabe>=0.7.0",
++ "pycodestyle>=2.9.0",
+ "pydocstyle>=2.0.0",
+- "pyflakes>=2.5.0,<2.6.0",
++ "pyflakes>=2.5.0",
+ "pylint>=2.5.0",
+ "rope>=0.10.5",
+ "yapf",
+ "whatthepatch"
+ ]
+-autopep8 = ["autopep8>=1.6.0,<1.7.0"]
+-flake8 = ["flake8>=5.0.0,<5.1.0"]
+-mccabe = ["mccabe>=0.7.0,<0.8.0"]
+-pycodestyle = ["pycodestyle>=2.9.0,<2.10.0"]
++autopep8 = ["autopep8>=1.6.0"]
++flake8 = ["flake8>=5.0.0"]
++mccabe = ["mccabe>=0.7.0"]
++pycodestyle = ["pycodestyle>=2.9.0"]
+ pydocstyle = ["pydocstyle>=2.0.0"]
+-pyflakes = ["pyflakes>=2.5.0,<2.6.0"]
++pyflakes = ["pyflakes>=2.5.0"]
+ pylint = ["pylint>=2.5.0"]
+ rope = ["rope>0.10.5"]
+-yapf = ["yapf", "whatthepatch>=1.0.2,<2.0.0"]
++yapf = ["yapf", "whatthepatch>=1.0.2"]
+ websockets = ["websockets>=10.3"]
+ test = [
+ "pylint>=2.5.0",
diff --git a/dev-python/python-lsp-server/python-lsp-server-1.6.0.ebuild b/dev-python/python-lsp-server/python-lsp-server-1.6.0.ebuild
new file mode 100644
index 000000000000..9b0f7992662b
--- /dev/null
+++ b/dev-python/python-lsp-server/python-lsp-server-1.6.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python Language Server for the Language Server Protocol"
+HOMEPAGE="https://github.com/python-lsp/python-lsp-server"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="all-plugins"
+
+BDEPEND="
+ test? (
+ >=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/flake8-5.0.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ dev-python/QtPy[gui,testlib,${PYTHON_USEDEP}]
+ >=dev-python/rope-0.10.5[${PYTHON_USEDEP}]
+ dev-python/yapf[${PYTHON_USEDEP}]
+ >=dev-python/whatthepatch-1.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+RDEPEND="
+ dev-python/docstring-to-markdown[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.17.2[${PYTHON_USEDEP}]
+ >=dev-python/python-lsp-jsonrpc-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ all-plugins? (
+ >=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/flake8-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/rope-0.10.5[${PYTHON_USEDEP}]
+ dev-python/yapf[${PYTHON_USEDEP}]
+ >=dev-python/whatthepatch-1.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+# Upstream is overly cautious, insists on pinning
+# dependencies to versions required by other dependencies.
+# i.e. pin to <dev-python/pycodestyle-2.9.0 because
+# dev-python/autopep8-1.6.0 requires that version.
+# This causes way more problems then it solves.
+PATCHES=(
+ "${FILESDIR}/${P}-unpin-all-the-deps.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -i -e '/addopts =/d' pyproject.toml || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ optfeature "Automatically format Python code to conform to the PEP 8 style guide" dev-python/autopep8
+ optfeature "A wrapper around PyFlakes, pep8 & mccabe" dev-python/flake8
+ optfeature "flake8 plugin: McCabe complexity checker" dev-python/mccabe
+ optfeature "Python style guide checker (fka pep8)" dev-python/pycodestyle
+ optfeature "Python docstring style checker" dev-python/pydocstyle
+ optfeature "Passive checker for Python programs" dev-python/pyflakes
+ optfeature "Python code static checker" dev-python/pylint
+ optfeature "Python refactoring library" dev-python/rope
+ optfeature "A formatter for Python files" dev-python/yapf
+}