summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-11 23:35:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-11 23:35:14 +0000
commita3c403d854118e8ef0e2d661383445eb2d7ec732 (patch)
tree4c0b622f99f30d948fa1dada7cf6be2c0baaa8ac /dev-python
parent20ba650e8d3869757f6c89b23f8b41500cd64657 (diff)
gentoo auto-resync : 11:02:2024 - 23:35:13
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Levenshtein/Levenshtein-0.25.0.ebuild48
-rw-r--r--dev-python/Levenshtein/Manifest2
-rw-r--r--dev-python/Manifest.gzbin268691 -> 268707 bytes
-rw-r--r--dev-python/cachelib/Manifest2
-rw-r--r--dev-python/cachelib/cachelib-0.12.0.ebuild46
-rw-r--r--dev-python/httpx-socks/Manifest2
-rw-r--r--dev-python/httpx-socks/httpx-socks-0.8.1.ebuild50
-rw-r--r--dev-python/sqlalchemy/Manifest2
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-2.0.26.ebuild111
9 files changed, 263 insertions, 0 deletions
diff --git a/dev-python/Levenshtein/Levenshtein-0.25.0.ebuild b/dev-python/Levenshtein/Levenshtein-0.25.0.ebuild
new file mode 100644
index 000000000000..240940a5e549
--- /dev/null
+++ b/dev-python/Levenshtein/Levenshtein-0.25.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+# custom wrapper over setuptools
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Functions for fast computation of Levenshtein distance, and edit operations"
+HOMEPAGE="
+ https://pypi.org/project/Levenshtein/
+ https://github.com/rapidfuzz/Levenshtein/
+"
+SRC_URI="
+ https://github.com/rapidfuzz/Levenshtein/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="
+ <dev-cpp/rapidfuzz-cpp-4
+ >=dev-cpp/rapidfuzz-cpp-3.0.0
+"
+RDEPEND="
+ <dev-python/rapidfuzz-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/rapidfuzz-3.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/cython-3.0.2[${PYTHON_USEDEP}]
+ >=dev-python/scikit-build-0.13.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # sterilize build flags
+ sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/Levenshtein/Manifest b/dev-python/Levenshtein/Manifest
index 4d7f6cde1384..917d52fe6a51 100644
--- a/dev-python/Levenshtein/Manifest
+++ b/dev-python/Levenshtein/Manifest
@@ -1,5 +1,7 @@
DIST Levenshtein-0.23.0.gh.tar.gz 36891 BLAKE2B 847772ee88a76881c0974a1a9c1ef252320308f17b30b227f8251b0a8b8454c2289e02a24b2a9cb225d34183c5b6e4dbf574b22a5d37a1b453596ff0cb6e0aa0 SHA512 137116f337f576534bf2c12dc49d35f81a3b267eb613e5e6cca6cb80e5701dd0adbfd97c1cec4ea8f1bb4dee2bc67deeb19553474348ea78af4e05b79ce01fdf
DIST Levenshtein-0.24.0.gh.tar.gz 37197 BLAKE2B 75dcce68255b3e14e0ff9cb8e67b0381c7463f8b52f5922fcefc860bc638dc42d070e7a3dec8a870f92981dbb2ac8ec0d238845b5a68561d57f10d1c1721c021 SHA512 b47b903eb5cee3c8dc38fe5a963f20af3bdf1a8df74c1d2ea6d94810ebd37c1fc0c2adbb4bc951245ea72a6196c509dcf18066f3746b94f5b6d5f4414f296a2a
+DIST Levenshtein-0.25.0.gh.tar.gz 39076 BLAKE2B cb3bb55b37b5bfa8dc95d78dc6898154b4d4240c27348c6e03b13cdaa2c8ff19d1e8f2bf3d6b4fcc5c77be917afaa391276e93dcac24c2c19e1b285653a45c72 SHA512 e07ea1cef83c19a2a24ae76647ae2c534213ac6044b50a78dd1f2007936eb46032db326728b420471b6cb63ba6ac80a11c575ab277ae77116c592d113daba74c
EBUILD Levenshtein-0.23.0.ebuild 1140 BLAKE2B 8ef5f12bff40a15cc4bef138833c076e5f273afc07249764fc7cbe7c0af2dd6a10e0b616154c7e9a2b0975fe21b8c2a8e189f212c245aec4d17a49c254d5de6d SHA512 c9f303a5cf20ba14488c4bebb9b4e8fe600998313536b9fdea073fb65a17b2b1db143bc60d0e458a92f200bf7ed9b16890e3f89ccbad7aba6c01d4748277f09c
EBUILD Levenshtein-0.24.0.ebuild 1147 BLAKE2B f8c20ffdec2d355582d470d030908a25c15531527719dbd50f34bb3aca3e4a09776543aa8146c35cfb90b16c7ad41447b91ee7ac9845c85287ef92cd449ace59 SHA512 aaa7382a6daddcb4bf1af107e181f38deb929f709e536172054b197f6b20a47ec157a4fbb7950cc5b72cca0584b846881e4022af2dd40309fcd5dd80c6083606
+EBUILD Levenshtein-0.25.0.ebuild 1147 BLAKE2B f8c20ffdec2d355582d470d030908a25c15531527719dbd50f34bb3aca3e4a09776543aa8146c35cfb90b16c7ad41447b91ee7ac9845c85287ef92cd449ace59 SHA512 aaa7382a6daddcb4bf1af107e181f38deb929f709e536172054b197f6b20a47ec157a4fbb7950cc5b72cca0584b846881e4022af2dd40309fcd5dd80c6083606
MISC metadata.xml 376 BLAKE2B def9cd056f31bd8ef5f0903f302a00ed361fef19a7df2494fc0ebb34f61c098e50288d98d30a292b0614ae2930082bf919fc37612cdc1bef9f5c5d07cdc080d3 SHA512 4b4766b2894b28a2d199a4d98d4accffe4a5197b41b08443d7d57d9363f96ae42400dd717e516aded73197233d779f5cbdf58670244ef162ebf4177f47cffa4c
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 108b329e8c92..ff55d5e7a3c2 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/cachelib/Manifest b/dev-python/cachelib/Manifest
index 10794396f085..eb6f8b61e9df 100644
--- a/dev-python/cachelib/Manifest
+++ b/dev-python/cachelib/Manifest
@@ -1,5 +1,7 @@
DIST cachelib-0.10.2.gh.tar.gz 29249 BLAKE2B 2f15e59f1f3ff2dfabed4076e0e47888d16421b7e94cbe13903a39641d903e044c6879aec3a7ad1673e0bb19d7b668d69316bee9b8f8bb4176125de93bc547df SHA512 7168703bdca228982216c65cd1a765d727813e47a0522d5e84258251b8aebde4d6d561850f97232b4e6c054fe09487e35a251b3992682145ef49c5ff1212488b
DIST cachelib-0.11.0.gh.tar.gz 29173 BLAKE2B f67a33b59d805997c89ee8ec1cbd268b2a12b459a56a3c7161a7fd660e72969c02cd94fd2048f54b256a25e050ce558b20f99d0b44a44dd51ed685894ce0123b SHA512 fd0d271866f09aa93b93579959b92e1d24e220bd3635fc0d16bee93119710afcaa8d7443c6dba5819c3b3ff841d8fe9eff1ebb69db496f9c56a74120644f8e52
+DIST cachelib-0.12.0.gh.tar.gz 30768 BLAKE2B 5d147e63d0be58c7134f851cea79a002aa89b5364aec5c0e0906bfb9573578b094d71f361265b15eb519da897eed069d4aaeae1a8599176a95c074186018a713 SHA512 a35bfa9dfb6db8ae0e6fcdad86e5221d82144d5c0fcdb046b951d193f70f706712800b27c27825f8020314c521eb568131257ce0e20dc820cb3f7f8ffbf2650f
EBUILD cachelib-0.10.2-r1.ebuild 969 BLAKE2B de4e1f30d02ea260274130c34e832944453a023b2c6155a34e551896d3158fbe8756247b29364739aecdd68b3f5c73e6b83cf42f23a9f0888dc4004fbd854310 SHA512 2386b2746aa16d3dff616dde0ec0d3c1d2ebc3c3a8f5ed5844bb194f32a0b3b0e610ed824c573ec413ff258503516a65adc201803b5136af63546ff8be3acf9c
EBUILD cachelib-0.11.0.ebuild 973 BLAKE2B 113cb31001ea00b68e42d9779ca2ba32d91d7f282a6e8676b814656bd6316ed826e57cbb69ca3204b6d1b3aa2f8abd8def8199e21fbe224d7f7ecae0cf7aeec3 SHA512 512b679de3dc5855c0ac90b065891463373975ed1d6aa3d67b3885fd04bf5fab3c6d2b0991ff62b9b027db4cef1c129166ed85df9665a569333302cb22bd21bd
+EBUILD cachelib-0.12.0.ebuild 1032 BLAKE2B 7076abb07312f9a3e5f9b23788a64a96e00fbd16e501738d2f0810f74a4727b38974efa798471c687f2aee99ebb41e888ce2911d3e1bd8efa8bde8119a96d57e SHA512 586793538dc2f2a879efa963b57ce21b05c756e13f8181582d93c1743b9f3125b3e4384fb229de883f2a5151543f911c1310e0bd48a29730cecbfe7a5bb48535
MISC metadata.xml 510 BLAKE2B 456e0e3b13e50fe5fa9fb866ca2a20a63c180a55691d3cc5e63cea2d16e9e98c61d4f0f5d043f8cf73c2fa80f68eb1b29f182b5bec04356fe1c5965799ea4d7f SHA512 caef760fc497745b37e82a3603d360eb3ca173d1c6d1ee47d8cc358c28db2683446e5ce67a60e267f509e6f7688c9ee3aa5c499539752c014f0830af9896d3c6
diff --git a/dev-python/cachelib/cachelib-0.12.0.ebuild b/dev-python/cachelib/cachelib-0.12.0.ebuild
new file mode 100644
index 000000000000..faaba7e5c123
--- /dev/null
+++ b/dev-python/cachelib/cachelib-0.12.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of cache libraries in the same API interface. Extracted from werkzeug"
+HOMEPAGE="
+ https://pypi.org/project/cachelib/
+ https://github.com/pallets-eco/cachelib/
+"
+SRC_URI="
+ https://github.com/pallets-eco/cachelib/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pylibmc[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
+ net-misc/memcached
+ www-servers/uwsgi[python,${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # bug #818523
+ tests/test_redis_cache.py
+ # requires some test server running
+ # (these tests require dev-python/boto3)
+ tests/test_dynamodb_cache.py
+ # requires mongo test server
+ tests/test_mongodb_cache.py
+)
diff --git a/dev-python/httpx-socks/Manifest b/dev-python/httpx-socks/Manifest
index e5a701ec53b2..6e7de9cc6298 100644
--- a/dev-python/httpx-socks/Manifest
+++ b/dev-python/httpx-socks/Manifest
@@ -1,3 +1,5 @@
DIST httpx-socks-0.8.0.gh.tar.gz 15285 BLAKE2B 1da3bffff2be273e62452d96c8e07f38cf3c488bb89704ab377565feecafc1f96e9b96b615dfca4c3721c295414005014f868982a440ed47f3454814545aa6c7 SHA512 f58555670bc689002633daf3cf373641cbab6417636d16e878d5f9fc796b8bf7111d7c6985909590ccaeedb95793f589676e7f36c217330cbf46b4778319a4b7
+DIST httpx-socks-0.8.1.gh.tar.gz 15289 BLAKE2B 08a8431c5818ea653ea27a0dbc3de6708cb81a7129cda779e8c8cbe3d497ccdad0ed646faf06c5138f6c136a74d4c1b06e6e3920fc5362d471aa03372721cd33 SHA512 804e609826eff4c9e321440b657f3c96d688bf27a4e9a1fdd6b07a410f7f7671fef840403d2231a48b53133a8a4db9522f6c46467e78dc2443270fea4116d66e
EBUILD httpx-socks-0.8.0-r1.ebuild 1215 BLAKE2B 161026c144fd49e0b9fe516f3d2dd5177f6f196db3621b4192092f804094045a6c085afe7811b4f25355bfa55c707120f809146afad992d1c1fe529bd83aa253 SHA512 a40399ced8524a28c337af5d1035c256acbd4535988cabb2b69cbc2da10200f23f2d16f36c314f408320aa503df2b1694d6112b2fb2562b0533ec7589cee64cb
+EBUILD httpx-socks-0.8.1.ebuild 1265 BLAKE2B 5dd7bead159ded13898a6bc0717399d1be0a9e302b5fd6861b2be6f4c3c98094de29e658867925bf6d166b9c79a0779b08b737d7e9c9331c01f53abea4845e57 SHA512 d49c268efa0b58abb8465bedbcdca8df38eb1df4cb98c18f4e0faec7faa2607c10515015f58fa759a4d49cd349fdadb3cf7844d695db1348cfb32bc694588402
MISC metadata.xml 400 BLAKE2B b244ebd9f79b1c3313797b0384339d17df61913473cd26ab01c8490fe02cbe735609dbd2b2d76e7b1b7f716bbb3038590517481a05c1b7886ad49905f171f5e3 SHA512 3cb1600426cdc5b9ec3bd5d18b547dedb961bbc341891293f828e70d5156d845c8676ba25244804d32c702fab40134c39237e5ce4fc518104a969a8f8ffb282f
diff --git a/dev-python/httpx-socks/httpx-socks-0.8.1.ebuild b/dev-python/httpx-socks/httpx-socks-0.8.1.ebuild
new file mode 100644
index 000000000000..04525123e363
--- /dev/null
+++ b/dev-python/httpx-socks/httpx-socks-0.8.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Proxy (HTTP, SOCKS) transports for httpx"
+HOMEPAGE="
+ https://github.com/romis2012/httpx-socks/
+ https://pypi.org/project/httpx-socks/
+"
+# no tests in sdist, as of 0.7.6
+SRC_URI="
+ https://github.com/romis2012/httpx-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/httpcore-0.17.3[${PYTHON_USEDEP}]
+ >=dev-python/python-socks-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/hypercorn-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.19.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.18.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.6.3[${PYTHON_USEDEP}]
+ dev-python/tiny-proxy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin dependencies
+ sed -i -e 's:,<[0-9.]*::' setup.py || die
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/sqlalchemy/Manifest b/dev-python/sqlalchemy/Manifest
index db69cb1a46e9..05e98d994a17 100644
--- a/dev-python/sqlalchemy/Manifest
+++ b/dev-python/sqlalchemy/Manifest
@@ -1,5 +1,7 @@
DIST SQLAlchemy-1.4.51.tar.gz 8521574 BLAKE2B 216550225c11d5367e5a50ec321a09078b4677973cf33eee1874beb9f855cfeb629a6df4d05e8ecc5b22052628de5cae2e468d18d50502a4560bd4ca7d85ab7d SHA512 be27a41f442428cdb5cc6a20af2de9424384457475d16a7d7167b718256e208766e2ba8d53bef2b314aafe87b3d9b0c5f9af6e4c03f53fb194671cfaca6e50b5
DIST SQLAlchemy-2.0.25.tar.gz 9508797 BLAKE2B 88f8927af1a20bdc3697e90112d515a04c64879bc806ae655d326f22322210853c2995ad884cb510a15d14ae12eb7612d867f701ab8f938ec0227abaab642497 SHA512 60b31a167f46a623f76e349f6a3f5a1696e1a04aee8dec2750396c715831a242a96e281ee7fcbfa26f82e6318573ab58e97d21bd93d02bbe3ff962777d809146
+DIST SQLAlchemy-2.0.26.tar.gz 9526590 BLAKE2B b68db1bd26106d199559ab80381c33c2bc0fd767f7a25e90216ddb93e2207fae5b85f369536f3531cb2699f6ed815a18f60860f0003c36d74a3c61080faeb1f2 SHA512 62532253ba6dee0c8e5c89487459ce783eb3d00cdcaf645efa5b68a03b62cc92ab7b447c791ac05bd552910edd223a390ab930a16b6234afb5dbe6d9c05b997a
EBUILD sqlalchemy-1.4.51.ebuild 3436 BLAKE2B 60b2e39902de5052fefb003514f3fb232cfd23ade139e8c5fc4d2b625d8fd65a40b22d6ae2593c7ee6ea12d1ce1dd4b192dc95cde3485671f292d96e3bd8999f SHA512 1c3c8bbd5459690c689ada1cfa9c89cf58298c6ade58117b9331ce99f3a7df8307f8976baaf03911ba3c828da05cd6c8b743cd2bd5120a7dbcf9e42b35fcc7a1
EBUILD sqlalchemy-2.0.25.ebuild 3954 BLAKE2B 9bce2efb81f5909ecb56762d4ab38fa16384109148131c76389b5bdf4f7644e1a6ed01a388d11a1cc975d7b55380e17cc7256bd38237f3b1cfe3c4634067ae97 SHA512 b655ead9dbfd58766b379a9f6f546185fd497ef478de0e323a5d87d8d5bd5698e5d503cb151a5c57c3b60241800826d53ec9779a38a2f4ac629b567809379c33
+EBUILD sqlalchemy-2.0.26.ebuild 3962 BLAKE2B 257ac594f9b76b02da6801683e8567085b3655fbd3aaf771fcc866f6e6f77d30b84d023000dae93f5c69e567ebb4fb54e15a11d9aff310f150122e9fed316fa6 SHA512 6b2f134d62958445e5e2049138ed296347c4734e7e81dbff51a6cb0b1323762ebca97e2acf492ba1c54a5a491e35ce095c68a480fae5781623099cfe34db9963
MISC metadata.xml 444 BLAKE2B 5fbfcf8f16e52ab5bb691b0b33a8491d94e42a80409114cd9b306af7d4b0eb8b6660fabc663adee53080c635217961301b78df536995b91afe9288d255f73d62 SHA512 b432b65ed3033d34ac0784d007909eb838b309b6a4785eebb1a3f808e43dfc41c786cd55e4dd048776c65127aac170bdd9fb9e5a8ae63accb5f65e300bca9676
diff --git a/dev-python/sqlalchemy/sqlalchemy-2.0.26.ebuild b/dev-python/sqlalchemy/sqlalchemy-2.0.26.ebuild
new file mode 100644
index 000000000000..f6836f064aa4
--- /dev/null
+++ b/dev-python/sqlalchemy/sqlalchemy-2.0.26.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="sqlite?"
+
+inherit distutils-r1 multiprocessing optfeature pypi
+
+MY_PN="SQLAlchemy"
+DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
+HOMEPAGE="
+ https://www.sqlalchemy.org/
+ https://pypi.org/project/SQLAlchemy/
+ https://github.com/sqlalchemy/sqlalchemy/
+"
+SRC_URI="$(pypi_sdist_url --no-normalize "${MY_PN}")"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="examples +sqlite test"
+
+RDEPEND="
+ >=dev-python/typing-extensions-4.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/greenlet/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ test/ext/mypy/test_mypy_plugin_py3k.py
+ test/typing/test_mypy.py
+ # hardcode call counts specific to Python versions
+ test/aaa_profiling
+ )
+ local EPYTEST_DESELECT=(
+ # warning tests are unreliable
+ test/base/test_warnings.py
+ )
+ local sqlite_version=$(sqlite3 --version | cut -d' ' -f1)
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ test/ext/test_associationproxy.py::ProxyHybridTest::test_msg_fails_on_cls_access
+ test/ext/test_associationproxy.py::DictOfTupleUpdateTest::test_update_multi_elem_varg
+ test/ext/test_associationproxy.py::DictOfTupleUpdateTest::test_update_one_elem_varg
+ test/engine/test_processors.py::PyDateProcessorTest::test_date_invalid_string
+ test/engine/test_processors.py::PyDateProcessorTest::test_datetime_invalid_string
+ test/engine/test_processors.py::PyDateProcessorTest::test_time_invalid_string
+ "test/dialect/test_sqlite.py::TestTypes_sqlite+pysqlite_${sqlite_version//./_}::test_cant_parse_datetime_message"
+ "test/dialect/test_suite.py::ReturningGuardsTest_sqlite+pysqlite_${sqlite_version//./_}"::test_{delete,insert,update}_single
+ test/base/test_utils.py::ImmutableDictTest::test_pep584
+ )
+ ;;
+ esac
+ if ! has_version "dev-python/greenlet[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_execution
+ test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_run_sync
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[False-True]"
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[True-True]"
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[has_terminate-is_asyncio]"
+ "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[not_has_terminate-is_asyncio]"
+ "test/engine/test_pool.py::QueuePoolTest::test_userspace_disconnectionerror_weakref_finalizer[True-_exclusions0]"
+ "test/engine/test_pool.py::QueuePoolTest::test_userspace_disconnectionerror_weakref_finalizer[True]"
+ )
+ fi
+
+ # upstream's test suite is horribly hacky; it relies on disabling
+ # the warnings plugin and turning warnings into errors; this also
+ # means that any DeprecationWarnings from third-party plugins cause
+ # everything to explode
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p rerunfailures --reruns=10 --reruns-delay=2 \
+ -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "asyncio support" dev-python/greenlet
+ optfeature "MySQL support" \
+ dev-python/mysqlclient \
+ dev-python/pymysql
+ optfeature "postgresql support" dev-python/psycopg:2
+}