summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-26 09:56:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-26 09:56:20 +0000
commit9b55c1bd600df28af7b9f6ee044b714873e19b49 (patch)
tree9c6d86e5e38b0aed45d07dc73907e9f818783a4d /dev-python
parent61044571b76d87a2eec42d36c9b7addf3e66e000 (diff)
gentoo auto-resync : 26:02:2023 - 09:56:20
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin260101 -> 260118 bytes
-rw-r--r--dev-python/cloudscraper/Manifest2
-rw-r--r--dev-python/cloudscraper/cloudscraper-1.2.69.ebuild55
-rw-r--r--dev-python/django-cors-headers/Manifest2
-rw-r--r--dev-python/django-cors-headers/django-cors-headers-3.14.0.ebuild34
-rw-r--r--dev-python/dkimpy/Manifest2
-rw-r--r--dev-python/dkimpy/dkimpy-1.1.0.ebuild37
-rw-r--r--dev-python/doit-py/Manifest2
-rw-r--r--dev-python/doit-py/doit-py-0.5.0-r1.ebuild37
-rw-r--r--dev-python/doit/Manifest1
-rw-r--r--dev-python/doit/doit-0.36.0-r1.ebuild67
-rw-r--r--dev-python/fastjsonschema/Manifest4
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.16.3.ebuild32
-rw-r--r--dev-python/fastjsonschema/metadata.xml1
-rw-r--r--dev-python/pyrate-limiter/Manifest2
-rw-r--r--dev-python/pyrate-limiter/pyrate-limiter-2.9.1.ebuild62
16 files changed, 339 insertions, 1 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 6802808201d6..7934eb3cb14b 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/cloudscraper/Manifest b/dev-python/cloudscraper/Manifest
index 4a80db91bb81..eb8f41de353b 100644
--- a/dev-python/cloudscraper/Manifest
+++ b/dev-python/cloudscraper/Manifest
@@ -1,3 +1,5 @@
DIST cloudscraper-1.2.68.gh.tar.gz 111952 BLAKE2B 69e896ad704ce776594fb89714bb75316ebff1b03387cba8575be6d60b496d18556690cfad109c2fa55c72ce3d91dcd21a21467a2d9820c579fea7482b688800 SHA512 42fa90127c6348c52a8327728683719966ae69c7b945cb9b485907e89e3b29b8053d31cd9cd4326e71ffd4c33e0fce20dd3d0e046fab62d89110eb4510535ad9
+DIST cloudscraper-1.2.69.gh.tar.gz 112198 BLAKE2B ea7325353aa9c4bfaca1834a1f9fdb2201cee1946a990d059540500e58322899469a48d847b6d7688b8f671bf4bbe762d1f61ed080587f3a553771ba8e9c2a93 SHA512 9da8d3d42117768a0a38843448248e3a124c864aaa76d62125d3a1dad8ea4f1921954e6efaa2eb9b40c283d6889c15c0c33378db7008155e46ccb5ae219c11d6
EBUILD cloudscraper-1.2.68.ebuild 1522 BLAKE2B 6114fc4c60872d61d24cf1822f900df5c6c0997572e0489a4edf8748bff71317b264846c8d7ae520fc5798571b79e4b691aace0389d06084fceb8c7f3620615c SHA512 6047e438a99db7e0e6df3301db05644f6f2405898cf81223f57c557f9f018389f7e9c1c260ffcda770e391f81baff9b89fd3f6f78b18cd12446fcb6a0b047bcb
+EBUILD cloudscraper-1.2.69.ebuild 1522 BLAKE2B 6114fc4c60872d61d24cf1822f900df5c6c0997572e0489a4edf8748bff71317b264846c8d7ae520fc5798571b79e4b691aace0389d06084fceb8c7f3620615c SHA512 6047e438a99db7e0e6df3301db05644f6f2405898cf81223f57c557f9f018389f7e9c1c260ffcda770e391f81baff9b89fd3f6f78b18cd12446fcb6a0b047bcb
MISC metadata.xml 749 BLAKE2B dd73d528bd6b2fd50230028ca8877783b315c9f3327ca3173b75a32ca7d1dc6135aa86e765f6d7b9929e6a84e5ce7f99a9c2a0ee4972c01e818f27b83719b5b8 SHA512 b36231ae7509d4ee146c4b0ba97aef6d9ee67db44741ba9f53e201f5f6b0392eaee3ce6e41c988ef9938c5e4b6dbe1fea10505319d40916e6b0bce5597dd790c
diff --git a/dev-python/cloudscraper/cloudscraper-1.2.69.ebuild b/dev-python/cloudscraper/cloudscraper-1.2.69.ebuild
new file mode 100644
index 000000000000..de0d08b51d59
--- /dev/null
+++ b/dev-python/cloudscraper/cloudscraper-1.2.69.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A Python module to bypass Cloudflare's anti-bot page"
+HOMEPAGE="
+ https://github.com/VeNoMouS/cloudscraper/
+ https://pypi.org/project/cloudscraper/
+"
+SRC_URI="
+ https://github.com/VeNoMouS/cloudscraper/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/js2py[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ net-libs/nodejs
+ )
+"
+
+# These tests fail for no understanadble reason
+EPYTEST_DESELECT=(
+ "tests/test_cloudscraper.py::TestCloudScraper::test_bad_interpreter_js_challenge1_16_05_2020"
+ "tests/test_cloudscraper.py::TestCloudScraper::test_bad_solve_js_challenge1_16_05_2020"
+ "tests/test_cloudscraper.py::TestCloudScraper::test_Captcha_challenge_12_12_2019"
+ "tests/test_cloudscraper.py::TestCloudScraper::test_reCaptcha_providers"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "brotli decompresssion support" "dev-python/brotlipy"
+
+ optfeature "js2py interpreter support" "dev-python/js2py"
+ optfeature "node.js interpreter support" "net-libs/nodejs"
+}
diff --git a/dev-python/django-cors-headers/Manifest b/dev-python/django-cors-headers/Manifest
index 73c3a480a2f8..4d9853ef7ca6 100644
--- a/dev-python/django-cors-headers/Manifest
+++ b/dev-python/django-cors-headers/Manifest
@@ -1,3 +1,5 @@
DIST django-cors-headers-3.13.0.gh.tar.gz 27361 BLAKE2B 2d0729ae6f0e0ff7c572c5f25482fd88dfa03e8f03a7f640ba32f56208fccb91712cd3067bc3376428469cc7f03dd8003069b79e98dd438fad9e5f4b15cd9c71 SHA512 153ae0d2e0b1e390c72993ca629f7ed521fd907481bb2944ee2f805c0081a1db334fd72f0b3fdb77cbb57b3392691f32564bb646bfb8e388a942a8a3da138a8e
+DIST django-cors-headers-3.14.0.gh.tar.gz 29634 BLAKE2B 08ec6811b8608feecbdaadcc6ce220b1574a4bf16823f939f93eda4ece9df0430b015edc1d0909b980996ff143e036858ca81f524e8d270846881a9c0af25fac SHA512 5ff390bd2fba1b3dff3cea08b10021d0fd100497000b2eaef788fe32c1b8584f1954e470f4aa15cbcf9e4342265633a658b8736de08962bfe0ea9e2068521379
EBUILD django-cors-headers-3.13.0.ebuild 709 BLAKE2B b583921f76ce1276a4f42bf5e55a10098811467e03df4729af9b1c727e01ef3bbdaefffe812643a947bcb3cf5012a53e7da153f83560368b69e70c34d520b503 SHA512 ee8081744c9632cc66112e1b266dd1babb14a312fe709371b913fa090cec7017d08350211c5fd01138e5e56f78754846175c9f45d368d6bc360ae56ec582401b
+EBUILD django-cors-headers-3.14.0.ebuild 709 BLAKE2B 27cff0452ff6c9ca21044ec70208bb7b2d182a9c3201737f82fa461861691df8e3ec08817e1587226d7b2183c33511e0abd221c01b9ce30743c04c84f2c21e03 SHA512 aa3a488d3bacec0d498f6ced40fbf7f909cea05751293c7e31d6ddf9b26db46c67b29cbae56e90f5ed0b2b2eb2c69833c0513733f6f6c57657d805c82a650eb1
MISC metadata.xml 393 BLAKE2B bfe5bf69a5cdf23648e6058016fa53d402db8141ebf97a8471b3335f13eb0adb3ac328c2a013bea02529ee012b00e77fbf43284500cc9e58937fae16d3a2d743 SHA512 b028f371bae9e3bb8e0e94890ee2a5a8c2d93a774eac7cccd6a1ff91886a82ed52ae4fb93442de89034cdbf4ca9d4186dad29b014b989690020db00c492fed04
diff --git a/dev-python/django-cors-headers/django-cors-headers-3.14.0.ebuild b/dev-python/django-cors-headers/django-cors-headers-3.14.0.ebuild
new file mode 100644
index 000000000000..2f86005be6e8
--- /dev/null
+++ b/dev-python/django-cors-headers/django-cors-headers-3.14.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django App that adds CORS (Cross-Origin Resource Sharing) headers to responses"
+HOMEPAGE="
+ https://github.com/adamchainz/django-cors-headers/
+ https://pypi.org/project/django-cors-headers/
+"
+SRC_URI="
+ https://github.com/adamchainz/django-cors-headers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/dkimpy/Manifest b/dev-python/dkimpy/Manifest
index d2ae9d28b408..42f68a962730 100644
--- a/dev-python/dkimpy/Manifest
+++ b/dev-python/dkimpy/Manifest
@@ -1,3 +1,5 @@
DIST dkimpy-1.0.5.tar.gz 59799 BLAKE2B 317e7a9e7ad1efdbbc7f4f1ce7efca70f3be4272ead3761d8bbde14d19e9f3a90af96d7bff5fba5b612cecaa166b58da4617e39a13276d0982ea38809f808b4d SHA512 af72a56a777b23318af8f8014bad03cadb93cc39f0b8c2062e15f3e5ca77a13be6f49664c9745f1fe97c592be5a63c4b0a3942da2c2c6eaa486137fdbb96528f
+DIST dkimpy-1.1.0.tar.gz 66326 BLAKE2B 3af2ab63351c117b7fa0fd2c7a2f2a98b2177511af61734d171fb69e25c5a3d629d95f8ba2832b66f57607ff447a4093ab8ebd58c931975e9ca0c1bab9469590 SHA512 d8c656d1adabbf8ef2121a36a848818ee9ce5ac9fe42c4b16ef50588870478989159f4ff3aa422ba0556a82763a9e78fde5e19195fe0b95176f2f4ff1d60c70e
EBUILD dkimpy-1.0.5-r1.ebuild 764 BLAKE2B 685f28d69261fddddc280e1cfd415006b4922c0a5d98693db4da248c875af4786aad094cbfad8268d732004b4eff003efadc654b871e5bcc572a54c33d0a09d2 SHA512 c612ba54b0e88755784ccfeaa77a1dddd07a4c97aaa7987133ff42ea482c53a9ee22fea0dbf6c62316df29b7dbcaf819cd15f36dffe252dda67089ac7e4daecf
+EBUILD dkimpy-1.1.0.ebuild 767 BLAKE2B 8960217a56f673459968760888226b9b4f6f98db17d268ce589e578661fa4ac2612fa1acb617d2c44f33bdaea5c2305392decb213fa1dab7281814c6020bf7c5 SHA512 ce8c5728bf2076458fbcc7270de55a43695899c5db046d3984e707c5da687a54a5fdfaeed394adbefa02ac26b51dc31015fc3c9071e8153faffcdf1125c681db
MISC metadata.xml 538 BLAKE2B c0b9cb73f84e5f3e6cb6653b0983a0ef5002ad9c1a201b36f6ccbfb150d15990820562b18eef385e571f024b4e44f8572b30eaea57e93df44bbb6105df7abd11 SHA512 1c650532a9c9152eef0803c1c29781095390aca93c036cc097dcf6b16ad0d5ff9938ed48cb12ab092d0df777fbb6f7ca6626be7dc10935ac2563332869e6d511
diff --git a/dev-python/dkimpy/dkimpy-1.1.0.ebuild b/dev-python/dkimpy/dkimpy-1.1.0.ebuild
new file mode 100644
index 000000000000..7a71236ad9dd
--- /dev/null
+++ b/dev-python/dkimpy/dkimpy-1.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="DKIM and ARC email signing and verification library"
+HOMEPAGE="
+ https://launchpad.net/dkimpy/
+ https://pypi.org/project/dkimpy/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/dnspython[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/authres[${PYTHON_USEDEP}]
+ dev-python/pynacl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "ARC support" dev-python/authres
+ optfeature "ed25519 capability" dev-python/pynacl
+ optfeature "asyncio support" dev-python/aiodns
+}
diff --git a/dev-python/doit-py/Manifest b/dev-python/doit-py/Manifest
index ac5bf21785ae..18a8f37b8e28 100644
--- a/dev-python/doit-py/Manifest
+++ b/dev-python/doit-py/Manifest
@@ -1,3 +1,5 @@
+DIST doit-py-0.5.0.gh.tar.gz 15174 BLAKE2B 092f21549d3c088baf8a96b8dd7575304d08c7ae7b0472e7a890159247422060af06c1cc14064cd608bd59e71788067c5374953b16f4511971bb3018c0245cd4 SHA512 f9e70be30f47b7251bdb479762dabe655be898f9fe37fc5ac6608110a82863a08002271620569745f9ec2f47c03529c044a6ea74244b8bb6438b3fbe7e4c28f7
DIST doit-py-0.5.0.tar.gz 15174 BLAKE2B 092f21549d3c088baf8a96b8dd7575304d08c7ae7b0472e7a890159247422060af06c1cc14064cd608bd59e71788067c5374953b16f4511971bb3018c0245cd4 SHA512 f9e70be30f47b7251bdb479762dabe655be898f9fe37fc5ac6608110a82863a08002271620569745f9ec2f47c03529c044a6ea74244b8bb6438b3fbe7e4c28f7
+EBUILD doit-py-0.5.0-r1.ebuild 712 BLAKE2B b7083088c5f14b67209105ae1627e8d6deba1e8f5cb97d01b0af8f6af52ace7145032d380dd041b499ad9970ca951a7f1ee444fa1865aa37653b49df079cde74 SHA512 50ca2723b8cddac91303beec3d8416f594d33945bbbf911cbacd951f6d422d291785cb3015237a0fcd9ae579eeaa0a7468c5a57bf7c9693b8f6755735f0bdd52
EBUILD doit-py-0.5.0.ebuild 627 BLAKE2B 299979c34032fafc87b10da64ff8d490d218050df93f584a461bdf7f006d4900c45bb192b52461b746e2f7e1c86af951fda41fda9415bd27b2c0d271885eb8c3 SHA512 5d48d286aad08b02dc4ba560c06b91305a26737b3c79973eda167a85f40751ae742086995fc2ea4c41f9b424246c55eddcff6fffca8f17e912f7fb83267204b7
MISC metadata.xml 574 BLAKE2B 7a0bbe729e4c116efeed154754527f4a2c8ce3f25aa0f0e7cddd9377ddd58032d49bd01583693014fd7006516d947f85976774da86ef2b952e14e06b4a81bc08 SHA512 e0f4d58ca417e125ace7705e1d326edad58ec391ef555f43ba3e34ee42007df84ee61f7234f98367f0410f4fa980c6a19e2493d3ae840c751687018919032294
diff --git a/dev-python/doit-py/doit-py-0.5.0-r1.ebuild b/dev-python/doit-py/doit-py-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..f4b939016f26
--- /dev/null
+++ b/dev-python/doit-py/doit-py-0.5.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="doit tasks for python stuff"
+HOMEPAGE="
+ https://pythonhosted.org/doit-py/
+ https://github.com/pydoit/doit-py/
+ https://pypi.org/project/doit-py/
+"
+SRC_URI="
+ https://github.com/pydoit/doit-py/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/configclass[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-text/hunspell[l10n_en]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
diff --git a/dev-python/doit/Manifest b/dev-python/doit/Manifest
index 3243a737840a..89be338f1f42 100644
--- a/dev-python/doit/Manifest
+++ b/dev-python/doit/Manifest
@@ -1,3 +1,4 @@
DIST doit-0.36.0.tar.gz 1448096 BLAKE2B 15558a39ccac031ddf3a429aa585bc6e1d49c2e7572df29979ca66d1025fa5d7a917f6cc5bcfd21f2749e4ed7e7885b0865ec67b6fa32817e1518d47da9ead97 SHA512 d4caa31701755c7f59213dde0f89fd3616c0c01b7f06245cbfd9f1a315d503e62f3556c3b86685cd0ebfcffcc9cae0987ca150f037aa7b3cd960439a1191be42
+EBUILD doit-0.36.0-r1.ebuild 1501 BLAKE2B c2e4086ae31308e2ad97a88ab783151c439203413b2574713c05a63f12c02f233f997f5c74a804314ae302239ce0316651e72fb44b906fb370ee5858b606213c SHA512 bd6c9269e4945441e65d0e8011af597c0439642f723c0775453e99712d38f3ea0ed065cdeba2eb2ec4ddb94064bd209549a7d5b8d483a4c22002e6d037ae6554
EBUILD doit-0.36.0.ebuild 1537 BLAKE2B cd68c7e7e47f205e37a62a8852e17f75b77db6ef49e1d9f4f8f5d815ff77dfba55ede7e6a70d39cf998f96b0b4f3e9f8747031641d0968f700d2f37e76e637b4 SHA512 c90d5d2ce66900b16377715f77bcbfc3270b8fd12c935a8b714451498ee450a14766fba7889bee8c68de80c201b4619ac50c322dd0182f7586fc0755df1c6b6f
MISC metadata.xml 568 BLAKE2B add52a6e7986bb88b9dc87d2f03c4ec3716ae7d5e2402556b7a3137b8267ca2cad0ae3324d628f3127afde36513414029c0f567a9683dd9b11b1a287ff5e3a7d SHA512 e772c9ccd8133fd73dcf04733facf60ef7c2f1559b83e5024faeea4d5fd7799c42a28be6c9b8676ea9b6d68969ca5be633320e8cb7dd8d1f0dca35e819eaebc7
diff --git a/dev-python/doit/doit-0.36.0-r1.ebuild b/dev-python/doit/doit-0.36.0-r1.ebuild
new file mode 100644
index 000000000000..21d211e22506
--- /dev/null
+++ b/dev-python/doit/doit-0.36.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="Automation tool"
+HOMEPAGE="
+ https://pydoit.org/
+ https://github.com/pydoit/doit/
+ https://pypi.org/project/doit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ || (
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/doit-py-0.4.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme
+
+EPYTEST_DESELECT=(
+ # test failing due to impact on PATH run in a sandbox
+ tests/test_cmd_strace.py::TestCmdStrace::test_dep # #836164
+ tests/test_cmd_strace.py::TestCmdStrace::test_target
+)
+
+src_prepare() {
+ # Replace custom theme with builtin for documentation
+ sed -e '/html_theme/s/press/sphinx_rtd_theme/' -i doc/conf.py || die
+ # Remove non-exist modules for doc generation (#832754)
+ sed \
+ -e '/sphinx_sitemap/d' \
+ -e '/sphinx_reredirects/d' \
+ -i doc/conf.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp bash_completion_doit ${PN}
+ insinto /usr/share/zsh/site-functions
+ newins zsh_completion_doit _${PN}
+}
diff --git a/dev-python/fastjsonschema/Manifest b/dev-python/fastjsonschema/Manifest
index e7c6a659f6cf..23763b28dadc 100644
--- a/dev-python/fastjsonschema/Manifest
+++ b/dev-python/fastjsonschema/Manifest
@@ -1,3 +1,5 @@
DIST python-fastjsonschema-2.16.2.gh.tar.gz 391619 BLAKE2B ea8da31d16ec7c9a897de0b2a91832ce26798d2dc048e70e862ce7a4e75787cd25ee4b9e14fac9f85599e050338b6306a2549a0a8bab9abcbfbd12c246d10697 SHA512 17fce033e6d334e82813af7366006ade29433efe291a1567ae494c2273b9ab87b8fa4ccf1bae0b7062f9f70fe492449c87a5d07075d79037ac2c755ed9278a23
+DIST python-fastjsonschema-2.16.3.gh.tar.gz 392011 BLAKE2B 04990592a2bf6e1309bf725361ef7c2e253c4765c5b9d60805c5e6189f14885a3b0bae98945c2fe228adc335ca8c8c0a243b283b24fa447238d6415d439288e2 SHA512 2e26f31f9c6966e77f70b8ca584e672d554219b6bbb4811e3ac8dff1c693b2638ef08b8b9011e0db6f739be02e2f41a35d15bcfc42a9cb06ddb4521e51f37d8a
EBUILD fastjsonschema-2.16.2.ebuild 735 BLAKE2B 94bcee2f1a4811ab16315197b74e60bcc5232848006a58e442f4105441c1e1552a8d4b8904b605762e32e22717cdb0620b53ea5ab3d1cc13734324dbd8de0d55 SHA512 1eb0f21c326f933c4a61fa576036e81b0ee8b37c2a81eaaba59b282bf3aada26f11e1b16a814bcd195631ad65117b780404e249c4698359e039a54a0298b912f
-MISC metadata.xml 320 BLAKE2B 6a243ee36316e1c8db01ec6da04593ee4edb8cf479e829291e74c5672b5dd419cf9a3528c13dbd540342377186130a49be652e3f8c1cf78feafd310dbbd3bc88 SHA512 0c0dff7e564b1c1176e05a49c0c028ce181497bd734a1c19e24d8af7169c16d8b5dccc73cc31379c28ce0e58d1eb142d131969719b1c8fe6df3b76c59b4f3a3e
+EBUILD fastjsonschema-2.16.3.ebuild 743 BLAKE2B 577283d575d6632fea86d4d12e4ee72633d21958a104d9cdff35bed327512d5720c6b400a2b6c395b2c73a377624153e0f49fd573a94458e6ce08dc44df16c92 SHA512 b7378494fa66d7168967e2087ad4c3b5baa729d26e53eb4d46ecdadb4a7f752e5a8740a40fadd2ae11410edd3f6ea99d6aa3c6790579662d9ea702fc4d4416a8
+MISC metadata.xml 390 BLAKE2B d29071ddcb0aea8db343c2924de51e8fdbf9295898c687ca0f474e007007407c9a402cd2fa74f0f2142dfb2f14a2cfd0c51c05f5fad6891734328a003283821f SHA512 db3339aaba0218ebea0ea4cd5b950dbf74572b18341f595fbbbe1f67c0c9c23413f4a98aeec5b49b036533cfea46e8f2a74f5f999c3b4c472a66297346139b05
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.16.3.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.16.3.ebuild
new file mode 100644
index 000000000000..453a2cbc2332
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.16.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="
+ https://github.com/horejsek/python-fastjsonschema/
+ https://pypi.org/project/fastjsonschema/
+"
+SRC_URI="
+ https://github.com/horejsek/python-fastjsonschema/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ rm -r tests/benchmarks || die
+}
diff --git a/dev-python/fastjsonschema/metadata.xml b/dev-python/fastjsonschema/metadata.xml
index 7e60f3e6248a..1a957a0ba04f 100644
--- a/dev-python/fastjsonschema/metadata.xml
+++ b/dev-python/fastjsonschema/metadata.xml
@@ -6,6 +6,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
+ <remote-id type="github">horejsek/python-fastjsonschema</remote-id>
<remote-id type="pypi">fastjsonschema</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pyrate-limiter/Manifest b/dev-python/pyrate-limiter/Manifest
index 1b36027d3fa8..bd6df17c8196 100644
--- a/dev-python/pyrate-limiter/Manifest
+++ b/dev-python/pyrate-limiter/Manifest
@@ -1,3 +1,5 @@
DIST pyrate-limiter-2.8.2.gh.tar.gz 51233 BLAKE2B a9a8bbf123596c7c64f60ae2c9d4e23a394dae6d18a8d09c0ec0b289bbbfce9dacee523726b906a30cf17fd7243b3fa1d1f2dc60af1bec67dc242d944535a5fd SHA512 3ff703347a86f6a91cf6b9c8edce3017cf88f2373961ba235c2f521d0112b0116951be7314b95d737ef0bec5cb6bae9908874fafe4060eb773cf0577e2ddbdb3
+DIST pyrate-limiter-2.9.1.gh.tar.gz 71544 BLAKE2B 2f87f998abdb891673931f91a9980f5876f58a2225ca41af6ec390e59bd326e8614162549946552b22fea093f89f5c2a219eaa9223719dd4db9023944f040da2 SHA512 461b1627574ce09817b434ce0d47e3bbcb549fcd8176623b87640089c1dd9bb45030ae1c944ffd7906b04f9b1ba2977c841c1da9483619bc092570b86a49bcd6
EBUILD pyrate-limiter-2.8.2.ebuild 1610 BLAKE2B 513df54bd30e8ebd64b58ca7d997a05a122606535f4b6d188a21d2b5e30380cccac7c435b017a0211eb9fc97af17d822d0e1cc1d66a20244ac9d666fbf5ada8f SHA512 ef0281396688a2985620780e736ddd2056db16b7d6be6eb11e32c381a7440dd992f639d6ea3e31479b3a1850c486e1d984e89bdf880919fb14fd9262c4d2a43d
+EBUILD pyrate-limiter-2.9.1.ebuild 1610 BLAKE2B 513df54bd30e8ebd64b58ca7d997a05a122606535f4b6d188a21d2b5e30380cccac7c435b017a0211eb9fc97af17d822d0e1cc1d66a20244ac9d666fbf5ada8f SHA512 ef0281396688a2985620780e736ddd2056db16b7d6be6eb11e32c381a7440dd992f639d6ea3e31479b3a1850c486e1d984e89bdf880919fb14fd9262c4d2a43d
MISC metadata.xml 525 BLAKE2B 8daa0c59b247c8ec215a3868315f383614b24bf36a80950f3a94968856a27ee2eb90cedba36784355926c509a26b530f3de44be729beeee0f22595cc0b9467b5 SHA512 429e23f33cd2889a7e989333a03ee374cbec2e264d354bf1c299263f2c9167059eb17f1c975b67cd4af7011843c3478d5296033666566bca97749ca85dfcab44
diff --git a/dev-python/pyrate-limiter/pyrate-limiter-2.9.1.ebuild b/dev-python/pyrate-limiter/pyrate-limiter-2.9.1.ebuild
new file mode 100644
index 000000000000..b8c9c6a33c68
--- /dev/null
+++ b/dev-python/pyrate-limiter/pyrate-limiter-2.9.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Rate-Limiter using Leaky-Bucket Algorimth Family"
+HOMEPAGE="
+ https://github.com/vutran1710/PyrateLimiter/
+ https://pypi.org/project/pyrate-limiter/
+"
+SRC_URI="
+ https://github.com/vutran1710/PyrateLimiter/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/PyrateLimiter-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/django-redis[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Optional dependency redis-py-cluster not packaged
+ "tests/test_02.py::test_redis_cluster"
+ # Python 3.11 is slightly faster, leading to a non-critical failure here
+ "tests/test_concurrency.py::test_concurrency[ProcessPoolExecutor-SQLiteBucket]"
+)
+
+# TODO: package sphinx-copybutton
+# distutils_enable_sphinx docs \
+# dev-python/sphinx-autodoc-typehints \
+# dev-python/furo \
+# dev-python/myst_parser \
+# dev-python/sphinxcontrib-apidoc
+distutils_enable_tests pytest
+
+src_prepare() {
+ # workaround installing LICENSE into site-packages
+ sed -i -e 's:^include:exclude:' pyproject.toml || die
+ distutils-r1_src_prepare
+}