summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-01 05:41:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-01 05:41:49 +0100
commit9a92076d428b51966bd8d699427341e5500b3a8a (patch)
tree89cfb1b8eafec7472c5c70e3b2d47f5372fa067a /dev-python
parentacc3fd0021f478ed04cb72c7b46bc0d6fa315f29 (diff)
gentoo auto-resync : 01:10:2023 - 05:41:49
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin267624 -> 267639 bytes
-rw-r--r--dev-python/arrow/Manifest2
-rw-r--r--dev-python/arrow/arrow-1.3.0.ebuild40
-rw-r--r--dev-python/denonavr/Manifest2
-rw-r--r--dev-python/denonavr/denonavr-0.11.4.ebuild40
-rw-r--r--dev-python/dns-lexicon/Manifest2
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.15.0.ebuild71
-rw-r--r--dev-python/httpbin/Manifest2
-rw-r--r--dev-python/httpbin/httpbin-0.10.1-r1.ebuild (renamed from dev-python/httpbin/httpbin-0.10.1.ebuild)1
-rw-r--r--dev-python/identify/Manifest2
-rw-r--r--dev-python/identify/identify-2.5.30.ebuild29
-rw-r--r--dev-python/matplotlib/Manifest2
-rw-r--r--dev-python/matplotlib/matplotlib-3.8.0.ebuild2
-rw-r--r--dev-python/pylint/Manifest2
-rw-r--r--dev-python/pylint/pylint-2.17.7.ebuild84
15 files changed, 278 insertions, 3 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index dd97076a4ed2..333a0301f628 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/arrow/Manifest b/dev-python/arrow/Manifest
index 37d395638fb3..17c6109a0664 100644
--- a/dev-python/arrow/Manifest
+++ b/dev-python/arrow/Manifest
@@ -1,3 +1,5 @@
DIST arrow-1.2.3.tar.gz 127552 BLAKE2B 35f5b694d819d80913b5938e4af71f413fd3944636c1e89a79e868c03cb423f75692c1f0e8d85dba21e640591f8cd0404cdc6d77dd59956490d268fb4c9fdc7b SHA512 e90276f50bf8521570cc2cdbf011ff376e0d5bada0576bbfc76f6c63730c13f7eba1d978cc3a481e7c7356b0dce7c554f19cbf3ef03b280c5515be72d2c7d177
+DIST arrow-1.3.0.tar.gz 131960 BLAKE2B 892ed898ea09a00ca100eada18956994d3567836c30feec50e1d2d1bca6a603c3f9254def16cd55b46e68c1530f8bf7c0f55401b458cc5aadf0883ade0899e90 SHA512 f0725e75d1005e0177bb234b3d2523aaf9e882ec08b020f6b3737a3af27af3c8c031aee9dcba0332595845a09a0286d56662b77ddad8a6da928ba37201725239
EBUILD arrow-1.2.3.ebuild 824 BLAKE2B c0a5630f775553c19eb721c0f3db0a77ee42b7882403165c7145bf02fabc7e806354962b4344075919232282804298aaea4241b74632247666a93c3dbc878b03 SHA512 442d0f4e91300d94bda10656a126afdae072f0dfa6d8da76ad21953bec7bc16808d85948e9559ad13645c67e6ebe6a895bd7b6f0732655d1b1423cb9d60a5ef6
+EBUILD arrow-1.3.0.ebuild 901 BLAKE2B 5b3a6699f9f4d61c351cd92083d301deeace93292914c03a0369f70d256bcb8b6b0599dd49421da98303ad551d0df18bbdf760d973c33cb0372f268e8376caa7 SHA512 71f25340f8c6f7f2cc047cf142d8b61f223480677b8332077202023f4ac329ec21160817832caf022400dc90da7bc7e95ba7606921cd8b71c0e8b16b421ca267
MISC metadata.xml 387 BLAKE2B e07417bbea7b9b1a8b850dda631d1e626e013a6cac793893deafec648003970a6240833af5ecc3a9b19aff3ea38e26e684a7a151f1138ed9d8597b567d3ca960 SHA512 ea9a24239141a4338c7d3291e2be9dff5d36f33f91ec3fefb62c7fd054b0c7a80ce66b6916f045aa3eaf69cc4f2f3d116a525958fb0f6185b98a10660bc08e50
diff --git a/dev-python/arrow/arrow-1.3.0.ebuild b/dev-python/arrow/arrow-1.3.0.ebuild
new file mode 100644
index 000000000000..b77f1acf1f27
--- /dev/null
+++ b/dev-python/arrow/arrow-1.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Better dates and times for Python"
+HOMEPAGE="
+ https://github.com/arrow-py/arrow/
+ https://pypi.org/project/arrow/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' tox.ini || die
+ # unnecessary type stub deps
+ sed -i -e '/types-/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/denonavr/Manifest b/dev-python/denonavr/Manifest
index be2fead086d9..f5bea32f72c2 100644
--- a/dev-python/denonavr/Manifest
+++ b/dev-python/denonavr/Manifest
@@ -1,3 +1,5 @@
DIST denonavr-0.11.3.tar.gz 179597 BLAKE2B 139cda38958e320d72f11ef25e94db67346b7e9f253cbbf60a0cc5f5e2e42846f070a57cfb1596cb648d1d70a62983d8f5fe6b91aec5b95501c049c1c65b7141 SHA512 a361ac3dd6385ad7c042f6cb7bd2092c39da75c167277347d199ab9de3a1ef9fad84e41428cfa02058c680c905965214e42780fa4d4fb1f4a1116102284fe571
+DIST denonavr-0.11.4.tar.gz 179759 BLAKE2B c75b5679c614f3776afd8a24befb49ca5c2528cb6cd6a573ea221cc66e7b9ec9819770b646c52c0aed126b35733aab09a9eb7c5f673a8e3208507d0afda36117 SHA512 7bdae172034122cc55571dd83888091987c973e29fd0f881428d09c093510c99f4c6eceaab0868d024a2e6acca36eaa941d62332849e7dc2547a88111d8dc55a
EBUILD denonavr-0.11.3.ebuild 958 BLAKE2B 477fdac771877d819d8c4233c31740f58b39f899a1c525215fa8f55f251cc17fe9a300640faeb717ad0499e5d6934b131cc4c038ea8397e762fe44f877d8826a SHA512 a45c945211e5dd9ac9773f830bc315db1cb9e1e636dbc4ffdf438d4b0313b7769d87ae769a16162f143dc415e559e6819a7a7dc5f96f07f84fe4c6d7c0e80443
+EBUILD denonavr-0.11.4.ebuild 958 BLAKE2B 477fdac771877d819d8c4233c31740f58b39f899a1c525215fa8f55f251cc17fe9a300640faeb717ad0499e5d6934b131cc4c038ea8397e762fe44f877d8826a SHA512 a45c945211e5dd9ac9773f830bc315db1cb9e1e636dbc4ffdf438d4b0313b7769d87ae769a16162f143dc415e559e6819a7a7dc5f96f07f84fe4c6d7c0e80443
MISC metadata.xml 538 BLAKE2B 7f0ea063a1ebe7cfbab11a8e92b803606c6454ea9bf871bc804f048a58b35e0ab66eafbee64d8d4328e4e3cd5361a810527813c48aba212950f263da2b4454cf SHA512 3531537b37f09f4b0d27d124d1bc698d8b8eeb410a0f3504f315a8002a8443a886959706e437359796623f3462b3d12d89ad677fbde73ee6081c61ed01663ad4
diff --git a/dev-python/denonavr/denonavr-0.11.4.ebuild b/dev-python/denonavr/denonavr-0.11.4.ebuild
new file mode 100644
index 000000000000..5adf44a85b90
--- /dev/null
+++ b/dev-python/denonavr/denonavr-0.11.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automation Library for Denon AVR receivers"
+HOMEPAGE="
+ https://github.com/ol-iver/denonavr/
+ https://pypi.org/project/denonavr/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/asyncstdlib-3.10.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-21.2.0[${PYTHON_USEDEP}]
+ >=dev-python/defusedxml-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.23.1[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.11.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index 7a70adcece87..d2cc9614380f 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -1,7 +1,9 @@
DIST dns-lexicon-3.12.0.gh.tar.gz 6729773 BLAKE2B 1566b98db71027a8c49c7c90060a67b0efc8dc8afb8c977c0277d29c751f26cabc824a510194f09d02f19a40151bfdebe877ccd3e0bfcc8484f694ce128c0d95 SHA512 4ba799c6f7a01b8209f5274337258d0525efff366b297fff2fcff1d40c7ee58850fa8c3743bf9d29a1a082288e1f615cd94036a9cdc7be9f85e46f26fe3d7fbc
DIST dns-lexicon-3.13.0.gh.tar.gz 6739417 BLAKE2B 86f879fb5b27c6d9b21788ce4a9d7573b9aca0eccc022f4ac81cbb0e683f089797156134720bcbd82b509253470b01ee3ead3161517a0108d16991b668e1b4f3 SHA512 582efefb93d9f122cf3f900ddc7cf615295855645f6d9621f14c11067e441eb67349adf40e5159b75e8c5703d1cfd874364d392ce2994feb89949d371b4b55be
DIST dns-lexicon-3.14.1.gh.tar.gz 6747567 BLAKE2B 55ddba2caf71b92ad0e5f34457d33c46be5969b13a12ac16a07e5c9ad8a25b921119edf89ce80928340e401308365eeb5b7c7c56f8e36482422f7e2e43412cde SHA512 13e4c5b046cad28e487b246b7c16a3ee71b2dbca4c40e513b234cee62e483e7702ce293c11ef96b245409229a7cd3a39c1771ebfc7b2430cd5b017d33e32a924
+DIST dns-lexicon-3.15.0.gh.tar.gz 6200937 BLAKE2B 94ff86424e5f9d03d5ec059359f684cbcda8fd617f84510c7154c2f48072b766bab0497ef1dd46c630b25f8196d177715eeaa9223bf2b502f125526120f91327 SHA512 22e6f11e2b5750ff44c8a72b0e6c0a1a4126e247074b87cf7fbbf403d8858c261fb2c57a5d01daa218e4b3448782ccb5567fd6f29da78baabb2aded90a82c97c
EBUILD dns-lexicon-3.12.0.ebuild 1974 BLAKE2B 6f0b2f9d18b2066ab05393fe7190a136a01c6c63b9e6eaab6ba96a1d085305d5cf3013267b9bc04101ffb8841715dc161b034e12d73c54aebaf42d7ca4166aa4 SHA512 ae016160fa92993ba8007635dbf18ee9c4de868ccfe39d889a3ed7b773456a3be4f43e8f9a9f6653bdda9f50880af2b65894a174565542df8931ab773991f9f0
EBUILD dns-lexicon-3.13.0.ebuild 1974 BLAKE2B 6f0b2f9d18b2066ab05393fe7190a136a01c6c63b9e6eaab6ba96a1d085305d5cf3013267b9bc04101ffb8841715dc161b034e12d73c54aebaf42d7ca4166aa4 SHA512 ae016160fa92993ba8007635dbf18ee9c4de868ccfe39d889a3ed7b773456a3be4f43e8f9a9f6653bdda9f50880af2b65894a174565542df8931ab773991f9f0
EBUILD dns-lexicon-3.14.1.ebuild 1918 BLAKE2B fa4274c3add2a44a14612dabf3f8382f858496df1584d173ebbcdb4ea2a04b4a90b12f3e959af00bfa27c61ec4c4f26807de475679fe39287478243a4934f8b6 SHA512 4758c1a5494dc2c7033ac6e37422a4de5bb3a432d894156c503ede539ff3115f5b0bee5ae29c6d6d1f6908716e92d38f5c52ee4220e9bf16f14e8539da865b5d
+EBUILD dns-lexicon-3.15.0.ebuild 1905 BLAKE2B 9f79af7861c3578a9aa301150d13cf0e9228947e1e02f0d2e80c1609a6339614f607baf6e6c37f74e5466485eda7859658772b397c243a84ac9bfa5bd134f341 SHA512 ec067f6d8590dfc7f0bb84067eba284ac2e4c78631cc0c3bfaf7ecc0bcdf12846cf276ad4ce9250848ffa4ddaf746b0dab75df5bad661db8e611b640eee796d1
MISC metadata.xml 541 BLAKE2B a22266eac0bc7b4c22d9552cf64cbf88bbc1c2953e3ef0daaf059b81519909e0f8808e0d74cec6db3296e43f98082d57b8ae3779d694432e8578112ac18c3ea6 SHA512 79e2b43a685bfcc8dace1faa1c1a08cc648b39a3fef2834a57b6e801f72e7309276604253089db7a2fbe1d5d776b2ba1427c90a9cb9c44a0c1b2812d4e1901db
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.15.0.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.15.0.ebuild
new file mode 100644
index 000000000000..55e62bd2d181
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.15.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="
+ https://github.com/AnalogJ/lexicon/
+ https://pypi.org/project/dns-lexicon/
+"
+SRC_URI="
+ https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/pyotp-2[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/boto3-1.25[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ tests/providers/test_transip.py
+ # Requires the "oci" module
+ tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ tests/providers/test_auto.py
+ # All recordings seem to be broken
+ tests/providers/test_namecheap.py
+ # Broken by minor vcrpy / urllib3-2 incompatibility
+ # https://github.com/kevin1024/vcrpy/issues/714
+ tests/providers/test_route53.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}
diff --git a/dev-python/httpbin/Manifest b/dev-python/httpbin/Manifest
index cf0a6272d3d7..0a7367f79a3a 100644
--- a/dev-python/httpbin/Manifest
+++ b/dev-python/httpbin/Manifest
@@ -6,6 +6,6 @@ DIST httpbin-0.10.0.tar.gz 103729 BLAKE2B 1daff5bd9eba62c224d4fd6030e3c3378f8493
DIST httpbin-0.10.1.tar.gz 107058 BLAKE2B a46732946fc3454e2ae71c4eec4f88521e190b736445c54f555021a273a75f57acbc9234237e6973a21fc3bf8f71d8c8b51d6422d719f03546ecd6887a20fe1b SHA512 e3b851253c347893a80e866e7d0188c572f2a87a540125de3d9cbe0b8c3f1ddfab2c60ee3ffde3fd7274fc662294c978c39b1b52acfd92c52fd552966da203be
DIST httpbin-0.7.0.tar.gz 92613 BLAKE2B 59252df1d4d0ef853ec65263b472d3ba6c597336d844f9b457f2d0a009048d4222f715a7f6fb120aca00fa641d1687e302036dc151bd2fd67ba98cf5fc47a63a SHA512 82e80058b58943637e9f8191764cea79bf7a6e40f36069f9b5d3f908585dbef20a03ef070d1f865d350920b6e874a93a48a544b05c14ff4911038ec2c20f6f63
EBUILD httpbin-0.10.0.ebuild 942 BLAKE2B e8c39c88fa05c542a18b0524e663d978355792d509a7e0be24e7a15b8392cb9d540f4eb5cb5e58801831352aeec894969523df693e2bfaa20416d0a77a640d22 SHA512 c2f759e92e9ff1ac093f27ffd8f916990b6ec38e80bd63bb0522af03fc6cd8365b0ad6ee942052e38e01eede9f072d869540bb4de813716e360ca421b19089d2
-EBUILD httpbin-0.10.1.ebuild 813 BLAKE2B d39d8901a1780dc585b484e57dfc9db9ed0ee5bf74049983490ac9a3a20ece84dd18d69992f4d1593863239c24e66c8d636217908ee7c04f345a07b0e7d68688 SHA512 83613fe475ebe4d8272c96dec2fc1d6e9c52af57403cbc431d49b70ee0582d3c1d943d684f718d3d522b06118fec2ada6498338a214c12d7a7a767c8f3da81af
+EBUILD httpbin-0.10.1-r1.ebuild 855 BLAKE2B 4b8363e6cee1761e0ed5d7cae6fde2b04b10fa458a160fc2d8487a50950378f7473083ad4e51094e502b3c6ac445be842b518ce0bd71c455662740e14869cb68 SHA512 1fbfd7a6f58cce71d119256e1ecf737dc56f029d2e68765b2f475d10fb25a1ff1f2b4f59fd29f871d4d64da863feddb439a221c787a971fe098e24378399ab39
EBUILD httpbin-0.7.0-r5.ebuild 1609 BLAKE2B c5fd5012488a88bcd5a31dfc74a8c776b18e125c957bbad894b42f61d11fb7309f3a80c16a0fb434232884759c05750e5d07549bf0f737ae5bb3f877c9ecaced SHA512 740d37a2f314e8233d492b1cc472a5a2be90a48c80b9197d7056d9928fa03637a5a40b920f82d380684ec1ae8b2f6393bba5e8451992843d29c436fbdf2b0988
MISC metadata.xml 445 BLAKE2B c577334830bc0d51f9df221e224c231c254b3db9129e4028d53cbd96a4481728e3b721b44f569c243deeecfb38e8dc81a7566a0b7ccd665d51b1a69a3687eb18 SHA512 fcdbd0c24e12d91df89af24befa6c9600f28083c3fe38e88ebec9856f4fb5c4c137c3b85f2271422c513bbd7c31a457f8290ebc2dd755d9117d57aa42883eec8
diff --git a/dev-python/httpbin/httpbin-0.10.1.ebuild b/dev-python/httpbin/httpbin-0.10.1-r1.ebuild
index 020ba48b0913..5c1775fc8286 100644
--- a/dev-python/httpbin/httpbin-0.10.1.ebuild
+++ b/dev-python/httpbin/httpbin-0.10.1-r1.ebuild
@@ -26,6 +26,7 @@ RDEPEND="
dev-python/itsdangerous[${PYTHON_USEDEP}]
dev-python/markupsafe[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/werkzeug-3[${PYTHON_USEDEP}]
>=dev-python/werkzeug-2.0[${PYTHON_USEDEP}]
"
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index 5d1284d57059..3346c98645a6 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1,3 +1,5 @@
DIST identify-2.5.29.gh.tar.gz 101599 BLAKE2B 57e444c99062c10334ac7d0642c47c9f706dc31447db6b5eff0997f5d6113723f6bd06d5dabf0ebdbf0dbc17d33b716e68864902ffe1c92638052458a53affa8 SHA512 f7feab8872bef0c8c3c07429f41d73455ae9f317ed5e974349af04ca0b459677c65ead47e85e58753f53f592b2a0363844496c43d7ffe25e2228f5e11b411b4d
+DIST identify-2.5.30.gh.tar.gz 101610 BLAKE2B d5f277316d58a1fbd78a193c357656e5f16e66f4a737a8b415570afc6bddedf130a4557c486696fbe0ed86542598122f65f0f14536430a59f4e970fa2ab78f75 SHA512 cbae5ca100f0e09fccd1b311243b1bc090ac63bc19fcdc57241bbdfe07920e4d0041d7ac69ab37ede38628c6f3ad8e7b34f698576f4a1188ae94dc6e32ec968a
EBUILD identify-2.5.29.ebuild 596 BLAKE2B 1ff0ef25ec8161f1b282f48401a18dbc6d8f219918089037de21686fb0fd509123a9d606c738680280effe304933771a345dda486331c942461866adcee6966f SHA512 9c58fc5a62222484d168a4be7c7463fa343fd487098318c53e3479d0508b0d75d460e217585a9ad2036262390037c03549267749093d24a6527216d217b198aa
+EBUILD identify-2.5.30.ebuild 598 BLAKE2B 15278ce98c490e872627af90b592d7c0912e7c68454e1ef02eccfe16995ddcebeb1896cc39b32c7310917c918dc8f34eacfeb1f8e5f74a282da5e5bbbd6bd6a4 SHA512 17a7eb2058b35699616c32621ecc7bee9222b6773b6cf37faa0cab88820c3c297d806ffa8d23b63ac3335ce594b27091be61f85e1f4a8725d35057830ad5b33e
MISC metadata.xml 501 BLAKE2B da95534590927f7290f78f47e30484e3349c9058048c15522e7346a74d9a2c96141a18897b10b230adf966d3c237217ef1d2dcfe59814ccfffd58ab4c38c1ebf SHA512 8d78245bbd2e14016eb70f1d8f8d6129e6b265084f7da95bd915f01ce5af94f86bd69c33c1514195de70d0f834332d9ca968a18afb59a7016c8cb58681d04d24
diff --git a/dev-python/identify/identify-2.5.30.ebuild b/dev-python/identify/identify-2.5.30.ebuild
new file mode 100644
index 000000000000..906b58d7a709
--- /dev/null
+++ b/dev-python/identify/identify-2.5.30.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/matplotlib/Manifest b/dev-python/matplotlib/Manifest
index 90fd21ed50d6..8e7ee04ae7b2 100644
--- a/dev-python/matplotlib/Manifest
+++ b/dev-python/matplotlib/Manifest
@@ -12,5 +12,5 @@ EBUILD matplotlib-3.7.1.ebuild 10081 BLAKE2B 20a93311d408f379c381bf4412481b55814
EBUILD matplotlib-3.7.2-r1.ebuild 10221 BLAKE2B e9e08c3c43f9fb7c3cc352f2e46e257127dd8cf83844b6c963402f6c7e0534b389bb2c5bd65086c70fafb4188f05a89b286ec49ad637a317c745963b9720fa7e SHA512 9e3a4f710da8f822eee9e457b8fcbdd4432fbb17375ffab36fcb8597552f4f633e75caaaefb44c3ac5a7d49d5aa6a6dfaaf82347839020048ddd2d877b832711
EBUILD matplotlib-3.7.2.ebuild 10290 BLAKE2B f429909f7dceaf77aa96e921e426a6fbb2d67b96f450dfebbf12a09df23d35902abe25b425eb3ea8e331d4c252a0ef74a6eae83b46d9f3ef73e302b711a5fdf6 SHA512 dba873d255fbbd4d4cde4afca61150b600466cdcf597e9a25cd1ed9c6da2fcb928b824496c8e3f315463fc3d1651b49b32983ebdfaa8c887c93949dcee7fd1e8
EBUILD matplotlib-3.7.3.ebuild 10008 BLAKE2B ca25579dc5c3f41a890c38e2889fbbbd99e51d5defabe926a172aec975415563225b84499fad053cc41f737da6d66506e1185e102259df5700985fd18420a04c SHA512 0da8c030af4744a84709f7baa7fd52052eb36731621cf20251620b2d29a9897c36ad136a2523ae03a6a1db7a81dab16f754d1120a9d4d3db3b8227d0caf54f4a
-EBUILD matplotlib-3.8.0.ebuild 9908 BLAKE2B db7b6b7249582d970d64ae6be2ed85ee997d902ab830510886c677247c8e5f42832297351d744c7dc684e7a3cc696849c799c1c7db8c2590b8364f4f053aba01 SHA512 bf8145928b22e863d8d57fb224f0d985b2468c5cbc288ebcbb422c76da742f67ace551a3ad4c70f15dd1ac8af6c0d16326c6ff11c02b6d66e0b03e8bb6c36bd4
+EBUILD matplotlib-3.8.0.ebuild 9907 BLAKE2B 1c6754b4fee4e7ffc02c5535987c7168c8654832464ed3e8d9d7ce6592a5c989fac817a7744f53753924155cd2bbc084b7d5bf92c0d243ae8ea56b4d82b2272b SHA512 b18457bf630f3fd3b464a68c033b64b000681e7d0c1056551997b559ec79cf77791d564745807e9380f9ba569053541de810c560e252ecd86de8cb1871612ee2
MISC metadata.xml 1074 BLAKE2B 1d7dce116e09939378872c2eaf5153948b7e934626110eb4899d0dfc2781429522328f1c4efd2c40f829da64e19bed8f9fbd1b8907a6e74a5fd54587c1d29e5b SHA512 e344bfc813e09c24a8edfa9c062eb2a6c44535559370f508a27a2de20c6ab92aeb48bc8daf9c357178e513eb2474a33782e4098c0f3bcbb84b11f7388ef1a704
diff --git a/dev-python/matplotlib/matplotlib-3.8.0.ebuild b/dev-python/matplotlib/matplotlib-3.8.0.ebuild
index 8b5bd939451b..fff6fc97896d 100644
--- a/dev-python/matplotlib/matplotlib-3.8.0.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.8.0.ebuild
@@ -30,7 +30,7 @@ SRC_URI+="
# Fonts: BitstreamVera, OFL-1.1
LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~loong ~ppc ppc64 ~riscv ~s390 sparc ~x86 ~arm64-macos ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~ppc ppc64 ~riscv ~s390 sparc ~x86 ~arm64-macos ~x64-macos"
IUSE="cairo doc excel gtk3 latex qt5 tk webagg wxwidgets"
# internal copy of pycxx highly patched
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index b2ad0de0557a..8de2ee4a1660 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,5 +1,7 @@
DIST pylint-2.17.5.gh.tar.gz 1413718 BLAKE2B 7ba0a6cb78cdef5f16e80d98d1b02f41ae700c44365de26a0a650b60fe95b4b806e36786d16ec50ed5c78c8b86c13afe8e7fe215dd938df654c2883d5493d318 SHA512 431e722d027b03f1b657841ccaba43233961e810aecfe1a679e3ba4ba92fea94f28524195861a6fd4fe6fc6267a1af6489b9b69e5e30f919ac3a476fd35698ec
DIST pylint-2.17.6.gh.tar.gz 1415348 BLAKE2B d760a81cc8a453a081f1b0e3845c5a0b608b8109863665361990da127323c877e8e02ed9c1aca656fa84dd49941b23652fc465177a3e347942047299ebb86a32 SHA512 1e1bba425d295f9d267ef439f4f402dfc7284ee57ac41c222ac39e502c66bbac60c9afb0024ca4236de7cc7130ac733c781f5ee98670fae054005a8d69107123
+DIST pylint-2.17.7.gh.tar.gz 1415651 BLAKE2B 9b2edea7d7d9e05fd265749cb1e50e77513e382518dc16bf654861e66564c55a430193ab1f538cb23e31e85d2130784c648ba185d62139c6df752ca54f0fc09d SHA512 514fe9d244a58e21fade66f0e343f2162a2fc2f99d7197f4d91801250c13fde2ddc365f92a274d89d602689466a12bac3ff9dd364ce15891171ef86d6313aba2
EBUILD pylint-2.17.5.ebuild 2483 BLAKE2B ce4da2fe18989c31a7bcf2af31a117fda0150f0c0e84cccfae2d39a3a8a00e7b079ea7f872f3c03185941fad03e8b3ace4dd4085d36be73818798d9e0dfea418 SHA512 953d0ef340305f1efa399b2da5983d1838a9502074bd1c0368c2d13815e533d657279016b3c737f36892b6cf552c413e565458dbf64cecb4b1e9d4782f7f0594
EBUILD pylint-2.17.6.ebuild 2491 BLAKE2B 18c9de8487ecd5eb15e0031da3393b3da4e054a845afb2eda631d736fd68bc5f6b1bb075db44b7d7717d8a4875e8114ce2f7c9fe5162959b5c8b75977b9c3289 SHA512 a411429f28bb0313b1ff947324a6d3951c65544e4f5995f26e4dca39649c4ad6ed03817c61c44bff810c4ebf011cfa9be1b5b5f6268830ae26738c2c251ee8c9
+EBUILD pylint-2.17.7.ebuild 2491 BLAKE2B 78c84afe98dadde45807dbedfa7396f757d73bb2379105cfb77fb6e0ec97ddc31f053f34dbc59955d63244cc2d14f8f9783b7195eeed2d1518fd40d54ed09321 SHA512 00e936e9c3526760f7c86b3408709660920ef2073ffc57dff48ef970f87e28ea496e895510c237083f112e9cdf9cb8f7054b5c1a77c452664f741adfd3917859
MISC metadata.xml 1105 BLAKE2B aa9d049b732f9198685901a0ec31f4a615da8398ce1741558e7b2c3840890da0c5ac6a2a23e0fd4cd45fb443b92f69b3fe4fb7f9d7570b1a75a0d0784231f392 SHA512 5f5bb3e31554bdc0cdcdaf1d7df9194e32da649784124714783c5d280c7ab4a9f65317b5d5e6de47698b2f30a019051191cb7ef3066902b606e2582a31f01c05
diff --git a/dev-python/pylint/pylint-2.17.7.ebuild b/dev-python/pylint/pylint-2.17.7.ebuild
new file mode 100644
index 000000000000..79d1f101ebe1
--- /dev/null
+++ b/dev-python/pylint/pylint-2.17.7.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/pylint-dev/pylint/
+"
+SRC_URI="
+ https://github.com/pylint-dev/pylint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/pylint-dev/pylint/blob/main/pyproject.toml#L34 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-2.17[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.15.8[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf pylint || die
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ 'tests/test_functional.py::test_functional[forgotten_debug_statement_py37]'
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ 'tests/test_functional.py::test_functional[shadowed_import]'
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_error_msg
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_info_msg
+ tests/config/pylint_config/test_run_pylint_config.py::test_invocation_of_pylint_config
+
+ # apparently fragile, needs unpickleable plugin
+ tests/test_check_parallel.py::TestCheckParallelFramework::test_linter_with_unpickleable_plugins_is_pickleable
+ )
+ local EPYTEST_IGNORE=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ )
+ epytest
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}