summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-22 14:44:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-22 14:44:10 +0100
commit63627de4936707c40b5c4dca4f23e9fe1e9c4837 (patch)
tree0882ba9f0e330ae7e1f2f3306a6683000060355d /dev-python
parent940cec7afea0fff03b206c62a512335e6f9d2d00 (diff)
gentoo auto-resync : 22:10:2023 - 14:44:09
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin267302 -> 267469 bytes
-rw-r--r--dev-python/dns-lexicon/Manifest2
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.16.1.ebuild2
-rw-r--r--dev-python/pytest-recording/Manifest3
-rw-r--r--dev-python/pytest-recording/metadata.xml12
-rw-r--r--dev-python/pytest-recording/pytest-recording-0.13.0.ebuild46
-rw-r--r--dev-python/vcrpy/Manifest3
-rw-r--r--dev-python/vcrpy/files/vcrpy-5.1.0-py312.patch35
-rw-r--r--dev-python/vcrpy/vcrpy-5.1.0.ebuild10
-rw-r--r--dev-python/wxpython/Manifest2
-rw-r--r--dev-python/wxpython/wxpython-4.2.1.ebuild124
11 files changed, 235 insertions, 4 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 9a467747057d..40f6df813e2e 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index 38275849faf8..1b23a5eb3a0b 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -11,5 +11,5 @@ EBUILD dns-lexicon-3.14.1.ebuild 1918 BLAKE2B fa4274c3add2a44a14612dabf3f8382f85
EBUILD dns-lexicon-3.15.0.ebuild 1905 BLAKE2B 9f79af7861c3578a9aa301150d13cf0e9228947e1e02f0d2e80c1609a6339614f607baf6e6c37f74e5466485eda7859658772b397c243a84ac9bfa5bd134f341 SHA512 ec067f6d8590dfc7f0bb84067eba284ac2e4c78631cc0c3bfaf7ecc0bcdf12846cf276ad4ce9250848ffa4ddaf746b0dab75df5bad661db8e611b640eee796d1
EBUILD dns-lexicon-3.15.1.ebuild 1905 BLAKE2B 9f79af7861c3578a9aa301150d13cf0e9228947e1e02f0d2e80c1609a6339614f607baf6e6c37f74e5466485eda7859658772b397c243a84ac9bfa5bd134f341 SHA512 ec067f6d8590dfc7f0bb84067eba284ac2e4c78631cc0c3bfaf7ecc0bcdf12846cf276ad4ce9250848ffa4ddaf746b0dab75df5bad661db8e611b640eee796d1
EBUILD dns-lexicon-3.16.0.ebuild 1905 BLAKE2B 9f79af7861c3578a9aa301150d13cf0e9228947e1e02f0d2e80c1609a6339614f607baf6e6c37f74e5466485eda7859658772b397c243a84ac9bfa5bd134f341 SHA512 ec067f6d8590dfc7f0bb84067eba284ac2e4c78631cc0c3bfaf7ecc0bcdf12846cf276ad4ce9250848ffa4ddaf746b0dab75df5bad661db8e611b640eee796d1
-EBUILD dns-lexicon-3.16.1.ebuild 1905 BLAKE2B 9f79af7861c3578a9aa301150d13cf0e9228947e1e02f0d2e80c1609a6339614f607baf6e6c37f74e5466485eda7859658772b397c243a84ac9bfa5bd134f341 SHA512 ec067f6d8590dfc7f0bb84067eba284ac2e4c78631cc0c3bfaf7ecc0bcdf12846cf276ad4ce9250848ffa4ddaf746b0dab75df5bad661db8e611b640eee796d1
+EBUILD dns-lexicon-3.16.1.ebuild 1905 BLAKE2B c5fabe1777226bbbba6da9efabf3f6008ab9c2471c6fb90b0149defd3ceedcb35a060d9d46f498aecd3c3967a90ef28027e27ed6523dc52eafafeda1d6b1ae4e SHA512 fc6165145019d12e814c9b54dfee7c9dbecf3e0420cd0dac7da1737969a177a972b090fa6195d812cd6514b678f008f2d7db2527b9d6f1a33fe670e3e88c3793
MISC metadata.xml 541 BLAKE2B a22266eac0bc7b4c22d9552cf64cbf88bbc1c2953e3ef0daaf059b81519909e0f8808e0d74cec6db3296e43f98082d57b8ae3779d694432e8578112ac18c3ea6 SHA512 79e2b43a685bfcc8dace1faa1c1a08cc648b39a3fef2834a57b6e801f72e7309276604253089db7a2fbe1d5d776b2ba1427c90a9cb9c44a0c1b2812d4e1901db
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.16.1.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.16.1.ebuild
index 55e62bd2d181..c3b422c0944f 100644
--- a/dev-python/dns-lexicon/dns-lexicon-3.16.1.ebuild
+++ b/dev-python/dns-lexicon/dns-lexicon-3.16.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 optfeature
diff --git a/dev-python/pytest-recording/Manifest b/dev-python/pytest-recording/Manifest
new file mode 100644
index 000000000000..e5c15ad023ea
--- /dev/null
+++ b/dev-python/pytest-recording/Manifest
@@ -0,0 +1,3 @@
+DIST pytest_recording-0.13.0.tar.gz 25027 BLAKE2B c325aaf809617886e85c3fa597c36858c7e1a9cb1552a18c8ee27f5a7479b66469b61bce51ceb14fc9dd5fa420c20803ed016875eef1a0cf05de5293ead24bfc SHA512 2e9ab39971d89f838f2d778d1d80fdb5519b39855a69019eeeb22d69ca3c92ecb14a7eda7b55ec37ea07fae0c3316c9c16932a0afcf0abe0dbfefc31fe23bd68
+EBUILD pytest-recording-0.13.0.ebuild 1052 BLAKE2B 0aef24005d1eafcfc347c300d8bf110b13381718dfec2d58964252b9846976ef6a0ecc55e3c671d2c46f5c233ca6cb51785241bf6277f02f484ad4661034595b SHA512 6f597fa60f6234ac95ef320d1183e831f35003409535017099f08f94c482302377b76e2d82efca66536b268faaf7f733330a156dae6b08e4e012f770a3ce29ac
+MISC metadata.xml 386 BLAKE2B 315ecea597106e9df678c10b0c5b24432795ddfaa07a8a7ae35361e3539ce31ceb1759c6bf49f5b588804d3b66157d599a8ae0858b5b8bca7972a58439bc8c64 SHA512 f652dd2ddf5752c2d5d022e8ad6cd68dee0f8421e71bf618a42e7e4786f61deda68316f9f8e518f34a761aaf1c9d48f55b7d49ba0a7a547f517436cfc781e2c9
diff --git a/dev-python/pytest-recording/metadata.xml b/dev-python/pytest-recording/metadata.xml
new file mode 100644
index 000000000000..9fa86cdaa74d
--- /dev/null
+++ b/dev-python/pytest-recording/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">kiwicom/pytest-recording</remote-id>
+ <remote-id type="pypi">pytest-recording</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-recording/pytest-recording-0.13.0.ebuild b/dev-python/pytest-recording/pytest-recording-0.13.0.ebuild
new file mode 100644
index 000000000000..a5f981d06b75
--- /dev/null
+++ b/dev-python/pytest-recording/pytest-recording-0.13.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pytest plugin to record network interactions via VCR.py"
+HOMEPAGE="
+ https://pypi.org/project/pytest-recording/
+ https://github.com/kiwicom/pytest-recording/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pytest-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/vcrpy-2.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test () {
+ local EPYTEST_DESELECT=(
+ # Internet
+ # https://github.com/kiwicom/pytest-recording/issues/131
+ tests/test_blocking_network.py::test_block_network_with_allowed_hosts
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_recording.plugin
+ PYTEST_PLUGINS+=,pytest_httpbin.plugin,pytest_mock
+ epytest
+}
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index e3a888997584..894fecf926eb 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,3 +1,4 @@
+AUX vcrpy-5.1.0-py312.patch 1227 BLAKE2B 774de5c873ca17b5a08d9c38c743402ead83efc4ca98d90ebba3ae54faf3e482047b1078815b981da1cdfbed9cd9474657e08021a27104ab064220d81d3c52ed SHA512 08fb62ca1dc79bf0e90ef7845e3ca77d37d5537558db68591d203dc2eea1e3cf2f0638b0c153a9a26539f7a08ea42bcb15d57a077de5a9fea52fe4f3440340c6
DIST vcrpy-5.1.0.gh.tar.gz 337183 BLAKE2B 76805db7c034fe4f6e0d6fb18340ad24a25a28ece4576d97958d689e46667a8ab2fb6cdc8186f635a7c4f4833d4ea541573bf6c5e0f775f842e60683336ad87e SHA512 dfb2e02027ed2e37f4c2201b410847cf1f03b1999853e3f838e49abf1e93641d58addb18f6144c484f9d4618693b9a99d73dc7fb55eb1de2c383109e054e3713
-EBUILD vcrpy-5.1.0.ebuild 1677 BLAKE2B 39dbc3018309a25639df46762e999643e699ec130bd7795b612c8c0e4bdc07dd594acb3a77e0b20b7b712a0b3a712250f59dd78628200e152eb0f53a6ba53917 SHA512 7c1fe673a2cde4274f6031f7767213446088f77d1bedc4c87cc58ed91aa04f4d44be8a3c3c3647301542c179b3a52e5f759c06b7906f9f8737a0695a4892801e
+EBUILD vcrpy-5.1.0.ebuild 1938 BLAKE2B 1df91b6165faa1438322cf7227731d04b533083fdd0326651a3c6eb50f598f1ad62ee9ed48c25e1609681f54459c793bc33687e5a5b2425da3914438b71a1c3f SHA512 306564cf80f58a35e957c2f515f32e85e5a1b706d7d587bef5abcf58c8e4e3d352c75efdf5bf2df5dd250f835174501f8500a438be394d2c9e03266c7567991c
MISC metadata.xml 388 BLAKE2B fd31293bd6085e6a93816a1813a8c3a9d046ed3d932fba5b32b454a71e7535606ba92815699b7ca10fc837b07a5335df54d5fae8c860a7ea88c6ea72891d0620 SHA512 0360ac6f113035ffd1991d2a42000f290c9d0a3fa8c4dac9abfde0eecafd23e1ff9929d8ee521f83a924c523992fabc5cb4353079bf7c52dac9f906a31d4da55
diff --git a/dev-python/vcrpy/files/vcrpy-5.1.0-py312.patch b/dev-python/vcrpy/files/vcrpy-5.1.0-py312.patch
new file mode 100644
index 000000000000..2dc9fdf09e88
--- /dev/null
+++ b/dev-python/vcrpy/files/vcrpy-5.1.0-py312.patch
@@ -0,0 +1,35 @@
+From 69621c67fb29dedd9ece4a7bdbf50380fbe4c5ee Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Thu, 3 Aug 2023 06:51:45 +0200
+Subject: [PATCH] Copy `debuglevel` and `_http_vsn` attrs into response classes
+
+Copy the `debuglevel` and `_http_vsn` attributes from base connection
+class into response classes, in order to fix compatibility with
+Python 3.12. For reasons I don't comprehend, these end up being called
+on the class rather than instance, so regular proxying logic does not
+work.
+
+Fixes #707
+---
+ vcr/stubs/__init__.py | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/vcr/stubs/__init__.py b/vcr/stubs/__init__.py
+index dafaec71..4d4bb39d 100644
+--- a/vcr/stubs/__init__.py
++++ b/vcr/stubs/__init__.py
+@@ -389,6 +389,8 @@ class VCRHTTPConnection(VCRConnection):
+
+ _baseclass = HTTPConnection
+ _protocol = "http"
++ debuglevel = _baseclass.debuglevel
++ _http_vsn = _baseclass._http_vsn
+
+
+ class VCRHTTPSConnection(VCRConnection):
+@@ -397,3 +399,5 @@ class VCRHTTPSConnection(VCRConnection):
+ _baseclass = HTTPSConnection
+ _protocol = "https"
+ is_verified = True
++ debuglevel = _baseclass.debuglevel
++ _http_vsn = _baseclass._http_vsn
diff --git a/dev-python/vcrpy/vcrpy-5.1.0.ebuild b/dev-python/vcrpy/vcrpy-5.1.0.ebuild
index daa52ed9d3d6..0cc7495e8266 100644
--- a/dev-python/vcrpy/vcrpy-5.1.0.ebuild
+++ b/dev-python/vcrpy/vcrpy-5.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -36,6 +36,10 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}/${P}-py312.patch"
+)
+
distutils_enable_tests pytest
python_test() {
@@ -52,6 +56,10 @@ python_test() {
# broken by simplejson, doesn't seem important
# https://github.com/kevin1024/vcrpy/issues/751
tests/unit/test_serialize.py::test_serialize_binary_request
+ # new httpbin, sigh
+ # https://github.com/kevin1024/vcrpy/issues/761
+ tests/integration/test_basic.py::test_basic_json_use
+ tests/integration/test_register_persister.py::test_load_cassette_with_custom_persister
)
local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
diff --git a/dev-python/wxpython/Manifest b/dev-python/wxpython/Manifest
index 808cbcb4ddf0..a875d6fceac5 100644
--- a/dev-python/wxpython/Manifest
+++ b/dev-python/wxpython/Manifest
@@ -3,5 +3,7 @@ AUX wxpython-4.2.0-flags.patch 711 BLAKE2B d05ee176b010199f32ba4325452d7eddb60b7
AUX wxpython-4.2.0-no-attrdict.patch 363 BLAKE2B 2ab3735103574959e069ecd647dc003ad6362760214a67632c91a7d216a372b4bf13450a7420bb8415bd744cac23a514726bf6feb09302b775a2a4c580094599 SHA512 b410023d186db3b07b3780fad2e1037d5a854f10771a5e1c8cd98da91a36e727931bf75944ff1a56e0730ff78a4ec8c9a3d81dec02efa3fe91191ad0a1639859
AUX wxpython-4.2.0-no-webkit.patch 1285 BLAKE2B 19fdee2293da214b8ae318b2670298b34b745cfefd3938be1f22c810cb1bc4273d628aa34cf427c1023d90739784d8e5c8d381e6084689876bdc336a86a3d0db SHA512 fbe6825f266443b9dec68786e26d6e3842d4dec3b9927420ecaca45a834798c8ef83a95398ea498db386e7d1c659a6a3779a5b62867296cc7244401b06db9586
DIST wxPython-4.2.0.tar.gz 70958238 BLAKE2B 2e8e34c4f5d1992983bfe4e09bb56ee5619b139b9b3b5f05dee48ecdf6971cf9fe1b0fb22aec685904eb44db6f50a4ba132a08aa91930d809040da828efa097e SHA512 9ec937a024efb2916403c84382a66004f0c2bb07471246b7de517778309ce459e929eeb59e261f538d3fa077c950628de62e49a3760fbd03ab9ff2114c6f354f
+DIST wxPython-4.2.1.tar.gz 73724359 BLAKE2B d9569ea172c7279e0b2cfcb3cdcd5d1faab5324e2648c9b0f8c8b838fb2355dc6af28c4593e5dd0cfa02573133bf15a58a6ffa9711d854925a9cada0985dc7f8 SHA512 ee9ab8effb3c71de004c3d61ec583b9980c6b75fe9bb04cf2c76025ea70afc206bc3073c44d1c83c7ba604afed9fd38c01b9ef506617ba279a4ac58e3cf34438
EBUILD wxpython-4.2.0.ebuild 3919 BLAKE2B 8b5a95b14ffb88ba9eda28307b7c9a7a0bac1335b943a0dc7f378bbc3ee2c568cc3b553b912bd4aa7670be106436be78d91812f0bdee5347229f60bbc3bb049d SHA512 de5f632e2309e18dee4577e26051431d148a7b2b79725e2dbf82459b754c6193ec52f5b061ae5b41381479338af828ccd209912bbcd6157384945838956ec94e
+EBUILD wxpython-4.2.1.ebuild 3440 BLAKE2B a2dff71e862e5652d66d2811d0f36e2146c48011eeacb2b986edf3b9560a175a1df6f8f7d3e7306c4bf45391bd7a3b0a0764f2c47879357441dccb47e1f76f1f SHA512 0ab2f6cbf44c037725b6640b68baf4e4deafa20bf5fe270b21047e07ed387d854f2b9a1a11ef7843e7c1c359c4d405310f8551791034cae7a9834770b8cf1774
MISC metadata.xml 491 BLAKE2B ffa0cccf66f484c856fb30249bd0ccc3b0da2f3ee8e3c3a0df1782bc58e4867ff99d9711f1784b44b439f2a8bcf297c1082b49a941823f046c7f2c7977a77629 SHA512 a2f5908a276a8f9c512cb59c8d17873398c91b21977371ab724e669f3b6c032d53510fbcd183a5dc340279fc522289e617b8c313c0d825ca70d0d2a5d74f8cfa
diff --git a/dev-python/wxpython/wxpython-4.2.1.ebuild b/dev-python/wxpython/wxpython-4.2.1.ebuild
new file mode 100644
index 000000000000..e149807f6d11
--- /dev/null
+++ b/dev-python/wxpython/wxpython-4.2.1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_IN_SOURCE_BUILD="1"
+PYTHON_COMPAT=( python3_{10..11} )
+PYPI_NO_NORMALIZE=1
+PYPI_PN="wxPython"
+WX_GTK_VER="3.2-gtk3"
+
+inherit distutils-r1 multiprocessing virtualx wxwidgets pypi
+
+DESCRIPTION="A blending of the wxWindows C++ class library with Python"
+HOMEPAGE="
+ https://www.wxpython.org/
+ https://github.com/wxWidgets/Phoenix/
+ https://pypi.org/project/wxPython/
+"
+
+LICENSE="wxWinLL-3"
+SLOT="4.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test webkit"
+RESTRICT="!test? ( test )"
+
+# wxPython doesn't seem to be able to optionally disable features. webkit is
+# optionally patched out because it's so huge, but other elements are not,
+# which makes us have to require all features from wxGTK
+DEPEND="
+ >=x11-libs/wxGTK-3.0.4-r301:${WX_GTK_VER}=[gstreamer,libnotify,opengl,sdl,tiff,webkit?,X]
+ media-libs/libpng:=
+ media-libs/tiff:=
+ media-libs/libjpeg-turbo:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ app-doc/doxygen
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/sip-6.6.2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ test? (
+ ${VIRTUALX_DEPEND}
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.2.0-flags.patch"
+ "${FILESDIR}/${PN}-4.2.0-cython-3.patch"
+)
+
+python_prepare_all() {
+ if ! use webkit; then
+ eapply "${FILESDIR}/${PN}-4.2.0-no-webkit.patch"
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ setup-wxwidgets
+}
+
+python_compile() {
+ DOXYGEN=/usr/bin/doxygen ${PYTHON} build.py dox etg --nodoc || die
+
+ # Refresh the bundled/pregenerated sip files
+ "${EPYTHON}" build.py sip || die
+
+ # Build the bindings
+ "${EPYTHON}" build.py build_py \
+ --use_syswx \
+ --no_magic \
+ --jobs="$(makeopts_jobs)" \
+ --verbose \
+ --release || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # virtx probably
+ unittests/test_display.py::display_Tests::test_display
+ unittests/test_frame.py::frame_Tests::test_frameRestore
+ unittests/test_mousemanager.py::mousemanager_Tests::test_mousemanager1
+ unittests/test_uiaction.py::uiaction_KeyboardTests::test_uiactionKeyboardChar
+ unittests/test_uiaction.py::uiaction_KeyboardTests::test_uiactionKeyboardKeyDownUp
+ unittests/test_uiaction.py::uiaction_MouseTests
+
+ # assertion (TODO)
+ unittests/test_aboutdlg.py::aboutdlg_Tests::test_aboutdlgGeneric
+ unittests/test_lib_agw_piectrl.py::lib_agw_piectrl_Tests::test_lib_agw_piectrlCtor
+
+ # seems to rely on state from a previous test (sigh)
+ unittests/test_lib_agw_persist_persistencemanager.py::lib_agw_persist_persistencemanager_Tests::test_persistencemanagerRestore
+
+ # requires Spanish localization
+ unittests/test_intl.py::intl_Tests::test_intlGetString
+
+ # TODO
+ unittests/test_tipwin.py::tipwin_Tests::test_tipwinCtor
+ unittests/test_lib_pubsub_provider.py::lib_pubsub_Except::test1
+ unittests/test_windowid.py::IdManagerTest::test_newIdRef03
+ )
+ local EPYTEST_IGNORE=()
+ if ! use webkit; then
+ EPYTEST_IGNORE+=( unittests/test_webview.py )
+ fi
+
+ # We use pytest-forked as opensuse does to avoid tests corrupting each
+ # other.
+ virtx epytest --forked -n "$(makeopts_jobs)" unittests
+}
+
+python_install() {
+ distutils-r1_python_install --skip-build
+}