summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-27 01:15:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-27 01:15:54 +0000
commit4b5a61a22263bba1a5119af1b9b61f80517d02fd (patch)
tree7acb10c8fed343782088865ecd16bd3efe268ad7 /dev-python
parentb3e456d42287ef73c7ff48148d18a9ea8fb8debf (diff)
gentoo auto-resync : 27:11:2022 - 01:15:53
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin261414 -> 261401 bytes
-rw-r--r--dev-python/caldav/Manifest2
-rw-r--r--dev-python/caldav/caldav-0.11.0.ebuild50
-rw-r--r--dev-python/httpauth/Manifest3
-rw-r--r--dev-python/httpauth/files/httpauth-0.3-remove-nose-dependency.patch40
-rw-r--r--dev-python/httpauth/httpauth-0.3-r1.ebuild12
-rw-r--r--dev-python/nuitka/Manifest4
-rw-r--r--dev-python/nuitka/nuitka-1.2.3.ebuild (renamed from dev-python/nuitka/nuitka-1.1.8.ebuild)0
-rw-r--r--dev-python/scipy/Manifest4
-rw-r--r--dev-python/scipy/scipy-1.9.3.ebuild11
-rw-r--r--dev-python/scipy/scipy-1.9.9999.ebuild11
11 files changed, 118 insertions, 19 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 361103c09bba..cbb0b2bbe113 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/caldav/Manifest b/dev-python/caldav/Manifest
index 9f59bbc369a7..4dd541075b79 100644
--- a/dev-python/caldav/Manifest
+++ b/dev-python/caldav/Manifest
@@ -1,3 +1,5 @@
DIST caldav-0.10.gh.tar.gz 121800 BLAKE2B 6398e2e94f40e6c0d8fa757a02ae2aedcdc2bef59be9b6499a9ff86304ee2280222ff4490b9cf6fe2b37bd1e5031e17f472afbd0e42da2a82a27aec87cfecd08 SHA512 1cd98a3f59381c238ba424a30a6596e969c04bcab74cd1f9cbf9bae1da32d23b12a718135252a12fc069091994ef451bf504a05097d9539a79b397370c55609f
+DIST caldav-0.11.0.gh.tar.gz 126186 BLAKE2B 0d818ea5e76b88b3ea18f1fd878a297fa88ad9921d994a61d05c02aa80b73ac40bd8cb36810a050d8f6a87009911655b64a8a4ef09133cb751a225adacdd5575 SHA512 761753fa86e2ba9788030df1af482177bd01ee266a7fe8da744ac85eee95a74d1450e1afa0f64109b9c12aaedba0354d76da2ee9b27dec2771141fc453727d4f
EBUILD caldav-0.10.ebuild 976 BLAKE2B e9fc1c933cadaa68715a872872c920bd52ca116a715cd8889ceeb111f41fabee9fa390a00064d30a33a29eaf5aae59fb4dd984b2c69d707baa87e694d15795a8 SHA512 0aebe3b8b30496ff0597cf4b372eb2a37436a4c0d875e6e02d0997b0f9ff689794aecad23fa8f1ad80c1be38463fca1c82cbcf33a4c004a746d532b37d3bedaa
+EBUILD caldav-0.11.0.ebuild 1295 BLAKE2B 040de0a23aabad8160e25e9b9c97f47cdd7d7bfc701d1734acd6d5c80480d626629bb8cdf0651b998905d8be121ebc7385318b45591a31b7634e9ac73c0f11e5 SHA512 998b3776e201dd5da65a018c45baa72104daa4f3f41fdc98cd94dbcfd3b01897f52c4056c333125b74e483f1e3c4205be0b93712a121f14b1958fc5c20c7f908
MISC metadata.xml 394 BLAKE2B f0b9c600418cbbc4c935d53b63f4e6c1235500984ed388ceb26c6e02fdb7200eec1464d8c4af17e6afdf3688479f0a0763e6e710f916c1c71dab2ca84df9509f SHA512 4f94039805c6cbfb97a667d555af39bcce7f10db8a7c61f3b8b48a903fcd52d3e30467c91c9ec13195be6dc3c4ccbfa088aeac390d5e1c64e9267527a8b77b6b
diff --git a/dev-python/caldav/caldav-0.11.0.ebuild b/dev-python/caldav/caldav-0.11.0.ebuild
new file mode 100644
index 000000000000..de90382f0920
--- /dev/null
+++ b/dev-python/caldav/caldav-0.11.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="CalDAV (RFC4791) client library for Python"
+HOMEPAGE="
+ https://github.com/python-caldav/caldav
+ https://pypi.org/project/caldav/
+"
+SRC_URI="
+ https://github.com/python-caldav/caldav/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( GPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ www-apps/radicale[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # needs unpackaged recurring_ical_events
+ tests/test_caldav.py::TestLocalRadicale::testTodoDatesearch
+ tests/test_caldav.py::TestLocalRadicale::testRecurringDateSearch
+ tests/test_caldav_unit.py::TestExpandRRule::testZero
+ tests/test_caldav_unit.py::TestExpandRRule::testOne
+ tests/test_caldav_unit.py::TestExpandRRule::testThree
+ tests/test_caldav_unit.py::TestExpandRRule::testSplit
+)
diff --git a/dev-python/httpauth/Manifest b/dev-python/httpauth/Manifest
index 65488cc5f4e4..e278f4d0711c 100644
--- a/dev-python/httpauth/Manifest
+++ b/dev-python/httpauth/Manifest
@@ -1,3 +1,4 @@
+AUX httpauth-0.3-remove-nose-dependency.patch 1239 BLAKE2B e4d40f37e88b7bc0e95d012837b3a256d75f8a67c41dbf66b6bd2d11f769f584771de3a5b83707ae32f8b4d5175d8814f57bc89450ba7f049b4afe3a91474b47 SHA512 a0cc7ce2db92e9bc89b4f5ef5be393e3c8a444729f0000aead02701e7128ed0a489f08f366f3ae327e476f10b29c4d81d1e1a743ab4c5bec032ab8c1204c9564
DIST httpauth-0.3.tar.gz 4440 BLAKE2B 41c9ba9ee50b7fcc4ed409f4b34897b5243df4065fd081cd5c0951ebe2719a34a424e59c21adbcd9be133c8fe4fa4ad9dc7bec561285b873987f982f684b3682 SHA512 aa35148322a1c5ffc22a132d3062d300118aa23181a0008018d0aacfd473758d86d50ff1236d88126858a53e2f45aeea938988b2d1a8f62f80a97d8c2cc69822
-EBUILD httpauth-0.3-r1.ebuild 471 BLAKE2B b4155fd7baaec6e39dbad3daff43803f78e72b24c1ee3e2c246964f26ce2bca191e036683e300b33e958dc0c716d71999fd4553f86de3395d164e0428f5afd97 SHA512 dd144bd32e7ad1944612e91d6beaa3b027bdcb884c0b59a8305abecddd8224786d115ed6e95d45b641976551a36d9f128ff753313b1aea4414a794b1c1984d94
+EBUILD httpauth-0.3-r1.ebuild 572 BLAKE2B 4f09b41a80d176ebcc96bb153d339ce46d672e9b48f200e9d420ee91a8710be115c607ca9800f79f6b2e6a47efcc30521dd1c5a2bc96249d3403d83a8256fb27 SHA512 3d7157523b5c7908aad90b01e8e431f096893e66339752898fecb84b0028836fa7339ff4518b656d3a25f5bc2ce3a83b3bb23906cee251b7717ee08a84fddedf
MISC metadata.xml 441 BLAKE2B 2c3d0480d416c2d12e0e5a4d511a5a2c04d2e26d1ddf4a52528371f16c36059276ac7f4b2c9b0d2d40a7d93aa5d3323e1763ada535ccc37a2c5b74ee28449dc5 SHA512 17202ae2f283611ae3a31f9519c7d11b32c904e729efbf878c928d5920481d1c4279127763a4d11f89b5354c677a213909cd4db39bbef56539bf4474ad61af1c
diff --git a/dev-python/httpauth/files/httpauth-0.3-remove-nose-dependency.patch b/dev-python/httpauth/files/httpauth-0.3-remove-nose-dependency.patch
new file mode 100644
index 000000000000..5cb607c2bb4c
--- /dev/null
+++ b/dev-python/httpauth/files/httpauth-0.3-remove-nose-dependency.patch
@@ -0,0 +1,40 @@
+commit d57060ebaeca8cd38e03cc64f9ee0996e83b50a9
+Author: Jonas Haag <jonas@lophus.org>
+Date: Thu Apr 21 08:58:36 2022 +0200
+
+ Move CI to GHA (#3)
+
+--- a/tests.py
++++ b/tests.py
+@@ -10,7 +10,7 @@ except ImportError: # Python 2
+
+ from httpauth import DictHttpAuthMiddleware, DigestFileHttpAuthMiddleware, md5_str
+
+-from nose.tools import raises
++import pytest
+
+
+ def parse_dict_header(value):
+@@ -121,16 +121,16 @@ def test_without_realm():
+ assert 'Digest realm=""' in response.headers['WWW-Authenticate']
+
+
+-@raises(ValueError)
+ def test_invalid_digestfile_1():
+- DigestFileHttpAuthMiddleware(StringIO('u::realm:hash'),
+- wsgi_app=wsgi_app)
++ with pytest.raises(ValueError):
++ DigestFileHttpAuthMiddleware(StringIO('u::realm:hash'),
++ wsgi_app=wsgi_app)
+
+
+-@raises(ValueError)
+ def test_invalid_digestfile_2():
+- DigestFileHttpAuthMiddleware(StringIO('u:realm:hash\nu2:realm2:hash2'),
+- wsgi_app=wsgi_app)
++ with pytest.raises(ValueError):
++ DigestFileHttpAuthMiddleware(StringIO('u:realm:hash\nu2:realm2:hash2'),
++ wsgi_app=wsgi_app)
+
+
+ def test_ticket_1():
diff --git a/dev-python/httpauth/httpauth-0.3-r1.ebuild b/dev-python/httpauth/httpauth-0.3-r1.ebuild
index 703fdd988ecb..ae8ef46058ed 100644
--- a/dev-python/httpauth/httpauth-0.3-r1.ebuild
+++ b/dev-python/httpauth/httpauth-0.3-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
inherit distutils-r1
@@ -16,4 +16,12 @@ LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-distutils_enable_tests nose
+PATCHES=(
+ "${FILESDIR}/${P}-remove-nose-dependency.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index f65070ff0d0b..630f9068354d 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1,9 +1,9 @@
-DIST Nuitka-1.1.8.tar.gz 3931273 BLAKE2B 19425e5394f02f4e5dab612e17f80de27569a0d364aaf8597c7bf63f0aa271c3f8cfa987c12b1ae09c5449775b6e4e61aa4d733d0ed81231c4df6ef955dc030e SHA512 f1e594499cd9fcd03873646c41b66a4d89980f408412dcd58db45b3c48238503d03ef25a1b230cfa99960df69f2564b74b02c446e0431dd72634ce277347a551
DIST Nuitka-1.2.1.tar.gz 3958041 BLAKE2B 461fd91fc2948aa131a5295f3e2f8c99d8de26b32d0dd3008ee130bdc8b722a469e458a717b5cbdbf45cd3720dfff828c3eade1d57c7f0ee391cd062105b4ad1 SHA512 98a95342a78c935ebea88446ee875122baeb66290148cf8c454c8287ecc40b092015d710a1a25b35c3b6869138800d2c654b09a3424512536f06d27860bfa2bb
DIST Nuitka-1.2.2.tar.gz 3958127 BLAKE2B fb4fbbf3537d78b5375ef9e26c65bae5a09db2b8839308b8b1ab847c9e820586e84742fd89aa91f8c0bfb366309cc4106ed2195566762103a54951026f81c3b8 SHA512 4b11e15fbb81d3bbf9c687a05ecd71cec7b4f145ad7f1af5a98eb77ff6e4d93bac5e3af8474b9ba0a7bffb5b191f46960e317b53d315455a1ca2ea0660859357
+DIST Nuitka-1.2.3.tar.gz 3958335 BLAKE2B c2d47e7ff355492fb72f224be92445849c3fce13768ba7957cf4bbbbc9cd4e0ec7c3904e5465ad543e16d1419a01b42cd4399b816e1ff56e2c8ea5c57fddbc04 SHA512 1c842c21764bd0dc9bf68bb26506959b35e54d03c1d6d6b9c179289ec073ed07b75d6709a3c73ac3e14bb988a7b2f5a88f7dfcce55a25eab1c5e4b294b15d4f4
DIST Nuitka-1.2.tar.gz 3957227 BLAKE2B e82c8e30ef326254db255785efd2bab1450c2c496bbef1aae35e6f6c42fee09f2454bdff366ecfcf704aa42bbe9cd62ff5a65f26065b85e95083cb0134829dbc SHA512 65c262109f2341aab607601299ec70c88df46218ecc2bb7a7d39ff66b8d4ec43e44a5d30ac936d6572fb141ca6b19e3c0e0c01975dea82d46a2ec190ed13c21b
-EBUILD nuitka-1.1.8.ebuild 1214 BLAKE2B b5c547ea636f0c56f83984808e9596f6119416150c47d49fbb77c6ba7c9ffaf8f23781fdf6a18aadabb5e7c77986c1709820583abee20d7ec6d2e53de4655653 SHA512 9c1931c4e40b695eb166bd0160c6a4cb5874873cbd1241bf275d38c823f4cb82fc335b8083b8bac4575294cdd1a7767b31533a437ae4f5364e3bc546da989cca
EBUILD nuitka-1.2.1.ebuild 1214 BLAKE2B b5c547ea636f0c56f83984808e9596f6119416150c47d49fbb77c6ba7c9ffaf8f23781fdf6a18aadabb5e7c77986c1709820583abee20d7ec6d2e53de4655653 SHA512 9c1931c4e40b695eb166bd0160c6a4cb5874873cbd1241bf275d38c823f4cb82fc335b8083b8bac4575294cdd1a7767b31533a437ae4f5364e3bc546da989cca
EBUILD nuitka-1.2.2.ebuild 1214 BLAKE2B b5c547ea636f0c56f83984808e9596f6119416150c47d49fbb77c6ba7c9ffaf8f23781fdf6a18aadabb5e7c77986c1709820583abee20d7ec6d2e53de4655653 SHA512 9c1931c4e40b695eb166bd0160c6a4cb5874873cbd1241bf275d38c823f4cb82fc335b8083b8bac4575294cdd1a7767b31533a437ae4f5364e3bc546da989cca
+EBUILD nuitka-1.2.3.ebuild 1214 BLAKE2B b5c547ea636f0c56f83984808e9596f6119416150c47d49fbb77c6ba7c9ffaf8f23781fdf6a18aadabb5e7c77986c1709820583abee20d7ec6d2e53de4655653 SHA512 9c1931c4e40b695eb166bd0160c6a4cb5874873cbd1241bf275d38c823f4cb82fc335b8083b8bac4575294cdd1a7767b31533a437ae4f5364e3bc546da989cca
EBUILD nuitka-1.2.ebuild 1214 BLAKE2B b5c547ea636f0c56f83984808e9596f6119416150c47d49fbb77c6ba7c9ffaf8f23781fdf6a18aadabb5e7c77986c1709820583abee20d7ec6d2e53de4655653 SHA512 9c1931c4e40b695eb166bd0160c6a4cb5874873cbd1241bf275d38c823f4cb82fc335b8083b8bac4575294cdd1a7767b31533a437ae4f5364e3bc546da989cca
MISC metadata.xml 943 BLAKE2B d7ab883773e7480dcfb4b79932a3874e2274669169a24a54aa622a2a0ac079e0296da4bd196d166cb11fcff785985da0b10d0fae351032914ccf312c9bb9833c SHA512 625d8760b8e849c6e014856f584cb42f50bb5ebb1fa648cb704a5a1baf175e7d2ce9f43f6f724d11c81a68e364b6ac1c38459540b58f2ccd6a675902af5b1cc9
diff --git a/dev-python/nuitka/nuitka-1.1.8.ebuild b/dev-python/nuitka/nuitka-1.2.3.ebuild
index b55f0385d58a..b55f0385d58a 100644
--- a/dev-python/nuitka/nuitka-1.1.8.ebuild
+++ b/dev-python/nuitka/nuitka-1.2.3.ebuild
diff --git a/dev-python/scipy/Manifest b/dev-python/scipy/Manifest
index afa21ed71ccd..bfd7dc5e26c1 100644
--- a/dev-python/scipy/Manifest
+++ b/dev-python/scipy/Manifest
@@ -6,6 +6,6 @@ DIST scipy-html-1.8.1.zip 37060661 BLAKE2B 2fa617c58eb47463f8a61f9798b32c6da255d
DIST scipy-ref-1.8.1.pdf 35025868 BLAKE2B 9221755d2dc69b8623271f75ff3078a0a4410fe9ff69ee317b40bf145af7da21a7f5f4b6b67820d8bb2878f83b7014f1ea7c2f0e026afb716da0479d394505e2 SHA512 8f27dcb9dd1030e15266389af21a1475ecfec5ea777fb2dbcf8db8d3398ac6e45c7040b8d6dbaffd29be3920925427be7c55efdc8094d670c857edfdab7f7728
EBUILD scipy-1.8.1.ebuild 5275 BLAKE2B 0b2f1bb8c37c253aae87941aa9cb15352d82ff5bc34089ae7cf93cad7d264b0ceaecd7f8f0ff02670d24282a61032eaa52bf16de03e1d25d8a18fbfe7d63c981 SHA512 d7ed5f3bc61e27f898937387f88cd934147149ba40ccc01b160571db97074ccba2eb68510899bb4ee70083e47cf3e2c5c6e53435f56933cc5652e9b21a231763
EBUILD scipy-1.9.2.ebuild 2354 BLAKE2B c013d3f8f9ddf0ba89246c9af4d4285f06b6aefdafb3c988924c93b3f70e97486c352933a6855e0b33d2d62dca49a6a58a0202b590f0b32f7834894a4e97db55 SHA512 dc72624aefd000730f8b8837e0ee7f4b56f57905e211c5eff186d3b9b21d891f8eda4484235edaccbf2505bbb02e25d5945b49f51265dedc9b4fe6ec0fc18b0f
-EBUILD scipy-1.9.3.ebuild 2514 BLAKE2B 7bdb834f05937fdf660d9e9874a353ac8e405c4b2e2ef455f4d9d478b4eb37395072766665f4d5185a5d472bcec9cbdae3d375407a57fa1ff78602980f3cf58c SHA512 ca6e616681ef59802390e5555acf94ac82373a5d8c9fd3b72b29b233b4962cfb3eaf8c01e8da2c5cd81ae8d98c6af456e72ca0299e2167dad274e0d59c66bf33
-EBUILD scipy-1.9.9999.ebuild 2501 BLAKE2B 88131a1e0f1774b496f20a1f51d52e18892342851e006f5e79179c2757d878c3a8ca622f76ecc2750cda199ef2927f09d9b44f01e77df8ad354bd678c4a1fce7 SHA512 461edf81f5d3435dc0e8e3060e11d0ca0029731445fceda46065634aa3b62e33bcf5f89da04816847348227e2842ffa33d1e563f954931997ccbf63e6657e119
+EBUILD scipy-1.9.3.ebuild 2436 BLAKE2B 314d29f24855e4740c92186c4394ed06c1d1e2fbedd6d712a9cd213569e6c591ad735900445d963b1385b86cc7917dbed43b35f20870be0c277d03cd593f6e02 SHA512 ec83ee6f04fb29e4c7db731b846cebb2e17f33878373532c1a14a1248e6f9ffe00e549f1a1d841050b2484867ac50eda92154fb2eb58aa55e3b767740f24c921
+EBUILD scipy-1.9.9999.ebuild 2423 BLAKE2B 7748a666cd11817a90e8bfd284615c95be1230f7891eed9f389b1abf1d52e59a6221f1679b5a92977ce9d8cadc7ae3b11731e65c0426f320060bcce3cfb6d7d2 SHA512 53c88741fd4924be2e68c65ad1f7ab11092776b3f1ea019d0f133a45d60dbfed5abbac0f04b49254661463f94f430d3ff41c01a97fb8e28349f202232e286718
MISC metadata.xml 1148 BLAKE2B bd532eb47b00da1ff18e9bb5be287ef32136412fd7542e92a522c9d3d9d9663d2312b74fd2fc6d4239e4fc581c8e881ac6e682fcfd14b0debb08210237878398 SHA512 a913d7013caece759f2fd36f8814589a512e7650afca19edf444694b1fceeeda02f0bffb4ced81a46a376b2d6d54b292257a236549418aecf20d99e70715babb
diff --git a/dev-python/scipy/scipy-1.9.3.ebuild b/dev-python/scipy/scipy-1.9.3.ebuild
index 18e8c08b3222..7c62ef8bb35f 100644
--- a/dev-python/scipy/scipy-1.9.3.ebuild
+++ b/dev-python/scipy/scipy-1.9.3.ebuild
@@ -62,6 +62,7 @@ RDEPEND="
BDEPEND="
dev-lang/swig
>=dev-python/cython-0.29.18[${PYTHON_USEDEP}]
+ >=dev-python/meson-python-0.11[${PYTHON_USEDEP}]
dev-python/pybind11[${PYTHON_USEDEP}]
>=dev-util/meson-0.62.2
dev-util/patchelf
@@ -70,10 +71,6 @@ BDEPEND="
fortran? ( dev-python/pythran[${PYTHON_USEDEP}] )
test? ( dev-python/pytest-xdist[${PYTHON_USEDEP}] )"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.9.9999-meson-options-lapack.patch
-)
-
EPYTEST_DESELECT=(
linalg/tests/test_decomp.py::TestSchur::test_sort
linalg/tests/test_solvers.py::test_solve_discrete_are
@@ -90,9 +87,11 @@ src_unpack() {
}
python_configure_all() {
- # workaround stupid numpy distutils overrides, indirectly via pythran
- export SETUPTOOLS_USE_DISTUTILS=stdlib
export SCIPY_USE_PYTHRAN=$(usex fortran 1 0)
+ DISTUTILS_ARGS=(
+ -Dblas=blas
+ -Dlapack=lapack
+ )
}
python_test() {
diff --git a/dev-python/scipy/scipy-1.9.9999.ebuild b/dev-python/scipy/scipy-1.9.9999.ebuild
index 6396c461e4e3..b85e9495ebc9 100644
--- a/dev-python/scipy/scipy-1.9.9999.ebuild
+++ b/dev-python/scipy/scipy-1.9.9999.ebuild
@@ -62,6 +62,7 @@ RDEPEND="
BDEPEND="
dev-lang/swig
>=dev-python/cython-0.29.18[${PYTHON_USEDEP}]
+ >=dev-python/meson-python-0.11[${PYTHON_USEDEP}]
dev-python/pybind11[${PYTHON_USEDEP}]
>=dev-util/meson-0.62.2
dev-util/patchelf
@@ -70,10 +71,6 @@ BDEPEND="
fortran? ( dev-python/pythran[${PYTHON_USEDEP}] )
test? ( dev-python/pytest-xdist[${PYTHON_USEDEP}] )"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.9.9999-meson-options-lapack.patch
-)
-
EPYTEST_DESELECT=(
linalg/tests/test_decomp.py::TestSchur::test_sort
linalg/tests/test_solvers.py::test_solve_discrete_are
@@ -90,9 +87,11 @@ src_unpack() {
}
python_configure_all() {
- # workaround stupid numpy distutils overrides, indirectly via pythran
- export SETUPTOOLS_USE_DISTUTILS=stdlib
export SCIPY_USE_PYTHRAN=$(usex fortran 1 0)
+ DISTUTILS_ARGS=(
+ -Dblas=blas
+ -Dlapack=lapack
+ )
}
python_test() {