summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-04 21:18:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-04 21:18:29 +0100
commit32a5c8c13e8f1f27cde72c03c7a519c5e8a74b0b (patch)
tree09d01669ad88d76c613f1e845c310b53bd3488ce /dev-python
parent2273b13517c999048fff4aa7714d14415478de1d (diff)
gentoo auto-resync : 04:08:2023 - 21:18:29
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin266835 -> 266842 bytes
-rw-r--r--dev-python/iminuit/Manifest2
-rw-r--r--dev-python/iminuit/iminuit-2.23.0.ebuild4
-rw-r--r--dev-python/m2crypto/Manifest2
-rw-r--r--dev-python/m2crypto/m2crypto-0.38.0.ebuild72
-rw-r--r--dev-python/snapshottest/Manifest3
-rw-r--r--dev-python/snapshottest/files/snapshottest-0.6.0-py3.12-imp.patch41
-rw-r--r--dev-python/snapshottest/snapshottest-0.6.0.ebuild5
-rw-r--r--dev-python/ujson/Manifest2
-rw-r--r--dev-python/ujson/ujson-5.7.0.ebuild41
10 files changed, 51 insertions, 121 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 97db1d488797..2e53a3b5dd91 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/iminuit/Manifest b/dev-python/iminuit/Manifest
index 2a00d66e3e3c..74e554d17657 100644
--- a/dev-python/iminuit/Manifest
+++ b/dev-python/iminuit/Manifest
@@ -4,5 +4,5 @@ DIST iminuit-2.22.0.tar.gz 2324676 BLAKE2B e45952ee6a7f7b6ef3e1ac570abf167423c59
DIST iminuit-2.23.0.tar.gz 2325309 BLAKE2B 05e94a0604daded06419d41dc6fa61f3aeb621dec1a84fd69d93a2028a990a6cdae72c99c2b184514003695025c70bea22340138f45abb2092775042293d8e92 SHA512 ea0b69722a75e537159fbdbd111eaf48431e0f5c355ef1256f32763873f9dfd3a1a195c45647eb4ca4be2d0532955eb5aa1f6ff43482764d3e566dce4b401305
EBUILD iminuit-2.21.3.ebuild 980 BLAKE2B 2f95e35c5c19b7068b30aa5d5ee118f875fe7562d0d76243c46e51061ede83c6d254c048c652cb40ba48694e887e2353fd251be5090daf6ee3e0a58218f73d3f SHA512 3873a89561036f06478c92051d543345e6d6681d01a499754b3db8693adb2b277be83bcbe4eb38ef1e8fa61dd76add2bd1abba32f53e1a9a0b1d06bbc46f12b8
EBUILD iminuit-2.22.0.ebuild 1123 BLAKE2B 5b5708164e64e309daa2683944bd89a9cf9cec12545a1aa56e2fc93804fc3eb3b3d08f089ae631dd75c04c18ef43226826f9119a2cea31c47ffa2045f2905602 SHA512 b9ef92c660c6fd74cfa9fceacc77ae315a5cc1f443a7c27e3869486a953633931f320534cb37f51decb51dc9eb8b11a886e52b2608491a53a37fe0df2159dd60
-EBUILD iminuit-2.23.0.ebuild 1123 BLAKE2B 5b5708164e64e309daa2683944bd89a9cf9cec12545a1aa56e2fc93804fc3eb3b3d08f089ae631dd75c04c18ef43226826f9119a2cea31c47ffa2045f2905602 SHA512 b9ef92c660c6fd74cfa9fceacc77ae315a5cc1f443a7c27e3869486a953633931f320534cb37f51decb51dc9eb8b11a886e52b2608491a53a37fe0df2159dd60
+EBUILD iminuit-2.23.0.ebuild 1185 BLAKE2B efcb77abfc58221378cb0757da83cd2dc53a515f3834afdb14217213b3bb9a8c10a466ed0afc8e20b29e7e49254ceed4cd638456bfc5c6b50bd2a6b5e8b97bab SHA512 6c735ca3dc4261b0046fd1511be88e3228bdbee9e6d6cb637a61b6abc9624fdf421f28ba8a03e7085e8ac63519db5b612306308a7f6be9ebcca167648906c6df
MISC metadata.xml 494 BLAKE2B c97d7fad530773c29b5e723843f13c8305aa1f011e678ad4e9625181ca633c1dfaa3847cb7b3aa09433b6ce665cbf4eb39fde7f80ead402292bc75bb8442beba SHA512 04413a2cbdc7f6843f89560a519ccdb00bcfcf0c9254e9fff7a8901ed992cd7121ba052191399fd60f76f35e495f84c2297acd0a9a1898d4fbcadb7a60841d99
diff --git a/dev-python/iminuit/iminuit-2.23.0.ebuild b/dev-python/iminuit/iminuit-2.23.0.ebuild
index b8a08320e0b8..5ec527b423af 100644
--- a/dev-python/iminuit/iminuit-2.23.0.ebuild
+++ b/dev-python/iminuit/iminuit-2.23.0.ebuild
@@ -22,7 +22,11 @@ KEYWORDS="~amd64"
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
"
+DEPEND="
+ dev-python/pybind11[${PYTHON_USEDEP}]
+"
BDEPEND="
+ ${BDEPEND}
dev-python/cython[${PYTHON_USEDEP}]
test? (
dev-python/ipython[${PYTHON_USEDEP}]
diff --git a/dev-python/m2crypto/Manifest b/dev-python/m2crypto/Manifest
index 6eef5714d75d..d75163b6e045 100644
--- a/dev-python/m2crypto/Manifest
+++ b/dev-python/m2crypto/Manifest
@@ -1,5 +1,3 @@
-DIST M2Crypto-0.38.0.tar.gz 1241269 BLAKE2B 95433090e08ff72cd2b0779491dc38b89eca159b26812e763b5b8973e3d27249a96d5a2c983b59f414184f64beb8e455dc26979310378db89dd2081741d4d17d SHA512 b1e24e3101ce0dd9f17be4cabeddc2ec0f1228b270d74ef2fb38bae8807c5025b031d0743185f06370786a3dd5c3f42129720534dcff07ea4de3c727613f8d20
DIST M2Crypto-0.39.0.tar.gz 1248372 BLAKE2B f89793b847fae3c51a0ea79c3ba861d26b53fa12b2c8d68c3b3476bb2c944b586e875bea0c4693c213e024024096a06de0734631e546c4284d65fc5494784476 SHA512 5d8210c6204fd71f06d238c5b1fe08dd38d6b8e92db7b1e433a9e4e2fe9af46d6d55df7550716a7d05328fb3c9eed427f015b7d5a1fe33a073f0af15a82ab050
-EBUILD m2crypto-0.38.0.ebuild 1732 BLAKE2B 00095b11d459ac799eeed239fe2f60a2529a1229a7aab1741a3fc3bc320d9abcf57d147114a1bd938a5877ba07aedcea2086289faab451dbb683e070a545388b SHA512 ed3c5decd518a2a9455a07d8e2b26fbc92b84c9c1fd3a00e7cd3e450790b1156c6c40991cbd1d8fdfce8d134ec8016d2957a36c5041d40c2f694ba91701f6b5e
EBUILD m2crypto-0.39.0.ebuild 1678 BLAKE2B e01bc9f506bc78eed153d0db6c57758286bb452587afa343e5eb4a1e6083171d5f2669470420cd9e94fb046a25bed232294b7831c3460091fe9fb7dda363094e SHA512 cc4f71f467c1744d61d23cb18e3f40a32e05b9167ddb57a33a99381cdf6919679e47bfe563acba01a2333e2392f4c4a8ce9ad4daf37380b3fd8d83fcacef5af5
MISC metadata.xml 381 BLAKE2B 9581f2ef53dd3b8bfff3724e91e36733892f9c4331376861ec25cee892d63f69f4f1846e46c40bc5a5045963d91aadcc2cdf70b574bf519557afe72cffab256b SHA512 95cfd7f65c912a520f371f236a49f41b711101f5997b14fa81f027cbcabe4bf6361d1a6f647d0de6e6b7756a2c662f2336c6dea5779d00372aa5b05f0566663d
diff --git a/dev-python/m2crypto/m2crypto-0.38.0.ebuild b/dev-python/m2crypto/m2crypto-0.38.0.ebuild
deleted file mode 100644
index 5566c34aa87f..000000000000
--- a/dev-python/m2crypto/m2crypto-0.38.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 2018-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_EXT=1
-PYTHON_COMPAT=( python3_{9..11} )
-PYPI_NO_NORMALIZE=1
-PYPI_PN="M2Crypto"
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 toolchain-funcs pypi
-
-DESCRIPTION="A Python crypto and SSL toolkit"
-HOMEPAGE="https://gitlab.com/m2crypto/m2crypto https://pypi.org/project/M2Crypto/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test abi_mips_n32 abi_mips_n64 abi_mips_o32"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- >=dev-lang/swig-2.0.9
- test? ( dev-python/parameterized[${PYTHON_USEDEP}] )
-"
-RDEPEND="
- dev-libs/openssl:0=
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_tests setup.py
-
-swig_define() {
- local x
- for x; do
- if tc-cpp-is-true "defined(${x})"; then
- SWIG_FEATURES+=" -D${x}"
- fi
- done
-}
-
-src_prepare() {
- # relies on very exact clock behavior which apparently fails
- # with inconvenient CONFIG_HZ*
- sed -e 's:test_server_simple_timeouts:_&:' \
- -i tests/test_ssl.py || die
- distutils-r1_src_prepare
-}
-
-python_compile() {
- # setup.py looks at platform.machine() to determine swig options.
- # For exotic ABIs, we need to give swig a hint.
- local -x SWIG_FEATURES=
-
- # https://bugs.gentoo.org/617946
- swig_define __ILP32__
-
- # https://bugs.gentoo.org/674112
- swig_define __ARM_PCS_VFP
-
- # Avoid similar errors to bug #688668 for MIPS
- if use abi_mips_n32; then
- swig_define _MIPS_SIM = _ABIN32
- elif use abi_mips_n64; then
- swig_define _MIPS_SIM = _ABI64
- elif use abi_mips_o32; then
- swig_define _MIPS_SIM = _ABIO32
- fi
-
- distutils-r1_python_compile --openssl="${ESYSROOT}"/usr
-}
diff --git a/dev-python/snapshottest/Manifest b/dev-python/snapshottest/Manifest
index f06864e2fea0..35f56b6c988c 100644
--- a/dev-python/snapshottest/Manifest
+++ b/dev-python/snapshottest/Manifest
@@ -1,4 +1,5 @@
+AUX snapshottest-0.6.0-py3.12-imp.patch 1203 BLAKE2B 709dac804fc8bcf6b5fe30ec4ebe8cbf02b5727311f8ffb14ba7e9e1e4b33d542b77b372b91b23bb5c9e20c4a8e87a1674d196d6bb22cb007eef505160df51ba SHA512 41f4524dabc6dc664390818e6e468164aedabb08583948c70d136fd0306b21e909621df752360af7ce42b954b55f3bcfcfdefe178eeb9a5453eabbd1aa106941
AUX snapshottest-0.6.0-remove-fastdiff.patch 1979 BLAKE2B 1645f9fe0d7a5ba9523f81c50f31c54d854d56d3137a8b6611594bb825ccc0c183c763dbf641b1517e45b4ae39979efc86d5fffaa6adc111ee937a8c2f4143b5 SHA512 da43e9d1eb27f66512e5c3f02a0693756ea1e6889c6a9c3871c2f53a80a6ab4cdd7a705cfbe523231b8496a5eca3587c71e57babeec89c653307923c045413df
DIST snapshottest-0.6.0.gh.tar.gz 19887 BLAKE2B d85b3025731dbe80c04388f8adf755f48f428df5f15496ad7e47d436ccfba0f8955833f576b12a38a3565a56deb49a425b67f9040bce69a7711be05558f0ef4e SHA512 7477668c0a61b4c282deb3eb9105cf06e8f644c931e2860a9a60dc2f8ed6de1eaf1ab100a816de200a39db8b488bda6ad33472265eecca707360dcbc9d8fafee
-EBUILD snapshottest-0.6.0.ebuild 919 BLAKE2B 226dde939136888d45340adc6c6cc7b11fe6b938129bfd7cacb8a305a02ce0e104329ceab71bfa026f039e8db8f70ddab4bb8c9b634125f01f4864012cca8c28 SHA512 31b14487d7147b6754559ad68498969f8db858a29c88a5e3b2b166148cad50135eb91d79c5a8d2e277421b6bc225a45557f63cb7dc155f5a29fd4dc00f9925df
+EBUILD snapshottest-0.6.0.ebuild 957 BLAKE2B 3dd5a4137bab0269a7b6781195d2b2862f739e077d53018c97f95c4f1f51c369d2d5dbd707a14a53e069ae46c2b0c0eee45e4a6de2b9518f634fc8593a5fbbf9 SHA512 627be837d04d88cc1481ea0b03f3773724c4036764f624376c9f1a4137d02320a26555e99f7422b417cca56dcba18695f41b0ac55b7f5b39c603d0d8bf0f3d0f
MISC metadata.xml 380 BLAKE2B af864f451c424be42fda967811c0754d246ff7399a14d7344c967e695dd33ed060f9db19823f7f7c3a78f90f45b2817b843dff1832cae24a5c6c3bb6b183c63e SHA512 a755150b8fd1cfae3e016e97cceb9d9e32e58750a7fd01665087fa82ebba1124b38566bf6869898338319532956869a472c50dce9f4ad53f6329e4691197d7b5
diff --git a/dev-python/snapshottest/files/snapshottest-0.6.0-py3.12-imp.patch b/dev-python/snapshottest/files/snapshottest-0.6.0-py3.12-imp.patch
new file mode 100644
index 000000000000..64c1bf69bfe8
--- /dev/null
+++ b/dev-python/snapshottest/files/snapshottest-0.6.0-py3.12-imp.patch
@@ -0,0 +1,41 @@
+https://github.com/syrusakbary/snapshottest/pull/168
+From: MarcellPerger1 <102254594+MarcellPerger1@users.noreply.github.com>
+Date: Tue, 18 Jul 2023 19:28:22 +0100
+Subject: [PATCH] Use importlib instead of imp
+
+--- a/snapshottest/module.py
++++ b/snapshottest/module.py
+@@ -1,7 +1,8 @@
+ import codecs
+ import errno
+ import os
+-import imp
++import sys
++import importlib.util
+ from collections import defaultdict
+ import logging
+
+@@ -17,6 +18,14 @@ def _escape_quotes(text):
+ return text.replace("'", "\\'")
+
+
++def _load_source(module_name, filepath):
++ spec = importlib.util.spec_from_file_location(module_name, filepath)
++ module = importlib.util.module_from_spec(spec)
++ sys.modules[module_name] = module
++ spec.loader.exec_module(module)
++ return module
++
++
+ class SnapshotModule(object):
+ _snapshot_modules = {}
+
+@@ -33,7 +42,7 @@ def __init__(self, module, filepath):
+
+ def load_snapshots(self):
+ try:
+- source = imp.load_source(self.module, self.filepath)
++ source = _load_source(self.module, self.filepath)
+ # except FileNotFoundError: # Python 3
+ except (IOError, OSError) as err:
+ if err.errno == errno.ENOENT:
diff --git a/dev-python/snapshottest/snapshottest-0.6.0.ebuild b/dev-python/snapshottest/snapshottest-0.6.0.ebuild
index 939e60178153..d01d038c7f3c 100644
--- a/dev-python/snapshottest/snapshottest-0.6.0.ebuild
+++ b/dev-python/snapshottest/snapshottest-0.6.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -30,7 +30,8 @@ RDEPEND="
distutils_enable_tests pytest
PATCHES=(
- "${FILESDIR}/snapshottest-0.6.0-remove-fastdiff.patch"
+ "${FILESDIR}/${PN}-0.6.0-remove-fastdiff.patch"
+ "${FILESDIR}/${PN}-0.6.0-py3.12-imp.patch"
)
python_prepare_all() {
diff --git a/dev-python/ujson/Manifest b/dev-python/ujson/Manifest
index 234e795ac330..7e515dba21d8 100644
--- a/dev-python/ujson/Manifest
+++ b/dev-python/ujson/Manifest
@@ -1,5 +1,3 @@
-DIST ujson-5.7.0.tar.gz 7152625 BLAKE2B 363fd77be3e2f8fb42a70db744ab4da12c0c8383103983b3555cee237497837abfcef102b19a51c0fa118fedd7847c568607c058f1d2cea76858a6bd89a226da SHA512 e18a1608a7fe79030e3ff307c9e95a0e238cd5049ee791eddbc07efa55853475d053268b80a8765023639ae8ff39f82b4ae2c04e82fc7dc5f3192a5134ec0757
DIST ujson-5.8.0.tar.gz 7154530 BLAKE2B 8eef1b2e03fa4a99dccc9d5fba8c1436d8e11b419e7f4c8d382bf5a2250477c99a1f0ff7f9e548ca5a50217a5964dafc953ab3cdb66b784ef1dea129ec1c2b6a SHA512 258e5527bda8b9fb3bea03f97d5db752ae06183337610975fc28f928817b430ae7a1867932ee7b0a0ccd6b825e2c5a104d7ce78c1e3405ed5679a2a70a5804c3
-EBUILD ujson-5.7.0.ebuild 870 BLAKE2B be432902027c94b24be183abb5c1d3f634a30dc2a5b472aeaa85f076ed776cf86b879a41abdce13232d8f2cb1939a72657a98b0868278596ac894bfc49e08358 SHA512 67f96e466cfecbb96e780106c28d047ba2ee4c945eaff611651ec0622688bf4756c262420191590913b45a985a15b3f74c5d8b49268377056688c7d9258526a8
EBUILD ujson-5.8.0.ebuild 870 BLAKE2B be432902027c94b24be183abb5c1d3f634a30dc2a5b472aeaa85f076ed776cf86b879a41abdce13232d8f2cb1939a72657a98b0868278596ac894bfc49e08358 SHA512 67f96e466cfecbb96e780106c28d047ba2ee4c945eaff611651ec0622688bf4756c262420191590913b45a985a15b3f74c5d8b49268377056688c7d9258526a8
MISC metadata.xml 494 BLAKE2B 8e20150926d62643e7ff2110cba22313db0c0e3112290ce08302d57103aa35c42a56921d0b46e0acca2ef83756eb4f7384f23ddb06fe41ef6c4a28921f11ec33 SHA512 d9c0a59f916b84d50e51a21152c1815fea90a909dc9bd44ea620b2a33ca6a92ee237aafe29debcc9d1a2bf63c84112300845309eb0ab1265e5d2b0c05dd313f0
diff --git a/dev-python/ujson/ujson-5.7.0.ebuild b/dev-python/ujson/ujson-5.7.0.ebuild
deleted file mode 100644
index 5b398600743f..000000000000
--- a/dev-python/ujson/ujson-5.7.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Ultra fast JSON encoder and decoder for Python"
-HOMEPAGE="
- https://github.com/ultrajson/ultrajson/
- https://pypi.org/project/ujson/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-
-DEPEND="
- dev-libs/double-conversion:=
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytz[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_configure() {
- export UJSON_BUILD_DC_INCLUDES="${EPREFIX}/usr/include/double-conversion"
- export UJSON_BUILD_DC_LIBS="-ldouble-conversion"
- export UJSON_BUILD_NO_STRIP=1
-}