summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-08 06:56:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-08 06:56:53 +0000
commit1fbaf1314579f2155166bebd1ddfe6131d400807 (patch)
treeb034ac67fab73c50b138ed5a57e5823cda058299 /dev-python
parentf50726afc610727258a31ddfa8b3b32639b20a10 (diff)
gentoo auto-resync : 08:01:2024 - 06:56:53
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin269047 -> 269040 bytes
-rw-r--r--dev-python/Nuitka/Manifest2
-rw-r--r--dev-python/Nuitka/Nuitka-1.9.7.ebuild52
-rw-r--r--dev-python/colorful/Manifest2
-rw-r--r--dev-python/colorful/colorful-0.5.6.ebuild30
-rw-r--r--dev-python/pycollada/Manifest2
-rw-r--r--dev-python/pycollada/pycollada-0.8.ebuild53
7 files changed, 141 insertions, 0 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 56b15562ffea..0e96891a3091 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index fe7865d87c62..daa0a94b5123 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,5 +1,7 @@
DIST Nuitka-1.9.5.tar.gz 3911838 BLAKE2B 064ad4aa48d94b4eb7c886d445e7228c72d03dcb22e75e82a7c43b42a20a32f1b11855017f72101e54c45b4591ffd2af0912191eb7f13367f16726208308a6de SHA512 8b8bc0ec0f4666ae63bd4cb3463c6321bd1cbde7a64ca37d500bd2e60d50f6a13aca5dc89a101d7b8e39622e21091b24232ecf8361b4ae9a9913c187742c7607
DIST Nuitka-1.9.6.tar.gz 3914776 BLAKE2B 82a50f642f8b93caa725bbfffa6236d490ccb8d731ea917886d0cde03aa6c2237f6c8ff7687ad3140c985cc7c5b525e16aaf07bd604232e32b7fa0fb102a00f5 SHA512 005be29f72685677da1e037b36381765c1248bc2940eb92a46e8e5df990f0241af831b8cf28ab2957d3a7d3d0cb03c2b99ab5af4e900afba53b5ac60e95d1a24
+DIST Nuitka-1.9.7.tar.gz 3916330 BLAKE2B df269672d0c7b860a0aebf0cd9f321442344c69e1ea8ccaad193a835b11ca6cfe048179d3ab03a616525aa022327e168c48406c733354ed13c07c49e26cb0bb8 SHA512 71ce5ef929489ce7a72a2b62b7106dee35380b0d185788e105044cab6448d9c3470e3d783c71a9796404038b8035019816553a360a62d868cfc870675b3bb384
EBUILD Nuitka-1.9.5.ebuild 1115 BLAKE2B 71600bcba8ba9422125dc6e145f919853e241a089aa855beb488ccb72bd3d5490ad4b986e1616dc4ac099023d88ee1fcbaf7efd5a84ad1f74ce17672efc7fff7 SHA512 28485d128e06c298f4aa512cf455dd38fe6dc34dce424246bb8bc69d531274158e377631b96c82cccea29a03492721a2bb71791ad2bbb4765475972347ea18ab
EBUILD Nuitka-1.9.6.ebuild 1115 BLAKE2B 71600bcba8ba9422125dc6e145f919853e241a089aa855beb488ccb72bd3d5490ad4b986e1616dc4ac099023d88ee1fcbaf7efd5a84ad1f74ce17672efc7fff7 SHA512 28485d128e06c298f4aa512cf455dd38fe6dc34dce424246bb8bc69d531274158e377631b96c82cccea29a03492721a2bb71791ad2bbb4765475972347ea18ab
+EBUILD Nuitka-1.9.7.ebuild 1115 BLAKE2B 3348a3c3ddb788d8bd8dd55fb63ccc72340cc63e4f1e3265e92abb2e84fc50dc36d34cb95bf0c143775ff27b3104f2a9b5fc06c712cc7b0a850d6b66f65d7c85 SHA512 8044ca9ef3dfb6b1ce9c49f08a75219263a5bad3766e9f11ef80aa71114124bf5ab04121e72f90acb9998dff866e54ef73aa0b1e43b0270dea804e84ae61d899
MISC metadata.xml 943 BLAKE2B d7ab883773e7480dcfb4b79932a3874e2274669169a24a54aa622a2a0ac079e0296da4bd196d166cb11fcff785985da0b10d0fae351032914ccf312c9bb9833c SHA512 625d8760b8e849c6e014856f584cb42f50bb5ebb1fa648cb704a5a1baf175e7d2ce9f43f6f724d11c81a68e364b6ac1c38459540b58f2ccd6a675902af5b1cc9
diff --git a/dev-python/Nuitka/Nuitka-1.9.7.ebuild b/dev-python/Nuitka/Nuitka-1.9.7.ebuild
new file mode 100644
index 000000000000..55247b1bdeb0
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.9.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}
diff --git a/dev-python/colorful/Manifest b/dev-python/colorful/Manifest
index 6ce32b11c6a4..3af67c5a6621 100644
--- a/dev-python/colorful/Manifest
+++ b/dev-python/colorful/Manifest
@@ -1,3 +1,5 @@
DIST colorful-0.5.5.gh.tar.gz 366498 BLAKE2B a7ab5dfb7ddfbf6682b75d2ed35f3f4cb7c3826918742316d877a17cb58e639b5fa86d7906be4879e89a5a0e78a16ede7535ade3f9f890c67bfcf42a0d1c9d9c SHA512 dc5e372261bd308a82bd0446a885b4c63a5a5781540731407f1a364d2c5397fe950f96fef3be8ffeab80cf02010be9551ba5b8550930e3fed5173cdc28a69306
+DIST colorful-0.5.6.gh.tar.gz 366563 BLAKE2B b2c1b9b12bc5de69465ffaca9178c5ac56e0026b0ef732ab4a3a82286fd16141ec3ca397625fd00a3d041de41b34baadf1aacb185089ab0e8d5efddb7363418a SHA512 265e36c73a7ec183e4fd87d3db718b1bae353a99185eb4b1b5e057a6eda502b65672a3f0f9a569c76e6bf9342a1e2ee47fd2f4a8eaa08585f9806aa75c850661
EBUILD colorful-0.5.5.ebuild 938 BLAKE2B 4278e1209cda1abdc590e37c1e760eef3c6ae06dda36ea8e21740a6c4d3a13727d4d6201205ae4cfec9e4115767e9e49c1bccb3f1590ebe5a0c53dc1021bfcba SHA512 34ce08bf61439b997229d5add59574699d5e43fd18dc69959e33c2a7c058846dd80460c817f86d8d1688d94856027dc0f06703c252da2aadcc02f74314477dea
+EBUILD colorful-0.5.6.ebuild 605 BLAKE2B 91f0f66bb85eece1c772e1f101e9b32e9e0bc527e5e73ce131c2f671b1bbea0ebdaae0c5130f0eb23610af34536ebce3a2c073617f05cdb862774c6cc74c4585 SHA512 bca45aa32bc1dd3469725c4e29da67adf5b21076600e1cbce93a5874fe699876326317fec5918c8e10a6364761107998171e10bad963416871361b74ebcbf1f1
MISC metadata.xml 828 BLAKE2B 68b782b4eca8e5c0bc591081526933afad4d81d53fb0af3d1b1edf0bb9df8ae59f6448da15fc82abe83906db8a76ea69b898d04767fd0d98730d0dafaf65c4c9 SHA512 4ffb104301f58d5ce9a9ea2614b74f1b3caf28f37f319738a9f1ddb1c1da4537b82c95de5fb7ba77a39c54ba96125d9d1b3dd11e0e98bc6b7c802e5cd5057339
diff --git a/dev-python/colorful/colorful-0.5.6.ebuild b/dev-python/colorful/colorful-0.5.6.ebuild
new file mode 100644
index 000000000000..55d9fa2e9996
--- /dev/null
+++ b/dev-python/colorful/colorful-0.5.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Terminal string styling done right, in Python"
+HOMEPAGE="
+ https://pypi.org/project/colorful/
+ https://github.com/timofurrer/colorful/
+"
+SRC_URI="
+ https://github.com/timofurrer/colorful/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -s
+}
diff --git a/dev-python/pycollada/Manifest b/dev-python/pycollada/Manifest
index 0df738be1bb4..1df719871aca 100644
--- a/dev-python/pycollada/Manifest
+++ b/dev-python/pycollada/Manifest
@@ -1,3 +1,5 @@
DIST pycollada-0.7.2.gh.tar.gz 3526845 BLAKE2B 3d8b4d2478fa4937756db69afbd8716ccd2dd4e0bec8e7dc045e84f06573605c0872d31bdee3d6ccca4b800699746877530f2fa81b5790c3f5c0cb3e7583fa66 SHA512 5c21155d52d54de62d192d4da0385bc7110ddd3962fe3e0e9e5904bbcd0e66cb1a95765c9996cdc5beef0edb30ee2123ae23b904d029be1c119e902d2fc4e7fe
+DIST pycollada-0.8.gh.tar.gz 3586706 BLAKE2B 533a2a309b4c7ee60671edfd241b80e7128330b2cd85d2707fc4f83b0aceb2d792d8efec77f9a6a8600eec0704878a4342449fde68f77e42617eff30965973a5 SHA512 7171469b8434a7c24ec2ebadefa9ad5268382659cb5b2b3712cf0ba73c7948e7fa4061ecfa02001862c76e1139293ab68cf425472222348e28efa28bc75f844f
EBUILD pycollada-0.7.2-r1.ebuild 1120 BLAKE2B 1d015ef90b31153e9decb783eb65665ef4ff1baa14dfde1ed0d7aa447ca2c4fb2224a932b8025e2a1e4c7b6030dce2682d2113fbcb8977b73a64d877e3cabefc SHA512 fdcaadc07719b67a7a812d981cbf5b82b6843bd45575d2fd3c702e1d09a46a49fc70df0dae8c68512b09b4ad253320bea8139acea63420930ec8030de5d22190
+EBUILD pycollada-0.8.ebuild 1122 BLAKE2B fb5a2e05f1bd368da154a4926d4fbad60509fc5187810830408b7877791ac6f4cac5f310785dbb9d7eb97b6eba659512785cfbfca1d78cc2e3ae6e9a19415855 SHA512 dd342296f6cc19b3e7e8930f6ccf4570b37607f19a148b979c34ce5f530c1b06fe4b4f0e5230e30b04f3803114db5abde8ab700178c24f40b4112b93c4055dce
MISC metadata.xml 905 BLAKE2B 9e1283685c76cd27ff971ab68ef51f56cf296aa44fe3dbb5bf74a3e6b4ea69abb927603acc16747bd1bf8db906b4437cf792330df5e7803a211b1699a01034d3 SHA512 686ffa6bb798bd4387106cdb461f0abdc2a685c53c4552c95c86febd6789e4b323ae1ac9717109fea96287ac100a93b33e3ce37eea37e6de3e4f4e704e40e9e8
diff --git a/dev-python/pycollada/pycollada-0.8.ebuild b/dev-python/pycollada/pycollada-0.8.ebuild
new file mode 100644
index 000000000000..396c0f814d49
--- /dev/null
+++ b/dev-python/pycollada/pycollada-0.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing COLLADA documents"
+HOMEPAGE="
+ https://pycollada.readthedocs.io/
+ https://github.com/pycollada/pycollada/
+ https://pypi.org/project/pycollada/
+"
+SRC_URI="
+ https://github.com/pycollada/pycollada/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.2[${PYTHON_USEDEP}]
+"
+
+DOCS=( AUTHORS.md COPYING README.markdown )
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest
+
+python_install_all() {
+ if use examples ; then
+ insinto /usr/share/${PF}/
+ doins -r examples
+ fi
+
+ distutils-r1_python_install_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # ensure data files for tests are getting installed too
+ python_moduleinto collada/tests/
+ python_domodule collada/tests/data
+}